Cmake prob. ZLIB missing - found 1.2.7

Forum for questions and support relating to the 1.27.x releases only.
Post Reply
liderbug
Posts: 123
Joined: Wed Dec 19, 2007 4:46 pm

Cmake prob. ZLIB missing - found 1.2.7

Post by liderbug » Sun May 18, 2014 2:24 pm

FC19
cmake
-- Could NOT find ZLIB (missing: ZLIB_LIBRARY) (found version "1.2.7")
-- Could NOT find CURL (missing: CURL_LIBRARY) (found version "7.29.0")

What version is it looking for 1.2. 6 or 8?

Thanks
---------------------------
Next day - what I want to do is RTSP. I'm running 25, and have ffmpeg installed but the logs say "You must have ffmpeg libraries installed to use remote camera protocol 'rtsp' for monitor 3". What have I missed?

Thanks

mastertheknife
Posts: 678
Joined: Wed Dec 16, 2009 4:32 pm
Location: Israel

Re: Cmake prob. ZLIB missing - found 1.2.7

Post by mastertheknife » Mon May 19, 2014 4:53 am

Hi,

This looks like a bug within cmake, but no fear, zlib and curl are not required dependencies, so you should have no problems continuing the installation.
Kfir Itzhak.

liderbug
Posts: 123
Joined: Wed Dec 19, 2007 4:46 pm

Re: Cmake prob. ZLIB missing - found 1.2.7

Post by liderbug » Mon May 19, 2014 2:41 pm

Thanks - when I ran make
and it errored out with:

In file included from src/zm_event.cpp:34:0:
src/zm_mpeg.h:43:7: error: use of enum ‘PixelFormat’ without previous declaration
enum PixelFormat pf;
src/zm_mpeg.h:44:2: error: ‘AVOutputFormat’ does not name a type
AVOutputFormat *of;
AVFormatContext *ofc;
AVStream *ost;
AVFrame *opicture;
AVFrame *tmp_opicture;

So now what am I missing?

Thanks

Let me add, all I'm trying to do is get rtsp working - I have 25 installed now.

liderbug
Posts: 123
Joined: Wed Dec 19, 2007 4:46 pm

Re: Cmake prob. ZLIB missing - found 1.2.7

Post by liderbug » Tue May 20, 2014 2:22 pm

I found this: zoneminder-1.27.0-1.fc19.x86_64.rpm but haven't been able to install it.
error: Failed dependencies:
libmysqlclient.so.1018
perl(LWP::Protocol::https)
perl(X10::ActiveHome)

So with help from the Fedora Forum I did yum localinstall. Which ran better until:
Error: Package: zoneminder-1.27.0-1.fc19.x86_64 (/zoneminder-1.27.0-1.fc19.x86_64)
Requires: perl(X10::ActiveHome)

and after searching the web I (think) found it - for Mageia.

Again: All I want to do is: rtsp://cam.... RPM errors out, cmake/make errors out. VLC works fine - but it doen't detect/record like ZM

Please help.

---------------------
Edit:

was able to install 27 --> http://www.zoneminder.com/forums/viewto ... =9&t=21400 although it could have gone smoother

Also: functions.php needs to have
"date_default_timezone_set('MST7MDT');"
added to the beginning of the file.
and zmupdate.pl needed to be run.

now...
Unable to get RTP Info identifier from response 'RTSP/1.0 200 OK Server: H264DVR 1.0 cseq: 3 Range: npt=now- Session: 33863030 '
but that'll be nuder post.


SOLVED: see: http://www.zoneminder.com/forums/viewto ... 29&t=22256

Post Reply

Who is online

Users browsing this forum: No registered users and 3 guests