New ZM Install on Ubuntu 13:10?

Forum for questions and support relating to the 1.27.x releases only.
Post Reply
Posts: 1
Joined: Sun Mar 30, 2014 7:26 pm

New ZM Install on Ubuntu 13:10?

Post by jarrah » Sun Mar 30, 2014 8:14 pm

I'd like to perform a ZM install on Ubuntu 13:10, but having seen the following warning in the ppa it put me off until more research could be done.
ZoneMinder currently does not work on 13.10 or newer, due to mysql support in PHP being deprecated.
This wiki page indicates it may be possible to have ZM working on 13:10 ... on_changes

Also looking at the GitHub source code, Isaac authored some changes from the 'mysql2PDO' branch. The Ubuntu 12:04 change log said:
+zoneminder (1.27.1-1) precise; urgency=low
+ * Convert from php mysql ext to PDO
Does this imply that I could compile ZM from source on my Ubuntu 13:10 and it'll work?

Would I be better off waiting for 1.27.1 to be released as a ppa due to all the benefits that gives? If so how long are you looking at until it's released please?


Posts: 2660
Joined: Mon Mar 26, 2012 11:40 am
Location: Pennsylvania

Re: New ZM Install on Ubuntu 13:10?

Post by bbunge » Fri Apr 04, 2014 1:29 am

Well, 1.27 is on the PPA. Works well on 12.04. Also have installed it on 13.04 then upgraded to 13.10 and it worked! ... e_easy_way

Posts: 61
Joined: Sat Jul 23, 2011 1:15 am

Re: New ZM Install on Ubuntu 13:10?

Post by windracer » Wed Apr 09, 2014 11:42 pm

I'm also running on 13.10 but have had ZM installed for a while so have just been doing upgrades and not a clean install.

Posts: 16
Joined: Fri Jun 10, 2011 11:58 pm

Re: New ZM Install on Ubuntu 13:10?

Post by hans109h » Sat Apr 12, 2014 12:18 am

Here is my experience with 1.27 on Ubuntu 13.10 building from source:

The week 1.27 was released I had 1.26.5 up and running.

I cloned the 1.27 master from github and merged the mysql2PDO branch into it.

I used the cmakecacheimport script to generate a cache file then used cmake to build the package using this command:

Code: Select all

cmake -C zm_conf.cmake . -DZM_CGIDIR="/usr/lib/cgi-bin" -DZM_CONTENTDIR="/media/JW_2TB_1/zm" -DZM_PERL_SUBPREFIX="/usr/share/perl5" -DCMAKE_INSTALL_PREFIX="/usr" -DCMAKE_VERBOSE_MAKEFILE=ON
when I tried to make the build I got the following error:

Code: Select all

Only one of PREFIX or INSTALL_BASE can be given. Not both.
make[2]: *** [scripts/ZoneMinder/CMakeFiles/zmperlmodules] Error 255
make[1]: *** [scripts/ZoneMinder/CMakeFiles/zmperlmodules.dir/all] Error 2
make: *** [all] Error 2
I was able to get around this by running make as root.

I then installed it and got ZM up and running after using to upgrade the db.

I was able to view monitors and motion detection was working but I noticed that the events were not being listed on the main index page. This has since been solved as reported here:

By this time the Iconnor branch had merged the mysql2PDO fix into it so I decided to checkout the Iconnor branch and build it the same way, however cmake failed do to undefined functions relating to something called Fifostream:: which I couldn't find any information on. I'm guessing I'm missing a dependency.

I then attempted to once again build the master with mysql2PDO and the commit to fix the event listings. I was able to make and install, however none of my monitors would display.

The logs showed zm not being able to access shared memory, and a whole bunch of socket_sento errors and sock files not being found. I tried all the fixes for these types of errors list on the internet but had no luck getting around them.

I've resorted to reverting back to 1.26.5 for the time being, which using the same cmake command to configure works perfectly. Not sure where to go from here, but plan on continuing to try to build 1.27 and get it running.


Posts: 16
Joined: Fri Jun 10, 2011 11:58 pm

Re: New ZM Install on Ubuntu 13:10?

Post by hans109h » Sat Apr 12, 2014 12:50 am

Ok, no I feel silly for wasting time posting above. Here's what I just did:

Code: Select all

$git pull
$git checkout mysql2PDO
$git commit -a -m 'merge PDO'
$git checkout master
$git merge mysql2PDO
$cmake -DZM_CGIDIR="/usr/lib/cgi-bin" -DZM_CONTENTDIR="/media/JW_2TB_1/zm" -DZM_PERL_SUBPREFIX="/usr/share/perl5" -DCMAKE_INSTALL_PREFIX="/usr" -DCMAKE_VERBOSE_MAKEFILE=ON
$sudo make
$sudo make install
I ran into errors here because my monitors table had already been upgraded for 1.27 so I had to comment line 16 and 17 out of ../db/zm_update-1.27.0.sql.

Started up zoneminder and everything is working as expected. I hope this helps someone.


Post Reply

Who is online

Users browsing this forum: No registered users and 2 guests