Filters Date/time

Forum for questions and support relating to the 1.26.x releases only.
Post Reply
otv5125
Posts: 3
Joined: Fri May 20, 2016 7:31 am

Filters Date/time

Post by otv5125 » Fri May 20, 2016 7:34 am

Hello!
I have a problem with zoneminder server filters.
Exactly, "Date/Time" filter has preset to "less than or equal to" with value of "-20 days". "Delete all matches" checked on. After "submit" command activation, all records (events) to be deleted are listed correctly, but "Execute" command activation results in nothing. All records (events) are untouched.
Log messages, applied to "filters" contain the following error messages "Error parsing date/time '-20 days', skipping filter '20 days qq'". The screenshots attached to this mail message.
Thanks in advance.
Attachments
unnamed (1).png
unnamed (1).png (11.78 KiB) Viewed 7641 times
unnamed.png
unnamed.png (38.75 KiB) Viewed 7641 times

bbunge
Posts: 2403
Joined: Mon Mar 26, 2012 11:40 am
Location: Pennsylvania

Re: Filters Date/time

Post by bbunge » Fri May 20, 2016 12:13 pm

Hope you can see the image of my purge filter
purge.jpg
purge.jpg (39.13 KiB) Viewed 7630 times

otv5125
Posts: 3
Joined: Fri May 20, 2016 7:31 am

Re: Filters Date/time

Post by otv5125 » Sat May 21, 2016 6:46 am

Error
Attachments
67.PNG
67.PNG (57.28 KiB) Viewed 7602 times

Gary S
Posts: 40
Joined: Sun Feb 10, 2008 2:39 pm
Location: Bismarck, ND

Re: Filters Date/time

Post by Gary S » Sat May 21, 2016 11:02 am

The only significant difference I see between mine and yours is that yours is set to "Date" and mine is set to "Date/Time". Mine works.

ac7ss
Posts: 4
Joined: Wed Mar 05, 2014 3:55 pm

Re: Filters Date/time

Post by ac7ss » Tue May 24, 2016 4:38 pm

Same trouble here. Perhaps a script or tool needs to be installed?
ImageImage

ac7ss
Posts: 4
Joined: Wed Mar 05, 2014 3:55 pm

Re: Filters Date/time

Post by ac7ss » Fri Jun 17, 2016 11:34 pm

I found a solution, instead of using "-20 days" (Which does work in a view), use "20 days ago" as this seems to parse just fine.

otv5125
Posts: 3
Joined: Fri May 20, 2016 7:31 am

Re: Filters Date/time

Post by otv5125 » Sat Oct 29, 2016 4:48 pm

ac7ss wrote:I found a solution, instead of using "-20 days" (Which does work in a view), use "20 days ago" as this seems to parse just fine.
Thank you, this filter work!

steelskin
Posts: 2
Joined: Thu Oct 16, 2014 8:20 pm

Re: Filters Date/time

Post by steelskin » Tue Jan 17, 2017 7:02 pm

I had the same problem, "-20 days" works when you use the submit button in filter but it isn't parsed by the background daemon. ie I get the filter -20 days unable to parse error.

As was mentioned above using 20 days ago worked for me too in both the submit & daemon. :D

I'm using zoneminder 1.30.0.

Post Reply

Who is online

Users browsing this forum: No registered users and 3 guests