Iinstall of 1.26 gets 1.25?

Forum for questions and support relating to the 1.26.x releases only.
Post Reply
mrd
Posts: 245
Joined: Wed Apr 26, 2006 12:39 am
Location: Boston USA

Iinstall of 1.26 gets 1.25?

Post by mrd » Wed Aug 06, 2014 1:47 am

I tried to follow these fresh install instructions and ended up with 1.25?

http://www.zoneminder.com/wiki/index.ph ... e_easy_way

I also tried the 1.27 version of instructions. If I follow the process without adding the ppa, I end up with 1.26?

Any help would be appreciated!
MRD

User avatar
iconnor
Posts: 828
Joined: Fri Oct 29, 2010 1:43 am
Location: Toronto
Contact:

Re: Iinstall of 1.26 gets 1.25?

Post by iconnor » Wed Aug 06, 2014 11:21 pm

are you sure you are running 12.04?

mrd
Posts: 245
Joined: Wed Apr 26, 2006 12:39 am
Location: Boston USA

Re: Iinstall of 1.26 gets 1.25?

Post by mrd » Wed Aug 06, 2014 11:48 pm

Pretty sure :?

root@system-z:~# lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 12.04.5 LTS
Release: 12.04
Codename: precise
root@system-z:~# uname -a
Linux system-z 3.0.35-cm-fx6-5.5 #721 SMP Sun Mar 23 14:12:17 IST 2014 armv7l armv7l armv7l GNU/Linux
MRD

mrd
Posts: 245
Joined: Wed Apr 26, 2006 12:39 am
Location: Boston USA

Re: Iinstall of 1.26 gets 1.25?

Post by mrd » Wed Aug 06, 2014 11:50 pm

The only odd thing about the system is that the OS is slightly customized for the Utilite Pro that it is running on, but I think the only difference is firmware related.
MRD

User avatar
iconnor
Posts: 828
Joined: Fri Oct 29, 2010 1:43 am
Location: Toronto
Contact:

Re: Iinstall of 1.26 gets 1.25?

Post by iconnor » Thu Aug 07, 2014 12:18 am

Interesting.

I suppose it's possible that they have updating the zm package in 12.04 like they have in later releases, but with my ppa active you should be running 1.27.0-precise-2

I'll build a package of our master branch which will soon be 1.28 for 12.04.

maybe you'd like to give it a try.

mrd
Posts: 245
Joined: Wed Apr 26, 2006 12:39 am
Location: Boston USA

Re: Iinstall of 1.26 gets 1.25?

Post by mrd » Thu Aug 07, 2014 12:24 am

I'm happy to try anything at this point. I really want to be on as recent of a release as possible.
MRD

mrd
Posts: 245
Joined: Wed Apr 26, 2006 12:39 am
Location: Boston USA

Re: Iinstall of 1.26 gets 1.25?

Post by mrd » Fri Aug 08, 2014 1:28 pm

FYI...
Turns out I was mistaken about the base package that I get with a clean 12.04 install. It is 1.25.
MRD

bbunge
Posts: 2441
Joined: Mon Mar 26, 2012 11:40 am
Location: Pennsylvania

Re: Iinstall of 1.26 gets 1.25?

Post by bbunge » Sun Aug 17, 2014 1:16 pm

If you want the latest "stable" version use:
http://www.zoneminder.com/wiki/index.ph ... e_easy_way

This will give you ZM 1.26.5 on Ubuntu 14.04. Guaranteed to work if you install a fresh copy of Ubuntu Server or Desktop.

If you want to work with the lasted version of 1.27.X see:
http://www.zoneminder.com/forums/viewto ... 31&t=22477

It is also possible to upgrade the 1.26.5 on Ubuntu 14.04 to 1.27.??? by adding the PPA repository. Just did that this morning and am getting ready to write up my procedure. Stay Tuned!

bb

mrd
Posts: 245
Joined: Wed Apr 26, 2006 12:39 am
Location: Boston USA

Re: Iinstall of 1.26 gets 1.25?

Post by mrd » Sun Aug 17, 2014 1:22 pm

Thanks but I am stuck with Ubuntu 12.04 so I am hopong for a way to get the latest version on that release.
MRD

bbunge
Posts: 2441
Joined: Mon Mar 26, 2012 11:40 am
Location: Pennsylvania

Re: Iinstall of 1.26 gets 1.25?

Post by bbunge » Sun Aug 17, 2014 2:06 pm

http://www.zoneminder.com/wiki/index.ph ... e_easy_way

And why are you stuck with 12.04?

Edit: Well, this is a real bummer! I tried to do an install as cited above and 12.04 is not allowing me to add the repository because python-pycurj is missing... Back to 14.04 I guess and will not mess with older versions as obsolesce really strikes them hard!!!

bb

bbunge
Posts: 2441
Joined: Mon Mar 26, 2012 11:40 am
Location: Pennsylvania

Re: Iinstall of 1.26 gets 1.25?

Post by bbunge » Mon Aug 18, 2014 12:01 am

Become root:

sudo su
First, get rid of your current Zoneminder:
apt-get remove
apt-get purge

Add repository
apt-get install python-software-properties
add-apt-repository ppa:iconnor/zoneminder-master
apt-get update

Install Zoneminder
apt-get install zoneminder libvlc-dev libvlccore-dev vlc

ln -s /etc/zm/apache.conf /etc/apache2/conf.d/zoneminder.conf

/etc/init.d/apache2 force-reload

adduser www-data video

Add delay to allow MySQL to start before Zoneminder

nano /etc/init.d/zoneminder

Add above "zmfix -a" sleep 15

should look like:

start() {
sleep 15
echo -n "Starting $prog: "


Ctrl+o Enter to save

CTRL+x to exit

This should work for you.

mrd
Posts: 245
Joined: Wed Apr 26, 2006 12:39 am
Location: Boston USA

Re: Iinstall of 1.26 gets 1.25?

Post by mrd » Mon Aug 18, 2014 12:36 am

I've tried that exact procedure and ended up with 1.25. This thread was really based on that problem and it seems that it could be related to the minor modifications that are made to the 12.04 build on my Utilite Pro system. I thought they only changed the kernel, but nothing else explains why the PPA process does not get the more recent version of ZM. I see no failures during the process at all.

Thanks
MRD

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest