"increase ring buffer size" on centos/rh 6 ??

Forum for questions and support relating to the 1.26.x releases only.
Post Reply
rwinkel
Posts: 13
Joined: Sun Nov 03, 2013 4:26 am

"increase ring buffer size" on centos/rh 6 ??

Post by rwinkel » Tue Apr 29, 2014 8:48 pm

Sorry for the basic question but I've been having capture problems on a centos/rh 6 machine. This is on a modern machine (Intel(R) i5-3470 CPU @ 3.20GHz) with 8GB ram and 5 cameras grabbing 640x480 at 5 fps when idle.
The symptom is gobs of "unexpected packet type 201" and "buffer overrun" errors, and live streams, captures and downloaded videos are full of jerky movement and "ghosts".
I've tinkered with 24bit vs 8bit captures, reduced the alarm capture rate to 10FPS and increased the cpu priority settings of zm to -10.
I'm not getting any 'shmget' errors at startup, and switching to 8bit from 24bit reduced the size of the /dev/shm/zm.mmap* files by a factor of 3 as expected.
kernel.shmmax is 68719476736 which would seem to be plenty even for 24bit.
Is there some config setting I'm missing?
This is zm 1.26.5. I built it with cmake, and CMakeCache.txt contains ZM_NO_MMAP:BOOL=OFF which I assume means it's using mapped memory.

Any help would be much appreciated!

Thanks,
Rich

mastertheknife
Posts: 678
Joined: Wed Dec 16, 2009 4:32 pm
Location: Israel

Re: "increase ring buffer size" on centos/rh 6 ??

Post by mastertheknife » Sun May 04, 2014 12:28 pm

Hi,

Logs wil be helpful.

You are not getting shmget errors because you are not using the old shared memory, but mmap which is automatic, so no need to play with shmall or shmmax.
Kfir Itzhak.

rwinkel
Posts: 13
Joined: Sun Nov 03, 2013 4:26 am

Re: "increase ring buffer size" on centos/rh 6 ??

Post by rwinkel » Tue May 06, 2014 10:34 pm

Thanks so much for the reply! Sorry I didn't see it until now. I've put a representative log online along with the camera settings from the zm db.
This is from an axis 212 ptz network camera.
They are here:
http://faculty.missouri.edu/~winkelr/zm ... z.settings
http://faculty.missouri.edu/~winkelr/zm/axis212ptz.log

Any help would be much appreciated! I really don't know what else to check.

Rich

rwinkel
Posts: 13
Joined: Sun Nov 03, 2013 4:26 am

Re: "increase ring buffer size" on centos/rh 6 ??

Post by rwinkel » Wed May 07, 2014 7:44 pm

I stumbled on a solution. I had set the idle FPS rate to 5 on all the cameras. That's when the problem started. Clearing that field fixed it.

Post Reply

Who is online

Users browsing this forum: No registered users and 2 guests