Bug affecting remote_auth still present in 1.26.x

Forum for questions and support relating to the 1.26.x releases only.
Post Reply
User avatar
MJN
Posts: 250
Joined: Wed Jan 17, 2007 10:29 am
Location: Wiltshire, UK
Contact:

Bug affecting remote_auth still present in 1.26.x

Post by MJN » Thu Jan 02, 2014 9:07 pm

Hi,

First off, can I just say how pleased I am that ZoneMinder lives on in the 1.26 series. As a long-time user - from since very nearly the beginning - I was getting rather concerned when we seemed to sticking on v1.25!

That said, I've only just got round to updating, however I have found a bug that has been present since at least as far back as 2009. Specifically, if AUTH_TYPE is set to remote (e.g. if using HTTP auth) then logging in results in an infinite loop. There may be other configuration factors involved to trigger the issue but toggling this one certainly reproduces it at will.

The fix is fairly straightforward - here it is - and requires only a small ordering change to index.php.

If there's a better way to report a bug please do let me know.

User avatar
iconnor
Posts: 1345
Joined: Fri Oct 29, 2010 1:43 am
Location: Toronto
Contact:

Re: Bug affecting remote_auth still present in 1.26.x

Post by iconnor » Fri Jan 03, 2014 11:34 pm

I've reviewed the fix... looks ok to me.

I have applied it to master and it will be included in 1.26.6

Generally either here or on github is the place to report bugs... github is better generally.

User avatar
MJN
Posts: 250
Joined: Wed Jan 17, 2007 10:29 am
Location: Wiltshire, UK
Contact:

Re: Bug affecting remote_auth still present in 1.26.x

Post by MJN » Sat Jan 04, 2014 9:26 am

Thanks Isaac, and indeed thanks for your continued contribution to this project.

Incidentally, I stumbled across your ZoneMinder PPA and I see it is intended for Ubuntu but do you know if it would also work with Debian (7/Wheezy)?

PacoLM
Posts: 970
Joined: Wed Dec 02, 2009 9:55 pm
Location: Spain

Re: Bug affecting remote_auth still present in 1.26.x

Post by PacoLM » Sat Jan 04, 2014 6:56 pm

Yes, please, add Debian Wheezy for your excellent work!

mini-ITX system (4 IPCams - Ubuntu20.04 - ZM1.34.15)
TelegramBot

User avatar
knight-of-ni
Posts: 2325
Joined: Thu Oct 18, 2007 1:55 pm
Location: Shiloh, IL

Re: Bug affecting remote_auth still present in 1.26.x

Post by knight-of-ni » Sat Feb 15, 2014 1:13 am

FYI, this fix has been incorporated into the source tree and will be included in the 1.27 release, which is currently in testing.

https://github.com/ZoneMinder/ZoneMinder/issues/296
Visit my blog for ZoneMinder related projects using the Raspberry Pi, Orange Pi, Odroid, and the ESP8266
All of these can be found at https://zoneminder.blogspot.com/

Post Reply

Who is online

Users browsing this forum: No registered users and 3 guests