cmake error

Forum for questions and support relating to the 1.26.x releases only.
Post Reply
sgrobinson
Posts: 22
Joined: Mon Mar 25, 2013 9:05 am

cmake error

Post by sgrobinson » Sat Dec 21, 2013 6:07 pm

Hello,

I seem to be getting this problem recently when trying to build. I got ZM to automatically create the zm_conf.cmake file but I cant run sudo cmake -C zm_conf.cmake because of the below error. Any suggestions? :( Sorry - I have googled and this was a last resort asking!

http://pastebin.com/EtwY9e1H

mastertheknife
Posts: 678
Joined: Wed Dec 16, 2009 4:32 pm
Location: Israel

Re: cmake error

Post by mastertheknife » Sun Dec 22, 2013 4:24 am

Hi,

It seems you are running cmake without specifying the source folder.
It should be like this (don't forget the period at the end):

Code: Select all

cmake -C zm_conf.cmake .
After that, make and then sudo make install. You might also need to update the symlinks for the images/ and events/ folder because make install overrides them. zmlinkcontent.sh can help you with that. e.g. if your events folder is /zm/events and the images folder is /zm/images, you should run:

Code: Select all

sudo ./zmlinkcontent.sh /zm"
Kfir Itzhak.

sgrobinson
Posts: 22
Joined: Mon Mar 25, 2013 9:05 am

Re: cmake error

Post by sgrobinson » Sun Dec 22, 2013 8:46 am

There I was about to submit an update to the INSTALL file, but If I had actually read it properly there is a . at the end of that command.

Sorry - I did look there, promise!
Thanks :)

Post Reply

Who is online

Users browsing this forum: No registered users and 4 guests