Streaming Video not working

Forum for questions and support relating to the 1.25.x releases only.
Post Reply
foldedhome
Posts: 8
Joined: Wed May 22, 2013 7:46 pm

Streaming Video not working

Post by foldedhome » Wed May 22, 2013 7:56 pm

I have installed zoneminder on ubuntu 12.10 and everything is working apart from streaming videos.

When i click on an event the window opens but the stream does not work.
if i change to stills then i can see all the images with this stream.

when i look in zoneminder log i see the following that it cant find the sock file as below.

Zoneminder Error Log

2013-05-22 20:24:56.538137 web_php 9399 ERR socket_sendto( /zoneminder/sock/zms-099757s.sock ) failed: No such

file or directory /usr/share/zoneminder/includes/functions.php Line 2322

When i look i list this directory at the same time of the error there is a sock file created for a short time as below and is then deleted. I discovered this by doing ls on the directory whilst trying to view a zoneminder triggered event.

Directory listing at the time of error

root@zm-media-pc:/zoneminder/sock#
srwxr-xr-x 1 www-data www-data 0 May 22 06:27 zmdc.sock

srwxr-xr-x 1 www-data www-data 0 May 22 20:24 zms-099757w.sock

the differance is that one has zms-******s.sock as the name whilst the other is zms-******w.sock.

can anyone please help me determine which script is generating these random sock names so that i can get them both the same and i think then that streaming will work

thanks

gedger
Posts: 4
Joined: Thu Jun 06, 2013 8:11 pm

Re: Streaming Video not working

Post by gedger » Sat Jun 08, 2013 4:37 pm

Did you ever solve this as I have the same problem on Debian.

Thanks

Richard

foldedhome
Posts: 8
Joined: Wed May 22, 2013 7:46 pm

Re: Streaming Video not working

Post by foldedhome » Tue Jun 11, 2013 8:34 am

i still have the same problem and am not able to find out how to get the filenames to be the same for the streaming to work. :(

User avatar
teraquad
Posts: 90
Joined: Fri Mar 09, 2012 2:03 pm
Location: New Bern, NC
Contact:

Re: Streaming Video not working

Post by teraquad » Tue Jun 11, 2013 4:11 pm

Hi,

I have the same problem on Fedora 19. I will post any results.

George....
Fedora 23, ZM 1.28
N4ZPO (ham Radio)
8)

DudeBud
Posts: 5
Joined: Sun Jun 30, 2013 8:13 pm

Re: Streaming Video not working

Post by DudeBud » Sun Jun 30, 2013 8:24 pm

I am also having this problem with Ubuntu 13.04
Still pictures events are ok, I can view them if i click them.
However, i cannot stream and have a similar socket error. - "No Main Content Type" error in the streaming window.


Zoneminder log output:
2013-06-30 16:07:24.262692 web_php 8048 ERR socket_sendto( /tmp/zm/zms-489163s.sock ) failed: No such file or directory /usr/share/zoneminder/includes/functions.php 2323

Any ideas?

** using a D-Link DCS-930L Camera

DudeBud
Posts: 5
Joined: Sun Jun 30, 2013 8:13 pm

Re: Streaming Video not working

Post by DudeBud » Mon Jul 01, 2013 12:36 am

I've been working on this all day and am ready to pull my hair out!


lol, and i can't even post a picture of my problem as the site is telling me that "as a new user off-site URLs look spammy"

DudeBud
Posts: 5
Joined: Sun Jun 30, 2013 8:13 pm

Re: Streaming Video not working

Post by DudeBud » Mon Jul 01, 2013 2:09 am

was able to capture a pic of my headache... and help would be great.

I can see images in the events folder, but there is nothing in the actual images folder.
Using a Dlink DCS-930L camera, and am not able to stream

setting the camera to the monitor setting it goes orange, but on any other setting it goes green.
zoneminderprob1.jpg
zoneminderprob1.jpg (251.62 KiB) Viewed 4033 times

mythedoff
Posts: 23
Joined: Sat Dec 04, 2010 5:21 pm

Re: Streaming Video not working

Post by mythedoff » Mon Jul 01, 2013 11:02 pm

Could it be an alias problem? From my notes a year ago:

2012-06-27 23:33:16.107014 web_php 3769 ERR socket_sendto( /tmp/zm/zms-907324s.sock ) failed: No such file or directory includes/functions.php 2322

Code: Select all

$ sudo service apache2 restart
 * Restarting web server apache2                                                [Wed Jun 27 23:21:34 2012] [warn] The Alias directive in /etc/apache2/sites-enabled/001-zoneminder at line 1 will probably never match because it overlaps an earlier Alias.
 ... waiting [Wed Jun 27 23:21:35 2012] [warn] The Alias directive in /etc/apache2/sites-enabled/001-zoneminder at line 1 will probably never match because it overlaps an earlier Alias.
looks like a conflict in http requests
I tried:

Code: Select all

$ sudo nano /etc/apache2/sites-enabled/000-default
and commented out the line starting with Alias
and then:

Code: Select all

$ sudo service apache2 restart
This stopped the socket_sendto problem but it change the url used to access zoneminder and view monitors.

Berfore:
http://<ip>/zm/
After:
http://<ip>/

I've since done a new install and http://<ip>/zm/ works.

twice
Posts: 18
Joined: Tue Nov 02, 2010 12:38 am

Re: Streaming Video not working

Post by twice » Thu Jul 04, 2013 2:29 am

try changing the path from /tmp/zm to /tmp restart zm

regards

foldedhome
Posts: 8
Joined: Wed May 22, 2013 7:46 pm

Re: Streaming Video not working - resolved

Post by foldedhome » Tue Aug 27, 2013 6:00 pm

all

this is now resolved by installing java and setting correct path_zms as this forum solution.
http://www.zoneminder.com/forums/viewto ... 62&start=0

i now get streaming video with no error :D

Post Reply

Who is online

Users browsing this forum: No registered users and 2 guests