ZM 1.25 libffmpeg0 and libavdevice53

Forum for questions and support relating to the 1.25.x releases only.
Post Reply
sipi
Posts: 129
Joined: Wed Feb 14, 2007 5:18 pm

ZM 1.25 libffmpeg0 and libavdevice53

Post by sipi » Wed Jul 25, 2012 3:30 pm

Hi,

I'd like to install zm 1.25 on opensuse 12.1 x86_64 form rpm package. I have to problem.

When I try to install it there is an dependency that it needs libffmpeg0 package. I didn't find anything, this package doesn't exist there is only libffmpeg-devel. Is it true?

Other problem that I ignored this dependency and install zm because I have install ffmpeg, libffmpeg-devel and a lot of other packages and there isn't any dependency problem. But when I try to start zm I have error message in messages log file and zm can't start.

zmpkg.pl[28432]: /usr/bin/zmfix: error while loading shared libraries: libavdevice.so.53: cannot open shared object file: No such file or directory
zm zmpkg[28432]: ERR [Unable to run "sudo -u wwwrun /usr/bin/zmfix", output is ""]

I don't understand because libavdevice53 package doesn't exist there are only libavdevice52 and 54 and both installed.

What is it? Does someone understand it? What can I doing that fix it? Thanks.

User avatar
monex
Posts: 169
Joined: Mon Jan 22, 2007 1:10 pm

Re: ZM 1.25 libffmpeg0 and libavdevice53

Post by monex » Fri Jul 27, 2012 7:36 pm

Hi,

the ffmpeg ABI anf API changed and is not compatible anymore with the built packages. I have to rebuild the packages to get it working again.
Image

Post Reply

Who is online

Users browsing this forum: No registered users and 3 guests