"Signal lost" doesn't create an "event"-major security issue

Forum for questions and support relating to the 1.25.x releases only.
Post Reply
JanD
Posts: 2
Joined: Fri Jul 13, 2012 5:03 pm

"Signal lost" doesn't create an "event"-major security issue

Post by JanD » Fri Jul 13, 2012 5:47 pm

Hello.

I've installed ZoneMinder v1.25.0 via the Ubuntu 12.04 repositories and all seems to be working great, except one major, important function.
The whole setup has been running for awhile, without any apparent problems. It's connected to an wirelesss IP camera.

The issue is that when the power to the IP camera cuts of / somebody cut the power cable, ZoneMinder doesn't create an event at "Signal lost".
It does however create an event at "Signal reacquired", which is a little too late... Until that the camera is blind and ZoneMinder doesn't care..
Both "Signal lost" and "Signal reacquired" does show up in the log when I kill and then turn on the power to the cam, but again, event isn't created on signal lost, so making a filter to send me an e-mail doesn't work (it does however work on "Signal reacquired".)

I've tried re-installing ZoneMinder without any luck.

Please help, without this function the whole setup is vulnerable.

Jan D.

Paranoid
Posts: 117
Joined: Thu Feb 05, 2009 10:40 pm

Re: "Signal lost" doesn't create an "event"-major security i

Post by Paranoid » Sat Jul 14, 2012 8:51 am

zoneminder records video. If the signal has been lost then there is no video to record so no event is generated.

Your best option is to install some monitoring software such as Nagios (http://www.nagios.org/). This will monitor any number of IP cameras and alert you if/when the network loses contact with them.

mastertheknife
Posts: 679
Joined: Wed Dec 16, 2009 4:32 pm
Location: Israel

Re: "Signal lost" doesn't create an "event"-major security i

Post by mastertheknife » Sat Jul 14, 2012 9:03 am

Its by design. If there is no signal, there is nothing to record.

mastertheknife
Kfir Itzhak.

JanD
Posts: 2
Joined: Fri Jul 13, 2012 5:03 pm

Re: "Signal lost" doesn't create an "event"-major security i

Post by JanD » Sat Jul 14, 2012 2:29 pm

Paranoid wrote:zoneminder records video. If the signal has been lost then there is no video to record so no event is generated.

Your best option is to install some monitoring software such as Nagios. This will monitor any number of IP cameras and alert you if/when the network loses contact with them.
I'm sorry to hear that... I really thought that an event or any other form for warning would be generated when a camera is disabled. (must be doable)
It is in the zoneminder log, so it's strange that it's not possible to get notified when that happens....I mean..isn't that of most importance!?

I'll check into that link (nagios), but i'm not a fan of running lots of additional services to get done what should be done by THE service in the first place.

This NEEDS to get implemented.
I'll propose this to the developers.

Thanks for the response!

Christo
Posts: 89
Joined: Wed Feb 01, 2012 9:48 pm

Re: "Signal lost" doesn't create an "event"-major security i

Post by Christo » Sat Sep 01, 2012 4:09 pm

JanD wrote:
Paranoid wrote:zoneminder records video. If the signal has been lost then there is no video to record so no event is generated.

Your best option is to install some monitoring software such as Nagios. This will monitor any number of IP cameras and alert you if/when the network loses contact with them.
I'm sorry to hear that... I really thought that an event or any other form for warning would be generated when a camera is disabled. (must be doable)
It is in the zoneminder log, so it's strange that it's not possible to get notified when that happens....I mean..isn't that of most importance!?

I'll check into that link (nagios), but i'm not a fan of running lots of additional services to get done what should be done by THE service in the first place.

This NEEDS to get implemented.
I'll propose this to the developers.

Thanks for the response!
Hello JanD,

Signal loss, Ir-defects and even "Blue Mute" is detectable with the help of an extra package (ImageMagick)

see http://www.zoneminder.com/forums/viewto ... 29&t=19553

Kind regards, Christo

McFuzz
Posts: 181
Joined: Tue Aug 28, 2012 7:03 am

Re: "Signal lost" doesn't create an "event"-major security i

Post by McFuzz » Sun Sep 02, 2012 8:20 am

I can attest to the fact that signal lost can indeed become detectable. I've had that happen a few times with my wifi camera - it has a few blips here and there and events are always created for that (though I created a filter that kills those notifications).

Christo
Posts: 89
Joined: Wed Feb 01, 2012 9:48 pm

Re: "Signal lost" doesn't create an "event"-major security i

Post by Christo » Sun Sep 02, 2012 10:53 am

McFuzz wrote:I can attest to the fact that signal lost can indeed become detectable. I've had that happen a few times with my wifi camera - it has a few blips here and there and events are always created for that (though I created a filter that kills those notifications).
Hello McFuzz,

Always nice to know that posts are read!!

The only problem with detecting Signal Loss with standard ZoneMinder features is that youll have to be aware that the camera('s) should run in a detection mode!! If running Monitor settings.. this is not detected by ZoneMinder, so a weak point!!


By running ImageMagick, you can even see if a camera is online, offline, BlueMuted or running low on InfraRed!

Just grab a frame and run this through ImageMagick on script, will do the trick!

Kind regards, Christo

dsnowdy
Posts: 1
Joined: Fri Aug 10, 2012 1:39 am

Re: "Signal lost" doesn't create an "event"-major security i

Post by dsnowdy » Mon Nov 05, 2012 3:40 pm

I'm also bothered by blue screens sometime being recorded as events.
If I access the camera directly through its built in interface, the picture doesn't drop, but zoneminder will drop the picture and display the blue screen and record an event.
I've lowered the framerate in ZM but may need to do more experimenting.
Dave

Post Reply

Who is online

Users browsing this forum: No registered users and 4 guests