localhost/zm/undefined problem

Forum for questions and support relating to the 1.25.x releases only.
Post Reply
chrisr
Posts: 3
Joined: Tue Jun 19, 2012 11:21 am

localhost/zm/undefined problem

Post by chrisr » Tue Jun 19, 2012 11:35 am

Hi

I have just installed ZoneMinder for the first time, version 1.25, using apt (apt-get install zoneminder). I went to localhost/zm, logged in with successfully with admin/admin.

At the top of the screen it says "ZoneMinder Console - Stopped - v1.25.0". So I clicked on the word "Stopped", then clicked on the "Apply" button to change it to started. After a few moments I am then sent to the page localhost/zm/undefined which has a 404 error.

Here is a pastie of last few lines of my error.log file :

pastie[dot]org[slash]4113909

There are lots of errors but i'm not exactly sure what the cause is. Can anyone shed any light on what I have to do to fix it? Any help is appreciated.

Thanks
Chris

chrisr
Posts: 3
Joined: Tue Jun 19, 2012 11:21 am

Re: localhost/zm/undefined problem

Post by chrisr » Tue Jun 19, 2012 11:36 am

I had to use [dot] and [slash] because the forum wouldn't let me add the real address.

chrisr
Posts: 3
Joined: Tue Jun 19, 2012 11:21 am

Re: localhost/zm/undefined problem

Post by chrisr » Tue Jun 19, 2012 12:09 pm

Ok, you can ignore my previous message as I am now in a worse situation. I apt-get remove'd zoneminder, and then ran apt-get install zoneminder. This time there are a lot of problems :

Yet again i find myself in dependency hell! I shouldn't have removed it.

root@chrisr-Latitude-E6510:~/Downloads/ZoneMinder-1.25.0# apt-get install zoneminder
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following extra packages will be installed:
apache2 apache2-mpm-prefork apache2.2-common libapache2-mod-php5 php5
Suggested packages:
apache2-doc apache2-suexec apache2-suexec-custom php-pear
The following NEW packages will be installed
apache2 apache2-mpm-prefork apache2.2-common libapache2-mod-php5 php5 zoneminder
0 upgraded, 6 newly installed, 0 to remove and 143 not upgraded.
Need to get 0 B/5,287 kB of archives.
After this operation, 16.4 MB of additional disk space will be used.
Do you want to continue [Y/n]? Y
Selecting previously unselected package apache2.2-common.
(Reading database ... 206996 files and directories currently installed.)
Unpacking apache2.2-common (from .../apache2.2-common_2.2.22-1ubuntu1_amd64.deb) ...
Selecting previously unselected package apache2-mpm-prefork.
Unpacking apache2-mpm-prefork (from .../apache2-mpm-prefork_2.2.22-1ubuntu1_amd64.deb) ...
Selecting previously unselected package apache2.
Unpacking apache2 (from .../apache2_2.2.22-1ubuntu1_amd64.deb) ...
Selecting previously unselected package libapache2-mod-php5.
Unpacking libapache2-mod-php5 (from .../libapache2-mod-php5_5.3.10-1ubuntu3.1_amd64.deb) ...
Selecting previously unselected package php5.
Unpacking php5 (from .../php5_5.3.10-1ubuntu3.1_all.deb) ...
Selecting previously unselected package zoneminder.
Unpacking zoneminder (from .../zoneminder_1.25.0-1_amd64.deb) ...
Processing triggers for ufw ...
Processing triggers for ureadahead ...
Processing triggers for man-db ...
Setting up apache2.2-common (2.2.22-1ubuntu1) ...
Setting up apache2-mpm-prefork (2.2.22-1ubuntu1) ...
* Starting web server apache2 Syntax error on line 4 of /etc/apache2/conf.d/zoneminder.conf:
Invalid command 'php_flag', perhaps misspelled or defined by a module not included in the server configuration
Action 'start' failed.
The Apache error log may have more information.
[fail]
invoke-rc.d: initscript apache2, action "start" failed.
Setting up apache2 (2.2.22-1ubuntu1) ...
Setting up libapache2-mod-php5 (5.3.10-1ubuntu3.1) ...
* Reloading web server config apache2 Setting up php5 (5.3.10-1ubuntu3.1) ...
Setting up zoneminder (1.25.0-1) ...
Starting ZoneMinder: Bareword "ZM_PATH_LOGS" not allowed while "strict subs" in use at /usr/share/perl5/ZoneMinder/Logger.pm line 153.
BEGIN not safe after errors--compilation aborted at /usr/share/perl5/ZoneMinder/Logger.pm line 168.
Compilation failed in require at /usr/share/perl5/ZoneMinder.pm line 34.
BEGIN failed--compilation aborted at /usr/share/perl5/ZoneMinder.pm line 34.
Compilation failed in require at /usr/bin/zmpkg.pl line 37.
BEGIN failed--compilation aborted at /usr/bin/zmpkg.pl line 37.
failure

invoke-rc.d: initscript zoneminder, action "start" failed.
dpkg: error processing zoneminder (--configure):
subprocess installed post-installation script returned error exit status 2
Errors were encountered while processing:
zoneminder
E: Sub-process /usr/bin/dpkg returned an error code (1)
root@chrisr-Latitude-E6510:~/Downloads/ZoneMinder-1.25.0# apt-get install zoneminder
Reading package lists... Done
Building dependency tree
Reading state information... Done
zoneminder is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 143 not upgraded.
1 not fully installed or removed.
After this operation, 0 B of additional disk space will be used.
Do you want to continue [Y/n]? Y
Setting up zoneminder (1.25.0-1) ...
Starting ZoneMinder: Bareword "ZM_PATH_LOGS" not allowed while "strict subs" in use at /usr/share/perl5/ZoneMinder/Logger.pm line 153.
BEGIN not safe after errors--compilation aborted at /usr/share/perl5/ZoneMinder/Logger.pm line 168.
Compilation failed in require at /usr/share/perl5/ZoneMinder.pm line 34.
BEGIN failed--compilation aborted at /usr/share/perl5/ZoneMinder.pm line 34.
Compilation failed in require at /usr/bin/zmpkg.pl line 37.
BEGIN failed--compilation aborted at /usr/bin/zmpkg.pl line 37.
failure

invoke-rc.d: initscript zoneminder, action "start" failed.
dpkg: error processing zoneminder (--configure):
subprocess installed post-installation script returned error exit status 2
Errors were encountered while processing:
zoneminder
E: Sub-process /usr/bin/dpkg returned an error code (1)

AndyMcc
Posts: 4
Joined: Fri May 11, 2012 6:10 pm

Re: localhost/zm/undefined problem

Post by AndyMcc » Wed Jun 20, 2012 8:05 pm

I have a similar error message, but it only happened after I upgraded MySQL (part of the Ubuntu routine upgrades).

Code: Select all

Starting ZoneMinder: Bareword "ZM_PATH_LOGS" not allowed while "strict subs" in use at /usr/share/perl5/ZoneMinder/Logger.pm line 153.
BEGIN not safe after errors--compilation aborted at /usr/share/perl5/ZoneMinder/Logger.pm line 168.
Compilation failed in require at /usr/share/perl5/ZoneMinder.pm line 34.
BEGIN failed--compilation aborted at /usr/share/perl5/ZoneMinder.pm line 34.
Compilation failed in require at /usr/bin/zmpkg.pl line 37.
BEGIN failed--compilation aborted at /usr/bin/zmpkg.pl line 37.
Trying to run zmupdate.pl, I received this:

Code: Select all

Bareword "ZM_PATH_LOGS" not allowed while "strict subs" in use at /usr/share/perl5/ZoneMinder/Logger.pm line 153.
BEGIN not safe after errors--compilation aborted at /usr/share/perl5/ZoneMinder/Logger.pm line 168.
Compilation failed in require at /usr/bin/zmupdate.pl line 48.
BEGIN failed--compilation aborted at /usr/bin/zmupdate.pl line 48.
Any other hints from your research?

AndyMcc
Posts: 4
Joined: Fri May 11, 2012 6:10 pm

Re: localhost/zm/undefined problem

Post by AndyMcc » Wed Jun 20, 2012 8:57 pm

this thread has the solution that worked for me:

http://www.zoneminder.com/forums/postin ... 29&t=18926

-andy

Post Reply

Who is online

Users browsing this forum: No registered users and 8 guests