Page 1 of 1

Initial setup: Black screen

Posted: Mon May 14, 2012 8:03 pm
by tortoise74
I am still wrestling with the initial setup of ZM.
I now have both a USB webcam and an IP cam both of which work outside of ZM.
I started on 1.24 but was automatically upgraded to 1.25 when I upgraded Ubuntu to 12.04.
The database update went smoothly.

One odd thing I notice since the upgrade is that there are no new messages
being added to /var/log/zm or /var/log/messages
e.g. even if I restart the zoneminder service.

> ls -ltr /var/log/z*
total 1364
-rw-r--r-- 1 www-data www-data 1781 May 14 01:18 zmupdate.log
-rw-r--r-- 1 www-data www-data 1170 May 14 08:54 zmwatch.log
-rw-r--r-- 1 www-data www-data 546 May 14 08:57 zmfilter.log
-rw-r--r-- 1 www-data www-data 88 May 14 09:03 zmaudit.log
-rw-r--r-- 1 www-data www-data 1371188 May 14 09:32 zmdc.log
-rw-r--r-- 1 www-data www-data 1028 May 14 11:26 zmpkg.log

I don't know where logs are going now if anywhere.

Trying the experiment suggested to test a local camera I get the same problem as
I described for 1.24: ... 21&t=19192

> zmc --device /dev/video
> echo $?

Having a black screen seems to be a common problem for us noobs - perhaps it should go in the FAQ?: ... 368#p75368

Can anyone help?



Re: Initial setup: Black screen [SOLVED]

Posted: Mon May 28, 2012 6:41 pm
by tortoise74
I have no idea what the problem was but the solution was to drop the ZM database and re-install.
I'm marking this as solved but really I'd still like to know what the problem was.
The nuclear option should ideally be a last resort.

Re: Initial setup: Black screen

Posted: Mon May 28, 2012 6:48 pm
by tortoise74
Also to answer my own question the logs are now in the database rather than in /var/log/zm.
This is presumably because it makes them more convenient to administer remotely
(I don't know where to look for a definitive statement on that).