Page 1 of 2

Add/Edit (new) Zone: Zone Image not displayed

Posted: Thu May 10, 2012 8:05 am
by athoopen

If I try to add a new zone (or edit an existing one) I do not get the "Zone Image". I do get the 4 markers, and the actual camera is working properly. The whole Zoneminder installation is working properly.

Anybody seen this behavior?? Any tips and tricks how to get the "Zone Image" back.

Zoneminder 1.25.0 running on openSUSE 12.1

Re: Add/Edit (new) Zone: Zone Image not displayed

Posted: Thu May 10, 2012 12:39 pm
by athoopen

I stored the images and events on another disk by specifying an absolute path. Once I've reconfigured ZM to use the "standard" locations the Zone Images in the interface returned.

Still strange behaviour ... is it a bug ... or a feature ??

Re: Add/Edit (new) Zone: Zone Image not displayed

Posted: Thu May 17, 2012 12:47 am
by rickdroio
Happened the same with me, but I didnt change anything regarding paths...
Do you now how to fix it??
Could you please share your screen to double check it?

Re: Add/Edit (new) Zone: Zone Image not displayed

Posted: Tue May 22, 2012 7:16 am
by athoopen
We are talking about the same window!! Is this the only image which does't work (in my case it was). Is everything else working as expected (in my case it was). Please double check if the paths (images and events) are pointing to a real directory, not a symbolic link to another dir (on another disk). Actually what are your path settings??

Did you restart zm and examined the log carefully, it may contain clues ;-)

Re: Add/Edit (new) Zone: Zone Image not displayed

Posted: Tue May 22, 2012 8:21 pm
by defacto7
I am also having this issue. I have a new install and all works just fine. 2 cams are working. The first time I set up a zone for the first cam, the zone pic was there and I adjusted the active zone and it works fine. I added the second cam and the image in both zones has disappeared (where you set the active zone). The normal monitor works fine. The red corner points for setting the active area are still visible and in the place I set to begin with. They still detect only within that designated area even though the picture is not showing any more. The panels for adjustment are still there and seem to work correctly.

No picture though. I have to imagine where the pointers should go. :roll:

Anyone have any input on this?


One other thing... I have not changed any paths from the original install.

Re: Add/Edit (new) Zone: Zone Image not displayed

Posted: Thu May 24, 2012 4:38 am
by defacto7
Sorry to bump this but I still have no idea why the zone picture is not displayed. Everything is installed in the default places including images and events. The picture was there the first time I made a zone for the first cam and missing after the second cam. The zone pointers are there and the panels are there. Everything, and I mean everything is working like a dream other than that and I have used Zoneminder for a couple of years now. There is nothing I can see in the logs that is relevant.

This is a new installation of 1.25 for Ubuntu server 12.04.


Re: Add/Edit (new) Zone: Zone Image not displayed

Posted: Tue May 29, 2012 8:10 am
by athoopen
Sorry defacto7 but I have no idea what is going on. Really sorry.
The things I'm thinking of is to set the debug level higher and see if there is something in the log which could give you a clue.
Or goto to the page with the "missing"image and debug the html to find out where it (should) get the picture from.

Sorry again that I can help you further.

Re: Add/Edit (new) Zone: Zone Image not displayed

Posted: Sun Jun 03, 2012 5:15 am
by blueyg
Not sure if you still have this problem. I have recently been trying to set up zoneminder on ubuntu 12.04 and also had this problem. I've just tracked it down to not having write permissions on the events and images folders (I had linked the folders to a different partition that didn't have the correct permissions). Now I've given full access to these folders the zone image is being displayed correctly.

Re: Add/Edit (new) Zone: Zone Image not displayed

Posted: Sun Jun 03, 2012 7:09 am
by defacto7
now it's getting more bizarre. I just gave full permissions to those directories and now when I go to the zone edit screens, the frame appears for a split second and then disappears. Still no picture.

athoopen: I haven't gotten around to debugging as you suggested, but I will and will report. It's a little bit of an annoyance since everything else works fine. I'll get on it.

Re: Add/Edit (new) Zone: Zone Image not displayed

Posted: Mon Jun 04, 2012 5:24 am
by defacto7
I changed to debug and set it to 9. Then restarted, went to a zone, edit, no picture just flash of the border, left that, and checked the debug logs. I made sure I synchronized the timing of the computer with each move I made so I could find the definitive item.

There was nothing in the logs that showed any error. Here's what the log says. The entry into the zone/edit was at exactly 22:28:30... nothing non-ordinary happened at that time. The logs before and after look about the same for 1 1/2 minutes before and after...

Code: Select all

06/03/12 22:28:27.064416 zma_m1[18430].DB4-zm_monitor.cpp/1074 [RI:16, WI: 17, PF = 1, RM = 39, Step = 1]
06/03/12 22:28:27.565363 zma_m1[18430].DB4-zm_monitor.cpp/1074 [RI:17, WI: 18, PF = 1, RM = 39, Step = 1]
06/03/12 22:28:28.066298 zma_m1[18430].DB4-zm_monitor.cpp/1074 [RI:18, WI: 19, PF = 1, RM = 39, Step = 1]
06/03/12 22:28:28.567326 zma_m1[18430].DB4-zm_monitor.cpp/1074 [RI:19, WI: 20, PF = 1, RM = 39, Step = 1]
06/03/12 22:28:29.068256 zma_m1[18430].DB4-zm_monitor.cpp/1074 [RI:20, WI: 21, PF = 1, RM = 39, Step = 1]
06/03/12 22:28:29.569193 zma_m1[18430].DB4-zm_monitor.cpp/1074 [RI:21, WI: 22, PF = 1, RM = 39, Step = 1]
06/03/12 22:28:30.070145 zma_m1[18430].DB4-zm_monitor.cpp/1074 [RI:22, WI: 23, PF = 1, RM = 39, Step = 1]
06/03/12 22:28:30.571095 zma_m1[18430].DB4-zm_monitor.cpp/1074 [RI:23, WI: 24, PF = 1, RM = 39, Step = 1]
06/03/12 22:28:31.072090 zma_m1[18430].DB4-zm_monitor.cpp/1074 [RI:24, WI: 25, PF = 1, RM = 39, Step = 1]
06/03/12 22:28:31.573112 zma_m1[18430].DB4-zm_monitor.cpp/1074 [RI:25, WI: 26, PF = 1, RM = 39, Step = 1]
06/03/12 22:28:32.074056 zma_m1[18430].DB4-zm_monitor.cpp/1074 [RI:26, WI: 27, PF = 1, RM = 39, Step = 1]
06/03/12 22:28:32.074910 zma_m1[18430].INF-zm_monitor.cpp/1293 [temporary_Parklot_night: 026 - Opening new event 2500, section start]
06/03/12 22:28:32.075214 zma_m1[18430].DB1-zm_event.cpp/547 [Writing capture frame 1]
06/03/12 22:28:32.081116 zma_m1[18430].DB1-zm_event.cpp/559 [Adding frame 1 to DB]
06/03/12 22:28:32.549021 zma_m1[18430].DB4-zm_monitor.cpp/1074 [RI:27, WI: 28, PF = 1, RM = 39, Step = 1]
06/03/12 22:28:32.549064 zma_m1[18430].DB1-zm_event.cpp/547 [Writing capture frame 2]
06/03/12 22:28:32.554009 zma_m1[18430].DB1-zm_event.cpp/559 [Adding frame 2 to DB]
06/03/12 22:28:33.055383 zma_m1[18430].DB4-zm_monitor.cpp/1074 [RI:28, WI: 29, PF = 1, RM = 39, Step = 1]
06/03/12 22:28:33.055424 zma_m1[18430].DB1-zm_event.cpp/547 [Writing capture frame 3]
06/03/12 22:28:33.080095 zma_m1[18430].DB1-zm_event.cpp/559 [Adding frame 3 to DB]
06/03/12 22:28:33.548115 zma_m1[18430].DB4-zm_monitor.cpp/1074 [RI:29, WI: 30, PF = 1, RM = 39, Step = 1]
06/03/12 22:28:33.548178 zma_m1[18430].DB1-zm_event.cpp/547 [Writing capture frame 4]
06/03/12 22:28:33.553159 zma_m1[18430].DB1-zm_event.cpp/559 [Adding frame 4 to DB]
These are the debug logs that are in /tmp/zm/ per the default config params. There was nothing in the debug sock directory and there also was no unusual information in the regular /var/syslog.

I am perplexed why I can get the picture from another installation with the same computer/browser but I can't get the picture in the zone/edit section on this installation.

I'm in the duhhhh mode now. File permissions seem to be correct if not more open than they should be and everything else works perfectly. I have 4 BNC cams on a cheep Chinese 4 channel card and 2 crumby USB cams as well running like a charm.... but NO picture in the zone/edit area.

Help :?

Edit: I looked at the page source of the page in question and the picture is images/Zones3.jpg. I decided to look it up and found it was set to 644 www-data www-data. Oh boy, some permissions I can mess up... I changed it to 777. But no luck. 'did nada.

I'll keep looking.

Edit2: The source page shows the image - Zones3.jpg as having the Dimensions: 0px × 0px (scaled to 61px × 13px) Whatever that means. I went to my working zone/edit installation and the that picture's dimensions are the correct ones 640 x 480 and it shows in the preview window. The plot gets lumpy...

Re: Add/Edit (new) Zone: Zone Image not displayed

Posted: Tue Jun 05, 2012 6:23 am
by cordel
Here are the various reasons that the zone frame might not display:

:arrow: ZM (or the apache user) does not have R/W permissions to the images folder (or what ever folder in defined for the path in zm options. If you see the images in this directory, then this is not your issue.

:arrow: The Path configured in ZM for the images don't point to the correct folder. Remember apache needs to be able to serve this so some how, it has to be included with in the web root one way or another so you have to plan for this if you change anything around or off to another disk. This is not the full path from the root of the drive, it should be the path with respect to the web server root path.

:arrow: It's not in Apaches web root path to be served as a web page. The option for the path in ZM does not configure apache for this path and depending on what you do, might need to be added whether it's aliased in or falls under the web pages path. IE you should be able to get to it via[camera_name].jpg If you can see it on the drive but not pull it up via the web server, then here is where you might be getting tripped up or the next line:

:arrow: If it's a symlink in the web root Apache has to be configured for that domain to follow symlinks or at least defined in a .htaccess with the directive.

These are the most common issues.

Re: Add/Edit (new) Zone: Zone Image not displayed

Posted: Tue Jun 05, 2012 8:16 pm
by defacto7
Thanks cordel. The apache configuration makes sense. This would explain why I can see the zone/edit pic on my local installation but not on my server installation; the server is not in my local network. So, I'll dig into apache and see what goes there and report back.

Re: Add/Edit (new) Zone: Zone Image not displayed

Posted: Tue Jun 05, 2012 9:00 pm
by defacto7
I did some looking around, and noticed the regular call to the cams is through CGI. The zone/edit pics (images) are not. But they both are linked through the index.php so when you call it on the web they both have similar addresses but are definitely not coming from the same sources. I tried allowing symlinks but they seem to already be allowed at least by matching owner. No luck. I also tried making an alias to the image source (link) in /usr/share/zoneminder, no luck.

Question... would it be unsafe to make the images directory in /var/cache/zm a CGI directory (seems so)? or make a different symlink in a /usr/lib/ directory a zm CGI script alisas? The idea being to make the call the same as for the cams.

Just a thought....

Re: Add/Edit (new) Zone: Zone Image not displayed

Posted: Tue Jun 05, 2012 11:13 pm
by cordel
Okay this sounds like my config...

So in /usr/lib/zoneminder should be a symlink pointing to /var/lib/zm/images or the like. Make sure the permissions of /var/lib/images and verify the sim link is there.

Else you could remove the symlink, and just create the alias in apache.

Re: Add/Edit (new) Zone: Zone Image not displayed

Posted: Wed Jun 06, 2012 2:14 am
by defacto7
Yep... That did it! I had the link w/ permissions on both sides but it still didn't like it for some reason. Earlier I tried to alias to the link instead of the directory which didn't work. But aliasing to the actual directory did the trick. Now I have the zone/edit pics.

Thanks cordel for reminding me where those images really were!

[solved for me]