Trouble starting ZM 1.25 on Ubuntu after latest updates

Forum for questions and support relating to the 1.25.x releases only.
Post Reply
kmk
Posts: 2
Joined: Mon May 07, 2012 10:16 pm

Trouble starting ZM 1.25 on Ubuntu after latest updates

Post by kmk » Mon May 07, 2012 10:21 pm

Hello,

My zoneminder installation seems to have stopped working after installing the latest updates for ubuntu. I can get to the web interface fine, but it will not start recording. I've upgraded to 12.04 hoping it would resolve these issues, however I'm still getting the same errors:

Starting ZoneMinder: Bareword "ZM_DYN_DB_VERSION" not allowed while "strict subs" in use at /usr/bin/zmpkg.pl line 159.
Bareword "ZM_DYN_DB_VERSION" not allowed while "strict subs" in use at /usr/bin/zmpkg.pl line 158.
Bareword "ZM_DYN_DB_VERSION" not allowed while "strict subs" in use at /usr/bin/zmpkg.pl line 160.
Execution of /usr/bin/zmpkg.pl aborted due to compilation errors.
failure

Any guidance is appreciated.

User avatar
nightcrawler
Posts: 71
Joined: Fri Aug 12, 2011 9:54 am
Location: the netherlands

Re: Trouble starting ZM 1.25 on Ubuntu after latest updates

Post by nightcrawler » Tue May 08, 2012 9:13 am

Did you check if your configtable at the ZM database is still complete with the settings?
I had an simular issue after an few updates.. and somehow the config table was empty.
Zoneminder @Ubuntu 11 server, ZM 1.25.0 , FFMPEG, 4 Analoge cameras, 1.6ghz P4mobile, 2GB ram, 60GB-HDD.
I also have an (homeseer) domotica system up-and-running with touchscreens,light controllers,weather forecast etc.

kmk
Posts: 2
Joined: Mon May 07, 2012 10:16 pm

Re: Trouble starting ZM 1.25 on Ubuntu after latest updates

Post by kmk » Wed May 09, 2012 10:22 pm

Yes, the config table is full, and settings seem pretty accurate.

Jim March
Posts: 88
Joined: Thu Oct 04, 2007 8:31 am

Re: Trouble starting ZM 1.25 on Ubuntu after latest updates

Post by Jim March » Fri May 11, 2012 1:23 am

Same problem here. Can't issue a start command from the ZM Console. And if I check the logs after trying, all I get is:

fetchNextLogs is undefined

Jim March
Posts: 88
Joined: Thu Oct 04, 2007 8:31 am

Re: Trouble starting ZM 1.25 on Ubuntu after latest updates

Post by Jim March » Fri May 11, 2012 1:27 am

Wait, to clarify, here's the whole log entry and it appears after a LONG pause...


Date/time: 2012-05-10 19:18:57.451305

Component: web_js

PID: 1171

Level: ERR

Message: fetchNextLogs is undefined

File: zm/skins/classic/views/js/log.js

Line: 122

That's all ONE line.

Is it possible that Java support of some sort is broken?!

Post Reply

Who is online

Users browsing this forum: No registered users and 2 guests