redirecting to systemctl

Forum for questions and support relating to the 1.25.x releases only.
Post Reply
User avatar
qu1nn
Posts: 9
Joined: Mon Jan 23, 2012 2:15 am

redirecting to systemctl

Post by qu1nn » Mon Jan 23, 2012 2:41 am

Hello...
ultra newb here....
using OpenSUSE 12.1 x86_64, relatively new install

updated repos
installed zoneminder (not zoneminder-mp) version 1.25.0-25.1
automagically selected 68 other packages, let them install.

then started to follow the instructions: wiki ZoneMinder_RPMs_for_SuSE

didnt get too far:
Started at Setting up MySQL and Apache
so as ROOT I start a console and do: rcapache2 start
and there is a pause, then it increments a line and states "redirecting to systemctl", then increments to the cursor

same thing happens with rcmysql start
this is the first time running MySQL and it did not ask for any type guided setup... just another "redirecting to systemctl" ...

any suggestions?
I have tried rebooting, same thing.

any suggestion will be great...


qu1nn
Pentium D 820, 2.80GHz, Intel D945PSN ATX, evga geforce 7600GT 256MB PCIE, Geil DDR2, (1GB x 2) Dual Channel 667MHz
Suse 12.1 x86-64bit, Zoneminder 1.25.0-25.1

User avatar
qu1nn
Posts: 9
Joined: Mon Jan 23, 2012 2:15 am

Re: redirecting to systemctl

Post by qu1nn » Mon Jan 23, 2012 4:57 pm

I never got asked to mysql password...
so I would assume there was a problem right off!

any suggestions would be great.
Thanks for your time
qu1nn
Pentium D 820, 2.80GHz, Intel D945PSN ATX, evga geforce 7600GT 256MB PCIE, Geil DDR2, (1GB x 2) Dual Channel 667MHz
Suse 12.1 x86-64bit, Zoneminder 1.25.0-25.1

User avatar
eracc
Posts: 84
Joined: Wed Mar 08, 2006 3:26 pm
Location: USA
Contact:

Re: redirecting to systemctl

Post by eracc » Mon Jan 23, 2012 10:16 pm

Since no one else has answered you ...

I am not a SuSE user, so I really have no clue about SuSE packages or the "redirecting to systemctl" message. Since you are using a pre-packaged SuSE 12.1 version of ZM 1.25 there may be differences from what you are seeing on the Wiki page. The best suggestion I have is maybe you could contact the package maintainer to ask for specific instructions. Or perhaps some kind soul who has your exact SuSE version and has used the aforementioned ZM package will see your post and answer.

As a pre-loaded system builder I just download the source of ZM and build from that. Maybe you could give that a shot.

joelgb
Posts: 8
Joined: Fri Jun 11, 2010 12:50 am

Re: redirecting to systemctl

Post by joelgb » Tue Jan 24, 2012 8:25 pm

The "redirecting to systemctl" messages are part of the sysvinit to systemd change that was made (and is new) in OpenSuSE 12.1 . restated: OpenSuSE 12.1 now uses systemd instead of traditional sysvinit and this is why the output looks different. My suggestion is to follow those "start" commands with a "status" command.
So in your example after running "rcapache2 start" then run "rcacpache2 status".

In systemd, you can do the same thing with "systemctl status apache2.service" . The syntax is longer and different than you may be used to. I'm still learning the systemd stuff myself and am still not used to not getting back a confirmation that a service was started.

Have you tried connecting to mysql, maybe it's already running and ready to go?

-Joel

User avatar
qu1nn
Posts: 9
Joined: Mon Jan 23, 2012 2:15 am

Re: redirecting to systemctl

Post by qu1nn » Wed Jan 25, 2012 3:50 am

thank you for the responses...
please note I am a newb to mysql, apache2, as well as zoneminder

I used instructions http://www.zoneminder.com/wiki/index.ph ... s_for_SuSE

1) starting at Setting Apache: < SEEMS TO BE OK>

LINUX-PD:/home/jason # rcapache2 start
redirecting to systemctl
LINUX-PD:/home/jason # rcapache2 status
redirecting to systemctl
apache2.service - apache
Loaded: loaded (/lib/systemd/system/apache2.service; enabled)
Active: active (running) since Sun, 22 Jan 2012 21:31:33 -0500; 2 days ago
Process: 14569 ExecStop=/usr/sbin/httpd2 -D SYSTEMD -k stop (code=exited, status=0/SUCCESS)
Process: 14682 ExecStart=/usr/sbin/start_apache2 -D SYSTEMD -k start (code=exited, status=0/SUCCESS)
Main PID: 14701 (httpd2-prefork)
CGroup: name=systemd:/system/apache2.service
├ 14701 /usr/sbin/httpd2-prefork -f /etc/apache2/httpd.conf -D SYSTEMD -k start
├ 14702 /usr/sbin/httpd2-prefork -f /etc/apache2/httpd.conf -D SYSTEMD -k start
├ 14703 /usr/sbin/httpd2-prefork -f /etc/apache2/httpd.conf -D SYSTEMD -k start
├ 14704 /usr/sbin/httpd2-prefork -f /etc/apache2/httpd.conf -D SYSTEMD -k start
├ 14705 /usr/sbin/httpd2-prefork -f /etc/apache2/httpd.conf -D SYSTEMD -k start
├ 14707 /usr/sbin/httpd2-prefork -f /etc/apache2/httpd.conf -D SYSTEMD -k start
└ 28426 /usr/sbin/httpd2-prefork -f /etc/apache2/httpd.conf -D SYSTEMD -k start


2) Starting MySQL (FOR THE FIRST TIME) - I never got asked for any onscreen steps as suggested by the wiki!!!
LINUX-PD:/home/jason # rcmysql start
redirecting to systemctl
LINUX-PD:/home/jason # rcmysql status
redirecting to systemctl
mysql.service - LSB: Start the MySQL database server
Loaded: loaded (/etc/init.d/mysql)
Active: active (running) since Sun, 22 Jan 2012 21:33:09 -0500; 2 days ago
Process: 14488 ExecStop=/etc/init.d/mysql stop (code=exited, status=0/SUCCESS)
Process: 14761 ExecStart=/etc/init.d/mysql start (code=exited, status=0/SUCCESS)
CGroup: name=systemd:/system/mysql.service
├ 14809 /bin/sh /usr/bin/mysqld_safe --mysqld=mysqld --user=mysql --pid-file=/var/run/m...
└ 15134 /usr/sbin/mysqld --basedir=/usr --datadir=/var/lib/mysql --plugin-dir=/usr/lib6...


3) Initializing ZoneMinder: << PLEASE EXCUSE MY NEWBISHNESS at from this point >>
I guess I am confused, when asked for a MYSQL ROOT PASSWORD what are you supposed to give?
a) the password that was SUPPOSED TO BE ASKED IN (2) above?
b) roots password?
c) or a new password for MySql that is unique to this application? ***** THIS IS HOW I TOOK IT, and what I DID *****

LINUX-PD:/home/jason # zm_database_init
INFO: when db is correctly installed and you just reinstalled rpm, then answer all questions with 'n'
no lockfile found, proceed anyway? [y/N]: y
Enter mysql root password:
generated/updated ~/.my.cnf
database is already installed. if you want to recreate the database drop it manually and change the 'database-initialized' configuration option to 'no'


4) When I tried to connect to the localhost/zm I get the following response:
Could not connect to database: Access denied for user 'zm_admin'@'localhost' (using password: YES)




I have to assume my passwords in mysql is goofing things up...
Could someone explain

my guess is that my problem stems from not getting asked in (2) for a mysql pass.... which could be anything, but most likely, for safetys sake different than root.... and this mysql pass is what should have been entered into step (3) above.
so how do I force setup a mysql password?

Thanks for your time and patience

qu1nn
Pentium D 820, 2.80GHz, Intel D945PSN ATX, evga geforce 7600GT 256MB PCIE, Geil DDR2, (1GB x 2) Dual Channel 667MHz
Suse 12.1 x86-64bit, Zoneminder 1.25.0-25.1

User avatar
eracc
Posts: 84
Joined: Wed Mar 08, 2006 3:26 pm
Location: USA
Contact:

Re: redirecting to systemctl

Post by eracc » Wed Jan 25, 2012 4:13 am

Even though you did not do a source code install you can probably get a clue by looking at this section in the documentation:

http://www.zoneminder.com/wiki/index.ph ... rom_Source

Specifically the part near the top of that section that deals with MySQL. At least, when I build from source on Red Hat derivatives, such as Mageia, that works for me.

User avatar
monex
Posts: 169
Joined: Mon Jan 22, 2007 1:10 pm

Re: redirecting to systemctl

Post by monex » Fri Jan 27, 2012 9:23 pm

Hi,

you are right, by using systemd the default output is redirected to /var/log/messages. I wrote a notice for that to the howto in the wiki. To set up a root password by running mysql_secure_installation. Then proceed with the regular steps.

Hope this helps
Dirk
Image

User avatar
monex
Posts: 169
Joined: Mon Jan 22, 2007 1:10 pm

Re: redirecting to systemctl

Post by monex » Fri Jan 27, 2012 9:27 pm

Hi,

I forgot to add one more thing which changed with the use of systemd: To enable mysql, apache2 and ZoneMinder at boot time you should use

Code: Select all

systemctl enable apache2.service
systemctl enable mysql.service
systemctl enable zm.service
I guess the wiki also needs an update here too :)

Hope this helps
Dirk
Image

Post Reply

Who is online

Users browsing this forum: No registered users and 8 guests