service zm start FAILED - first attempt at running

Forum for questions and support relating to the 1.25.x releases only.
Post Reply
ansonch
Posts: 3
Joined: Sat Jan 14, 2012 5:21 am

service zm start FAILED - first attempt at running

Post by ansonch » Sat Jan 14, 2012 5:31 am

So, I'm following the CentOS 5.7 install guide here (http://www.zoneminder.com/wiki/index.ph ... ZoneMinder) But I've hit a snag.

At the final step - Start ZoneMinder - I'm running "service zm start" at the command line.

Starting ZoneMinder: Bareword "ZM_PATH_LOGS" not allowed while "strict subs" in use at /usr/lib/perl5/site_perl/5.8.8/ZoneMinder/Logger.pm line 153.
BEGIN not safe after errors--compilation aborted at /usr/lib/perl5/site_perl/5.8.8/ZoneMinder/Logger.pm line 168.
Compilation failed in require at /usr/lib/perl5/site_perl/5.8.8/ZoneMinder.pm line 34.
BEGIN failed--compilation aborted at /usr/lib/perl5/site_perl/5.8.8/ZoneMinder.pm line 34.
Compilation failed in require at /usr/local/bin/zmpkg.pl line 37.
BEGIN failed--compilation aborted at /usr/local/bin/zmpkg.pl line 37.
[FAILED]

I noticed if I go to the my localhost/zm site, I'm greeted with the ZoneMinder Web Title Prefix with the username/password. I believe this means httpd and mysql is running (it is) but I'm not able to get further. What does the error message "Barewood "ZM_PATH_LOGS" indicate?

Any help always appreciated. Thanks!

User avatar
monex
Posts: 169
Joined: Mon Jan 22, 2007 1:10 pm

Re: service zm start FAILED - first attempt at running

Post by monex » Mon Jan 16, 2012 6:52 pm

Hi,

it looks like the Config table is broken. Easiest way is to reinstall the database. You can do this by dropping the zm database (in mysql enter drop database zm) and dump the file zm_create.sql in (http://www.zoneminder.com/wiki/index.ph ... gure_MySQL).

I don't know enough about the actual CentOS release to explain why this had happened but I had similar problems while packaging the RPMs for openSUSE 12.1 (http://www.zoneminder.com/forums/viewto ... use#p73178). It could be a similar issue here.

Hope this helps
Image

ansonch
Posts: 3
Joined: Sat Jan 14, 2012 5:21 am

Re: service zm start FAILED - first attempt at running

Post by ansonch » Mon Jan 16, 2012 11:46 pm

Thank you monex!

As stated in your response, I ended up dropping the zm database, followed by creating a new zm db, and loading in the necessary tables via the zm_create.sql. Fixed now, and I'm on my way to getting Zoneminder up and running.

Thanks again!

Post Reply

Who is online

Users browsing this forum: No registered users and 4 guests