Zoneminder server locking up.

Forum for questions and support relating to the 1.25.x releases only.
Yamanipanuchi
Posts: 90
Joined: Wed May 19, 2010 2:53 am

Zoneminder server locking up.

Post by Yamanipanuchi » Wed Sep 14, 2011 12:22 am

I have two Zoneminder boxes having the same problem and one with no problem. I'm wondering if anyone else out there has had a similar problems and have found anything out that can lead to a solution.

In short the Zoneminder box completely locks up. Only way to shut the system down it s a hard shutdown. Both systems are completely different hardware.

I've checked /var/log/syslog and it just stops cold.

Its running Zoneminder 1.25.0 and Ubuntu Server x64 11.04

I wish I had more information but there really isnt much else to add that I've found so far. Anyone have any idea's where to start looking from here?

User avatar
MJN
Posts: 250
Joined: Wed Jan 17, 2007 10:29 am
Location: Wiltshire, UK
Contact:

Re: Zoneminder server locking up.

Post by MJN » Wed Sep 14, 2011 8:32 pm

Whilst obviously not all that much to go on, it sounds like a hardware issue. Are you able to swap out the RAM to see if that shifts/eliminates the problem? Perhaps even removing and reseating them might suffice.

Mathew

bb99
Posts: 943
Joined: Wed Apr 02, 2008 12:04 am

Re: Zoneminder server locking up.

Post by bb99 » Wed Sep 14, 2011 11:14 pm

If you're using a capture card check the temperature of the chips. Adding heat sinks solved this problem for me, very similar symptoms.

Flasheart
Posts: 345
Joined: Thu Jul 06, 2006 2:27 pm

Re: Zoneminder server locking up.

Post by Flasheart » Thu Sep 15, 2011 6:26 am

Installing munin will give you some hardware info, especially if you configure it to display temps.

bb99's theory sounds like it's worth pursuing. Tried checking the fans are working, and running with the case open to see if it makes a difference? A laser thermometer is a good tool for spotting localised heat buildups such as chipsets on cards.

Yamanipanuchi
Posts: 90
Joined: Wed May 19, 2010 2:53 am

Re: Zoneminder server locking up.

Post by Yamanipanuchi » Thu Sep 15, 2011 1:17 pm

Im still trying to narrow this one down. Out of three different Zoneminder Boxes only two are having this problem.

All three are running one different models of Dell PC's but are using ubuntu 11.04. One is a Dell Optiplex 620, Another is Dell Optiplex 755 and the last is a Dell Optiplex 990. These models span almost 5 years. This is a good sign there completely different hardware. The Dell Optiplex 990 I completely switchout to a different PC all new hardware with the same outcome.

I am not using a capture card on any of these machines. There all IP based camera's.

The only difference that I can note is that during the initial compilation of Zoneminder, On the two that have this problem I had to add "#include <limits.h>" to on of the cpp files. If I dont add the limits.h I get an error while compiling and it does finish.

The one Box that is working with not issues I did not have to do that.

Yamanipanuchi
Posts: 90
Joined: Wed May 19, 2010 2:53 am

Re: Zoneminder server locking up.

Post by Yamanipanuchi » Thu Sep 15, 2011 3:29 pm

Im trying a newer build of Zoneminder and see how it goes.

http://www.zoneminder.com/downloads/Zon ... 492.tar.gz

Instead of

http://www.zoneminder.com/downloads/Zon ... 475.tar.gz

I sometimes takes a few days to lock up so it will take me a little while to see...

Yamanipanuchi
Posts: 90
Joined: Wed May 19, 2010 2:53 am

Re: Zoneminder server locking up.

Post by Yamanipanuchi » Tue Sep 27, 2011 10:00 pm

I tried


http://www.zoneminder.com/downloads/Zon ... 492.tar.gz

With no success. Its really weird, I go into syslog and the log just ends where the PC locks up. Again this is on two different PC completely different hardware same issue.

I do have one out of three Zoneminder's working like a champ. No problems.

I was hoping maybe a few other people have had a similar problem.

User avatar
MJN
Posts: 250
Joined: Wed Jan 17, 2007 10:29 am
Location: Wiltshire, UK
Contact:

Re: Zoneminder server locking up.

Post by MJN » Wed Sep 28, 2011 8:43 am

Sorry, yes, I missed the key bit about this happening on two different machines hence hardware anomalies do sound unlikely (however likely the symptoms of a hard lockup pointing that way might be).

Could you try a different distribution on one of the machines as a divide and conqueor approach to pinpointing the cause of the problem?

Mathew

Yamanipanuchi
Posts: 90
Joined: Wed May 19, 2010 2:53 am

Re: Zoneminder server locking up.

Post by Yamanipanuchi » Thu Sep 29, 2011 2:48 pm

Ya im slowly trying different things trying to narrow it down.

Here's the last line in Syslog when it locks up....

Sep 28 21:59:38 zonemindeSep 29 07:28:10 zoneminder kernel: imklog 4.6.4, log source = /proc/kmsg started.

As you can see it does not even finish writing the information to syslog. Only difference I know from the system that does work and this one is that I used a different ubuntu installation CD. Same version. Just downloaded at different times.

Anyone know if there is a command you can run to scan or replace all the components you have on your distribution?

Normally I would just re-install the system from scratch, but one of the systems is a bit difficult to pull from service easily.

Yamanipanuchi
Posts: 90
Joined: Wed May 19, 2010 2:53 am

Re: Zoneminder server locking up.

Post by Yamanipanuchi » Thu Oct 06, 2011 2:15 pm

So im going to just give up on Zoneminder 1.25.0. Seems no matter what type of PC I load it on if locks up.

So far i've tried 3 different PC's, Both Ubuntu and CentOS. Used the posted instructions which seem to work perfectly. Ive used to different build of 1.25.0 that I can find. I have one system with 33 camera's and one with 2 camera's.

Seems no matter what the combonation is the system locks up.

What the kicker is, Is that I have one Zoneminder 1.25.0 working perfectly! This one has 7 camera's on it.

Ill keep scouring the forums to see if there's anyone out there that has had a similar problem.

PacoLM
Posts: 970
Joined: Wed Dec 02, 2009 9:55 pm
Location: Spain

Re: Zoneminder server locking up.

Post by PacoLM » Thu Oct 06, 2011 3:03 pm

Same ZM version, but waht about the dependencies. Have you checked that apache2, perl and all the dependencies are the same?.

mini-ITX system (4 IPCams - Ubuntu20.04 - ZM1.34.15)
TelegramBot

camroidv27
Posts: 35
Joined: Tue Jun 15, 2010 6:18 am

Re: Zoneminder server locking up.

Post by camroidv27 » Wed Oct 12, 2011 3:09 am

Having the same issue here. ZM works for a few hours, then locks up. I was able to SSH into the computer right before it totally locked hard, and reported that the CPU was over 2.0 usage (on a dual core). Maybe there's a process somewhere that keeps stealing resources? I already bumped up the memory in the kernel shmmax and such.

Like the OP, the ZM log has nothing. I have analog cameras using a PV-183 card, with chipset heatsinks and a fan directly blowing. Feels cool to the touch. Computer is an AMD Regor x2 @ 2.8gHz, 4GB RAM. Ubuntu 11.04, that I just installed yesterday (my OS hard drive failed and was replaced)

camroidv27
Posts: 35
Joined: Tue Jun 15, 2010 6:18 am

Re: Zoneminder server locking up.

Post by camroidv27 » Thu Oct 13, 2011 11:19 pm

For the time being, I downgraded to 1.24.4. So far, no issues. Nothing else changed.

camroidv27
Posts: 35
Joined: Tue Jun 15, 2010 6:18 am

Re: Zoneminder server locking up.

Post by camroidv27 » Thu Oct 27, 2011 11:17 pm

I recently did a re-format of my OS drive (well, got a new one since my second old drive failed) and installed Ubuntu 10.04.3 64bit server.
So far so good.

Seeing I have 8 cameras, I kept getting "Not enough ring memory" type errors. I increased the kernel.shmall & kenrel.shmax to 512MB each (I have 4gb of ram, so not too worried). So far so good, and NO errors in my ZM log file.

camroidv27
Posts: 35
Joined: Tue Jun 15, 2010 6:18 am

Re: Zoneminder server locking up.

Post by camroidv27 » Sun Oct 30, 2011 10:57 pm

I bumped my memory settings to 1GB. With all 8 analog cameras going at once, Zoneminder will lock up the computer. Running 5, I am okay. I honestly don't know what more to do.

Post Reply

Who is online

Users browsing this forum: No registered users and 3 guests