Control scripts not working in 1.25.0

Forum for questions and support relating to the 1.25.x releases only.
Post Reply
gmar_87
Posts: 69
Joined: Sat Aug 13, 2011 11:38 pm
Location: Melbourne, Australia

Control scripts not working in 1.25.0

Post by gmar_87 » Sun Sep 11, 2011 3:23 am

I am unable to get my existing Foscam FI8918W control scripts working with 1.25.0.

I have confirmed there are no typos and chmod 777 to all *.pm files.

Log shows:

Code: Select all

2011-09-11 13:19:14.865596	web_php	871	ERR	socket_sendto( /tmp/zm/zms-405465s.sock ) failed: No such file or directory	includes/functions.php	2325
2011-09-11 13:19:11.943530	zmcontrol	2028	FAT	Can't connect: No such file or directory	zmcontrol.pl	
2011-09-11 13:19:11.832452	web_php	869	ERR	/usr/local/bin/zmcontrol.pl --autostop --command=moveConRight --id=1=>	includes/functions.php	2325
2011-09-11 13:19:11.828610	zmcontrol	2026	FAT	Can't connect: No such file or directory	zmcontrol.pl	
The same control script works fine in 1.24.4

Most of the google searches lean towards a typo in file name or path, but i have triple checked and nothing is misspelt...

linuxsense
Posts: 374
Joined: Wed Nov 07, 2007 1:59 am
Location: Huntington Beach, California
Contact:

Re: Control scripts not working in 1.25.0

Post by linuxsense » Sun Sep 11, 2011 8:06 am

You are not alone. I am having the same issue. I have not had much time to look into it but I have not seen any obvious reason for the failure.

Optimist
Posts: 11
Joined: Sun Sep 11, 2011 9:17 am

Re: Control scripts not working in 1.25.0

Post by Optimist » Sun Sep 11, 2011 9:25 am

I had the same problem.

In your FoscamFI8908W.pm file, try replacing line

use ZoneMinder::Debug qw(:all);

with

use ZoneMinder::Logger qw(:all);

It worked for me.

gmar_87
Posts: 69
Joined: Sat Aug 13, 2011 11:38 pm
Location: Melbourne, Australia

Re: Control scripts not working in 1.25.0

Post by gmar_87 » Sun Sep 11, 2011 10:19 am

Optimist wrote:I had the same problem.

In your FoscamFI8908W.pm file, try replacing line

use ZoneMinder::Debug qw(:all);

with

use ZoneMinder::Logger qw(:all);

It worked for me.
Thanks Optimist! That fixed it :)

linuxsense
Posts: 374
Joined: Wed Nov 07, 2007 1:59 am
Location: Huntington Beach, California
Contact:

Re: Control scripts not working in 1.25.0

Post by linuxsense » Mon Sep 12, 2011 7:28 pm

Nice find, fixes the problem for me as well. Makes sense with the new logging in 1.25. Thanks.

User avatar
expertpc
Posts: 5
Joined: Fri Mar 02, 2012 7:07 am

Re: Control scripts not working in 1.25.0

Post by expertpc » Fri Mar 02, 2012 7:41 am

This also helped me fix control problems with the Airlink101 SkyIPCam7xx camera as well so thanks!
Steve B
General Manager
Expert PC

Post Reply

Who is online

Users browsing this forum: No registered users and 8 guests