socket_sendto( /tmp/zm/zms-656085s.sock) on 10.04 LTS 64-bit

Forum for questions and support relating to the 1.25.x releases only.
dhanasekar
Posts: 19
Joined: Mon Aug 29, 2011 4:43 am
Location: Chennai, India

Re: socket_sendto( /tmp/zm/zms-656085s.sock) on 10.04 LTS 64

Post by dhanasekar » Mon Jan 16, 2012 7:34 am

  • web_php 8352 ERR socket_sendto( /tmp/zm/zms-685363s.sock ) failed: No such file or directory zm/includes/functions.php 2322
    zmc_dvideo0 9599 WAR Hue control is not suppported zm_local_camera.cpp 1337
    zmupdate 9612 ERR Error check failed: '500 Can't connect to http://www.zoneminder.com:80 (Bad hostname 'www.zoneminder.com')' zmupdate.pl
    I also face the socket errors with zone minder on debian squeeze distribution.
    Tried changing the permissions of /tmp/zm/ to 755 and also ownership to www-data:www-data but no progress.
  • And no streaming in web browser even after
    copy pasting both the cambozola.jar and its extracted folder cambozola in /usr/share/zoneminder and
    enabling the optional live streaming in the Option->Images
Can anyone get me through the above issues?

gaddman
Posts: 1
Joined: Tue May 15, 2012 10:03 am

Re: socket_sendto( /tmp/zm/zms-656085s.sock) on 10.04 LTS 64

Post by gaddman » Fri Mar 07, 2014 11:15 pm

Replying to an ancient post I know, but this is what the Googlebot pointed me to for the same error with ZM1.25.0 and Ubuntu 13.10. And I got it fixed as below:

Here's what I was seeing in zm logs (/var/log/syslog):

Code: Select all

Mar  8 11:44:14 myserver web_php[1336]: ERR [socket_sendto( /tmp/zm/zms-784531s.sock ) failed: No such file or directory]
Also found this in /var/log/apache2/error.log:

Code: Select all

[Sat Mar 08 11:58:49.297048 2014] [:error] [pid 2418] [client 10.2.1.3:65042] PHP Warning:  strtotime(): It is not safe to rely on the system's timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected the timezone 'UTC' for now, but please set date.timezone to select your timezone. in /usr/share/zoneminder/includes/functions.php on line 1427
Courtesy of Gentoo wiki (won't let me link since I'm a new user) I added my timezone into php.ini (/etc/php5/apache2/php.ini), it was commented out before.

Code: Select all

[Date]
; Defines the default timezone used by the date functions
date.timezone = "Europe/London"
And booya, all is good!

Post Reply

Who is online

Users browsing this forum: No registered users and 2 guests