ZoneMinder 1.25.0 with Foscam FI8918W - Control Problems

Forum for questions and support relating to the 1.25.x releases only.
akon83
Posts: 3
Joined: Thu Dec 27, 2012 6:53 pm

ZoneMinder 1.25.0 with Foscam FI8918W - Control Problems

Postby akon83 » Thu Dec 27, 2012 7:07 pm

Hello guys.

I'm having the toughest time working out the control portion of Foscam FI8918W.

I've followed many instructions online step by step, checking to see that I spelled, capitalized everything appropriately, but still have issues controlling the camera through zoneminder web interface.

I have a two Foscam FI8918W setup on LAN with IPs
192.168.1.150:7090
192.168.1.151:7091

have setup the static IP of my linux (ubuntu) box at 192.168.1.5

I first followed the zoneminder wiki page http://www.zoneminder.com/wiki/index.php/Foscam_FI8918W and performed all steps, installation, config, including setting up the new control script where the user id and pw is sent by the control device.

I also made sure that I set the .pm file name and protocol field exactly same (without space between Foscam and FI8918W)

I have no issues viewing the camera at all, it's just I can't get the control working. Every time I try to play around with it, i get different errors in log file, but the most recent one I'm experiencing is

zmcontrol 5937 ERR Error check failed:'500 Can't connect to 192.168.1.150:80 (Connection refused) zmcontrol.pl null

Few hours ago, I was getting error box popup whenever I tried to control indicating the follow error.

status = undefined
message = /usr/bin/zmcontrol.pl --autostop --command=moveConxxxxx --id=1=>

I don't know what's been changed but I do not see this message any longer.

I also tried chmoding the FoscamFI8918W.pm to 755 but to no avail.

I also changed port from 80 to 9000 on apache server via webmin.


I'd appreciate any help or a direction I can take to even start troubleshooting this.

Please let me know if there are any other details I should provide.

Thanks so much in advance!

luwii
Posts: 8
Joined: Thu Dec 27, 2012 9:24 pm

Re: ZoneMinder 1.25.0 with Foscam FI8918W - Control Problems

Postby luwii » Thu Dec 27, 2012 9:31 pm

Hi,

I'm not an expert here, just did the same as you. Followed the instructions, it took about 2 days to get a Foscam FI8910W up and running with controls. (few days ago)

The problem is that your webcam port is set to port 7090, and and ZM is trying to connect to port 80

192.168.1.150:7090

zmcontrol 5937 ERR Error check failed:'500 Can't connect to 192.168.1.150:80 (Connection refused) zmcontrol.pl null

I suggest you change the camera port to 80 to test it. Unfortunately I don't know where to make the setting change in ZM.

Good luck

akon83
Posts: 3
Joined: Thu Dec 27, 2012 6:53 pm

Re: ZoneMinder 1.25.0 with Foscam FI8918W - Control Problems

Postby akon83 » Thu Dec 27, 2012 9:38 pm

Thanks for your response.

Yea I did notice that the error code was trying to find the camera at port 80.

What is confusing is that Zoneminder has a section where you assign port number of the camera and I did input that which is why the camera feed does show up without a problem. The problem arises when i try to control it.

I have no idea why it's trying to connect to camera at port 80. It's not really reasonble in my case to assign camera to port 80 because I have multiple cameras.

I feel like there should be a different alternative option.

Thanks very much for sharing your insights though. Much appreciated.

luwii
Posts: 8
Joined: Thu Dec 27, 2012 9:24 pm

Re: ZoneMinder 1.25.0 with Foscam FI8918W - Control Problems

Postby luwii » Thu Dec 27, 2012 9:59 pm

Each camera has it's own IP address, so you can have both of them on port 80.

It's only when you are running multiple items on the same IP that you need to use different ports. (e.g. two web servers on one pc needs different ports)

akon83
Posts: 3
Joined: Thu Dec 27, 2012 6:53 pm

Re: ZoneMinder 1.25.0 with Foscam FI8918W - Control Problems

Postby akon83 » Thu Dec 27, 2012 10:05 pm

yes you're right about that.

I will actually try to see if that would resolve the issue at all.

However, does that infer you as well as anyone else running foscam with zoneminder is running the cameras on default http port 80?

Thanks.

luwii
Posts: 8
Joined: Thu Dec 27, 2012 9:24 pm

Re: ZoneMinder 1.25.0 with Foscam FI8918W - Control Problems

Postby luwii » Thu Dec 27, 2012 10:32 pm

Don't know! I saw no reason to change the port ... I'm sure there is a way to do it if you dig deep enough.

The problem I still have, and you may run into it, is that the camera only moves for the first button press. Then the controls stop working. Video feed remains active, just the controls are stuck. Restarting only the web server (nothing else) get's it going, and it then seems to run fine after that. Not a big issue for me at the moment.

But I'm curious to know if you run into the same issue. (I'm on Ubuntu 12)


Return to “ZoneMinder 1.25.x”

Who is online

Users browsing this forum: No registered users and 2 guests