No Monitor on Motion detect

Forum for questions and support relating to the 1.24.x releases only.
atomino_max
Posts: 18
Joined: Mon Jan 23, 2012 11:00 am

No Monitor on Motion detect

Postby atomino_max » Sun Feb 12, 2012 7:42 pm

Hi to all,
after select Modect and clicking on Zones are not showed any image from monitor.

Monitor it's working fine

see attached

Pls help me...
Attachments
md6.png
md6.png (48.41 KiB) Viewed 1470 times

PacoLM
Posts: 896
Joined: Wed Dec 02, 2009 9:55 pm
Location: Spain

Re: No Monitor on Motion detect

Postby PacoLM » Sun Feb 12, 2012 7:53 pm


mini-ITX system (6 IPCams - Ubuntu14.04 - ZM1.29 - ZMNinja)

atomino_max
Posts: 18
Joined: Mon Jan 23, 2012 11:00 am

Re: No Monitor on Motion detect

Postby atomino_max » Sun Feb 12, 2012 8:03 pm

What means "cambozola"

PacoLM
Posts: 896
Joined: Wed Dec 02, 2009 9:55 pm
Location: Spain

Re: No Monitor on Motion detect

Postby PacoLM » Mon Feb 13, 2012 5:10 am

Read the link I posted and check your system.

mini-ITX system (6 IPCams - Ubuntu14.04 - ZM1.29 - ZMNinja)

atomino_max
Posts: 18
Joined: Mon Jan 23, 2012 11:00 am

Re: No Monitor on Motion detect

Postby atomino_max » Mon Feb 13, 2012 8:19 pm

I have modified the file
'/usr/share/zoneminder/skins/classic/includes/functions.php' in this way :



Code:
<script type="text/javascript" src="../javascript/mootools/mootools-core-nc.js"></script>
<script type="text/javascript" src="../javascript/mootools/mootools-more-nc.js"></script>


now I have 4 pointer in for each corner but no image...
Attachments
md7.png
md7.png (53.35 KiB) Viewed 1445 times

PacoLM
Posts: 896
Joined: Wed Dec 02, 2009 9:55 pm
Location: Spain

Re: No Monitor on Motion detect

Postby PacoLM » Mon Feb 13, 2012 10:02 pm

Getting closer...Have your system the default directories (/usr/share/zoneminder/events-images-temp)?. Have you moved the default location?. Check the ownership and permissions of the directories.
Hope it helps!

mini-ITX system (6 IPCams - Ubuntu14.04 - ZM1.29 - ZMNinja)

atomino_max
Posts: 18
Joined: Mon Jan 23, 2012 11:00 am

Re: No Monitor on Motion detect

Postby atomino_max » Tue Feb 14, 2012 6:04 am

Have your system the default directories (/usr/share/zoneminder/events-images-temp)?: yes I have...linked see below
massimiliano@maxnb:~$ ls -la /usr/share/zoneminder
totale 64
drwxr-xr-x 13 root root 4096 2012-01-21 19:28 .
drwxr-xr-x 356 root root 12288 2012-01-23 11:25 ..
drwxr-xr-x 2 root root 4096 2012-01-21 19:28 ajax
lrwxrwxrwx 1 root root 17 2012-01-21 19:28 cgi-bin -> ../../lib/cgi-bin
drwxr-xr-x 2 root root 4096 2012-01-21 19:28 css
drwxr-xr-x 2 root root 4096 2012-01-21 19:28 db
lrwxrwxrwx 1 root root 28 2012-01-21 19:28 events -> /var/cache/zoneminder/events
drwxr-xr-x 2 root root 4096 2012-01-21 19:28 graphics
lrwxrwxrwx 1 root root 28 2012-01-21 19:28 images -> /var/cache/zoneminder/images
drwxr-xr-x 2 root root 4096 2012-01-21 19:28 includes
-rw-r--r-- 1 root root 3717 2011-01-17 12:31 index.php
drwxr-xr-x 2 root root 4096 2011-01-17 12:31 js
drwxr-xr-x 2 root root 4096 2012-01-21 19:28 lang
drwxr-xr-x 4 root root 4096 2012-01-21 19:28 skins
drwxr-xr-x 2 root root 4096 2011-01-17 12:31 sounds
lrwxrwxrwx 1 root root 26 2012-01-21 19:28 temp -> /var/cache/zoneminder/temp
drwxr-xr-x 2 root root 4096 2011-01-17 12:31 tools
drwxr-xr-x 2 root root 4096 2011-01-17 12:31 views
massimiliano@maxnb:~$



Have you moved the default location? What have I to do to move the default location ?
Check the ownership and permissions of the directories: what directories have i to check...

Be patient for my not experience...

PacoLM
Posts: 896
Joined: Wed Dec 02, 2009 9:55 pm
Location: Spain

Re: No Monitor on Motion detect

Postby PacoLM » Tue Feb 14, 2012 8:11 am

Try changing the ownership from root to www-data:

Stop zoneminder, then:

Code: Select all

 chown -R www-data:www-data /usr/share/zoneminder/events
 chown -R www-data:www-data /usr/share/zoneminder/images
 chown -R www-data:www-data /usr/share/zoneminder/temp


Restart zoneminder, check if image appears in the zone settings.

mini-ITX system (6 IPCams - Ubuntu14.04 - ZM1.29 - ZMNinja)

atomino_max
Posts: 18
Joined: Mon Jan 23, 2012 11:00 am

Re: No Monitor on Motion detect

Postby atomino_max » Tue Feb 14, 2012 8:51 pm

after changing the owner to www-data no image on zone and also the monitor it's not showing anything, so i return to root owner..

camsystem
Posts: 32
Joined: Fri Aug 12, 2011 8:35 pm

Re: No Monitor on Motion detect

Postby camsystem » Tue Feb 14, 2012 10:19 pm

I had a similar issue with my zones. I had to run make install again from the ZM directory to get the ability to have the zones again. I word of caution, you will have to recreate all your cameras. Make sure you have all the setting recorded first. Also back up any pictures or videos you want to save first.
Good luck!

atomino_max
Posts: 18
Joined: Mon Jan 23, 2012 11:00 am

Re: No Monitor on Motion detect

Postby atomino_max » Wed Feb 15, 2012 9:19 pm

sorry ...where is the zm directory to remake ...
I have installed directly fron sudo apt-get install....


thanks

Schuhkasten
Posts: 48
Joined: Thu Jun 03, 2010 6:43 am

Re: No Monitor on Motion detect

Postby Schuhkasten » Sun Feb 19, 2012 7:45 am

Hello

I have exactly the same problem.
http://www.zoneminder.com/forums/viewtopic.php?f=21&t=18809

sudo apt-get remove zoneminder and afterwards
sudo apt-get install zoneminder

did not really help!

atomino_max
Posts: 18
Joined: Mon Jan 23, 2012 11:00 am

Re: No Monitor on Motion detect

Postby atomino_max » Mon Feb 20, 2012 10:37 am

I have tried to remove and install again but not nothing successful, ..
now I am trying with new version 1.25.0, but i am not lucky, I have configured, compiled and install
but it's not running...I have to a open a new post

Schuhkasten
Posts: 48
Joined: Thu Jun 03, 2010 6:43 am

Re: No Monitor on Motion detect

Postby Schuhkasten » Sun Feb 26, 2012 8:20 am

Any news how to solve it? Seems to be a problem with 10.04... Mainly...

Schuhkasten
Posts: 48
Joined: Thu Jun 03, 2010 6:43 am

Re: No Monitor on Motion detect

Postby Schuhkasten » Sun Feb 26, 2012 4:10 pm

Is here no one that can help? Also compiling 1.24.4 does not work see other new thread!

Why is this SW sooo complex?


Return to “ZoneMinder 1.24.x”

Who is online

Users browsing this forum: No registered users and 1 guest