Zoneminder or Apache hanging when watching events

Forum for questions and support relating to the 1.24.x releases only.
tcg
Posts: 16
Joined: Fri Jan 13, 2012 3:41 pm

Zoneminder or Apache hanging when watching events

Postby tcg » Sat Feb 04, 2012 7:35 pm

I'm running Zoneminder 1.24.4 on Ubuntu 11.04. I have a PV-149 card with two cameras attached to input 1 and input 2. The camera on input 1 has been up and running for a couple of months with no problems. I just added the second one today.

When I try to watch a recorded motion detect event from camera 2, zm or apache seems to hang. The browser says "transferring data from zm" at the bottom but the video never moves. I then have to restart apache in order to get things working again.

The two inputs are configured exactly the same and I can watch live video from either camera without problems. It's only when I try to watch a recorded event on camera 2 that I have problems.

The apache process doesn't actually die though. It's still running but is unresponsive.

Any ideas on how to debug this? I can't seem to find anything useful in the apache or zoneminder logs.
Chris

bb99
Posts: 943
Joined: Wed Apr 02, 2008 12:04 am

Re: Zoneminder or Apache hanging when watching events

Postby bb99 » Sat Feb 04, 2012 8:38 pm

Try deleting the second monitor and then recreating it. Experienced something similar and turned out to be a MySQL issue. Recreating monitor fixed without having to screw with DB.

sgn
Posts: 68
Joined: Mon Oct 25, 2004 2:36 pm

Re: Zoneminder or Apache hanging when watching events

Postby sgn » Sun Feb 05, 2012 11:00 am

This happens to me as well, usually after streaming for ~5 minutes and closing the window. I had to make a cron script that kills (hangs) and restarts apache every fifteen minutes.

tcg
Posts: 16
Joined: Fri Jan 13, 2012 3:41 pm

Re: Zoneminder or Apache hanging when watching events

Postby tcg » Sun Feb 05, 2012 1:09 pm

bb99 wrote:Try deleting the second monitor and then recreating it. Experienced something similar and turned out to be a MySQL issue. Recreating monitor fixed without having to screw with DB.


That did it. I deleted the second monitor, rebooted and then recreated it. It works fine now. Thanks!
Chris


Return to “ZoneMinder 1.24.x”

Who is online

Users browsing this forum: Yahoo [Bot] and 1 guest