Ubuntu 10.04 Desktop install-httpd unrecognized service SOLV

Forum for questions and support relating to the 1.24.x releases only.
Post Reply
GrayBeardNerd
Posts: 9
Joined: Wed Aug 03, 2011 8:02 pm

Ubuntu 10.04 Desktop install-httpd unrecognized service SOLV

Post by GrayBeardNerd » Tue Aug 30, 2011 3:17 am

I used the Wiki "Ubuntu 10.04 (Lucid Lynx) Desktop" install instructions and followed them exactly.

I am running on Ubuntu 10.04 (64 bit) Kernel Linus 2.6.32-33 generic (I also tried 32 bit) clean install followed by updates - AMD Phenom II X6 1055T


When I do the service httpd start, I get "httpd: unrecognized service"

Does this mean that there is something wrong with apache2?


I do a service zoneminder start and I can get the console (localhost/zm)

My camera shows up fine with XawTV

I bring up the ZoneMinder Console - Running - v1.24.2

I've created a single local monitor with defaults including /dev/vedeo (0) and NTSC

On the ZM Console, I clink on Monitor-1 and get the window, but it always says, "Waiting for localhost..."


During the install when it said Starting web server apache2,
apache2: Could not reliably determine the server's fully qualified domain name, using 127 0 1 1 for ServerName.

No crash messages from apache2.

My /etc/apache2/httpd.conf file is empty.


If I search the forum with "+httpd +unrecognized +service" I get one match with someone with a Fedora issue and a response to install apache2.

Google gives a bewildering variety of answers to the missing service. Apache org only has one hit on the search.

This is the fourth time I've formatted the disc and started the install. I don't understand what I am doing different from the Wiki instructions.
Last edited by GrayBeardNerd on Mon Oct 17, 2011 2:15 am, edited 1 time in total.

bb99
Posts: 943
Joined: Wed Apr 02, 2008 12:04 am

Re: Ubuntu 10.04 Desktop install - httpd unrecognized servi

Post by bb99 » Tue Aug 30, 2011 10:58 am

I'm going to suggest that your "hosts" file does not have a localhost entry. You can edit it or try http//:127.0.1.1/zm (usually 127.0.0.1, not sure why the 127.0.1.1) and see if that gets you to the main page.

GrayBeardNerd
Posts: 9
Joined: Wed Aug 03, 2011 8:02 pm

Re: Ubuntu 10.04 Desktop install - httpd unrecognized servi

Post by GrayBeardNerd » Tue Aug 30, 2011 6:04 pm

Thanks for the info bb99.

I looked at my /etc/hosts file and it has
127.0.0.1 localhost
127.0.1.1 zzz-desktop
and IPv6 stuff


When I try 127.0.1.1/zm in my Firefox, I get the same console that I get with localhost
and if I click on Monitor-1 in the Name column, I get the same window with "Waiting for 127.0.1.1..."


On previous attempts, I tried to uninstall apache2, then reinstalled it, and that just made a mess.

It is a local camera that goes to a Black Cherry PV-149PA board and I am trying to view it on the PC with the Black Cherry board. The ZoneMinder console appears to work, except viewing the monitor. This is my first time trying to use ZoneMinder, so I don't know what is expected behavior.

bb99
Posts: 943
Joined: Wed Apr 02, 2008 12:04 am

Re: Ubuntu 10.04 Desktop install - httpd unrecognized servi

Post by bb99 » Tue Aug 30, 2011 10:51 pm

Check to see if the "'deny from all' delete this line" entry has been removed from /etc/httpd/conf.d/zoneminder.conf; just a guess here...

GrayBeardNerd
Posts: 9
Joined: Wed Aug 03, 2011 8:02 pm

Re: Ubuntu 10.04 Desktop install - httpd unrecognized servi

Post by GrayBeardNerd » Wed Aug 31, 2011 2:16 am

Good catch bb99.

The /etc/apache2/conf.d/zoneminder.conf link was misnamed zoneinder.conf. I corrected that with a new ln command and there is no change in symptoms. I didn't find an httpd folder in /etc.

I had also changed /etc/apache2/httpd.conf and /etc/hosts, and that made the "Could not determine the server's fully qualified domain name" message go away.

The two symptoms remaining are: the command service httpd start gives unrecognized service and in the ZoneMinder Console window, clicking on the Monitor-1 link opens the Monitor-1 window and shows the controls, but no video and the status line shows "Waiting for localhost..."


The file is from the /var/log/apache2/error.log

bb99
Posts: 943
Joined: Wed Apr 02, 2008 12:04 am

Re: Ubuntu 10.04 Desktop install - httpd unrecognized servi

Post by bb99 » Wed Aug 31, 2011 10:56 am


bb99
Posts: 943
Joined: Wed Apr 02, 2008 12:04 am

Re: Ubuntu 10.04 Desktop install - httpd unrecognized servi

Post by bb99 » Thu Sep 01, 2011 3:54 am

Continued from: http://www.zoneminder.com/forums/viewto ... 21&t=17807

Most of this forum is best guess, some good, some not so good. I'm guessing (reads like) we're down to a palette choice; Try BGR24, post back.

GrayBeardNerd
Posts: 9
Joined: Wed Aug 03, 2011 8:02 pm

Re: Ubuntu 10.04 Desktop install - httpd unrecognized servi

Post by GrayBeardNerd » Thu Sep 01, 2011 4:10 am

Oh, that's just amazing bb99!

I now have video. TYSM!

To recap for the thread,
edited the hosts file
delay the startup of zoneminder for a race condition
ensure that device matches exactly
changed from RGB24 to BGR24

bb99
Posts: 943
Joined: Wed Apr 02, 2008 12:04 am

Re: Ubuntu 10.04 Desktop install - httpd unrecognized servi

Post by bb99 » Thu Sep 01, 2011 4:15 am

Perfect! Enjoy ZM it's really very good. Keep in mind that to increase your resolution you will need to pay attention to how much shared memory you've allocated.... Please edit the title to "solved", makes others searching the forum very easy to select a winner.

Post Reply

Who is online

Users browsing this forum: No registered users and 2 guests