Errors in Zm compile on 11.04, how to fix?

Forum for questions and support relating to the 1.24.x releases only.
Post Reply
User avatar
kp4djt
Posts: 212
Joined: Mon Jun 18, 2007 1:53 am
Location: Tampa, FL
Contact:

Errors in Zm compile on 11.04, how to fix?

Post by kp4djt » Sat Jul 02, 2011 12:55 pm

Folks,
I have done a couple of the ZM setups with the 11.04 instructions,
one prior to the addition of the script to remove the need to use
nano and edit those lines, the 2nd after that was removed by the
script. Both worked OK.

Today I went to do a build, and in the building of the ZM code I
got the following Warning, there were a lot but this looked a bit
more serious than the rest:

Code: Select all

root@zmtest02:/usr/src/zm# autoconf
aclocal.m4:16: warning: this file was generated for autoconf 2.65.
You have another version of autoconf.  It may work, but is not guaranteed to.
If you have problems, you may need to regenerate the build system entirely.
To do so, use the procedure documented by the package, typically `autoreconf'.
OK, so I prayed that the "It may work" would be true but perhaps not
here is the first sign of a problem beyond the usual bunch of warnings:

Code: Select all

zm_mpeg.cpp: In member function ‘double VideoStream::EncodeFrame(uint8_t*, int, bool, unsigned int)’:
zm_mpeg.cpp:359:16: error: ‘AV_AV_PKT_FLAG_KEY’ was not declared in this scope
zm_mpeg.cpp:390:18: error: ‘AV_AV_PKT_FLAG_KEY’ was not declared in this scope
make[2]: *** [zm_mpeg.o] Error 1
make[2]: Leaving directory `/usr/src/zm/src'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/usr/src/zm'
make: *** [all] Error 2
I press on for one more but get this far:

Code: Select all

zm_mpeg.cpp: In member function ‘double VideoStream::EncodeFrame(uint8_t*, int, bool, unsigned int)’:
zm_mpeg.cpp:359:16: error: ‘AV_AV_PKT_FLAG_KEY’ was not declared in this scope
zm_mpeg.cpp:390:18: error: ‘AV_AV_PKT_FLAG_KEY’ was not declared in this scope
make[1]: *** [zm_mpeg.o] Error 1
make[1]: Leaving directory `/usr/src/zm/src'
make: *** [install-recursive] Error 1
root@zmtest02:/usr/src/zm# 
Again, same error, I am trying to figure out where the problem is but I
am not that good at digging in the code.

Can I get some direction or guidance here

I sure see a lot more warnings since the last time I did this ( about a week
ago) I wonder what has changed, I am assuming that something has been
changed in the updates which ran at the beginning of the whole thing.
Chuck Hast -- KP4DJT --
Web site www.wchast.com
ZM demo www.wchast.com/zm

User avatar
zoneminder
Site Admin
Posts: 5220
Joined: Wed Jul 09, 2003 2:07 pm
Location: Bristol, UK
Contact:

Re: Errors in Zm compile on 11.04, how to fix?

Post by zoneminder » Sat Jul 02, 2011 9:13 pm

What version of ZM do you have?

You should not need to run autoconf, but if you do then you should probably also run aclocal, acheader and automake, or autoreconf. Otherwise you will have your config tools generated from various different versions of the config meta-tools. Even so, that warning is overly cautious I have found, I've never hit a problem with it.

The AV_AV_PKT_* issue I think is down to the fact that those constants should just be AV_PKT_* but I don't know how you got a version where that is broken as I don't know that there is one.
Phil

User avatar
kp4djt
Posts: 212
Joined: Mon Jun 18, 2007 1:53 am
Location: Tampa, FL
Contact:

Re: Errors in Zm compile on 11.04, how to fix?

Post by kp4djt » Sat Jul 02, 2011 10:29 pm

Thank you for the fast reply. I followed the instructions on the wiki for 11.04 64bit
http://www.zoneminder.com/wiki/index.ph ... _Cambozola

I cut and paste the instructions, it worked two times before, the first
time I did it the changes in the area where several lines were pasted
into a script using nano had not been changed, the second time I did
it those mods had been incorporated, so I tried it both ways. and both
worked just fine.

This time I did not get such luck. I am assuming that the code is going
out and pulling down the latest and greatest version. But indeed I did
not see which ver it tried to load. I will see if I can see. It appears that
it tries to pull down whatever is listed as the latest available.

Has there been any work on getting audio into the system. I have a
couple of guys that want it, I am trying to see if I can get one of them
to spring for some $$ for dev on that front if someone is working on
it please say so in order to see about getting some additional monetary
aid in that direction.
Chuck Hast -- KP4DJT --
Web site www.wchast.com
ZM demo www.wchast.com/zm

Post Reply

Who is online

Users browsing this forum: No registered users and 6 guests