zm 1.24.4 ppa for ubuntu natty

Forum for questions and support relating to the 1.24.x releases only.
Post Reply
User avatar
iconnor
Posts: 785
Joined: Fri Oct 29, 2010 1:43 am
Location: Toronto
Contact:

zm 1.24.4 ppa for ubuntu natty

Post by iconnor » Tue Jun 28, 2011 5:43 pm

Anyone wanting an easy option for running 1.24.4 on natty, I have created a PPA at ppa:iconnor/zoneminder

This also contains some changes by me to allow zm to be easily distributed across multiple machines (to handle more cameras). As such, it will not automatically install mysql server.

It is an ongoing effort, and my first ppa. It works for me, but YMMV.

sogood007
Posts: 25
Joined: Tue Oct 26, 2004 6:53 pm

Re: zm 1.24.4 ppa for ubuntu natty

Post by sogood007 » Thu Jun 30, 2011 6:32 am

I just come across you ppa and installed in my natty. However, the install fail with error. (one with the ZM_SERVER_HOST empty value, and the after that I got
Starting ZoneMinder: DBD::mysql::st execute failed: Unknown column 'ServerHost' in 'where clause' at /usr/bin/zmpkg.pl line 183.
Can't execute: Unknown column 'ServerHost' in 'where clause' at /usr/share/perl5/ZoneMinder/Debug.pm line 349
ZoneMinder::Debug::Fatal('Can\'t execute: Unknown column \'ServerHost\' in \'where clau...') called at /usr/bin/zmpkg.pl line 183
failure

I also tried install zoneminder from source on natty. I got issue streaming on the web (I am sure the camera capture work as I can see each frame jpeg but just not stream able). I wonder that is problem with ffmpeg. I haven't debug too much. Do you have instruction of using ppa? I am happy to try it.

User avatar
iconnor
Posts: 785
Joined: Fri Oct 29, 2010 1:43 am
Location: Toronto
Contact:

Re: zm 1.24.4 ppa for ubuntu natty

Post by iconnor » Mon Jul 11, 2011 4:16 pm

I have been making more changes, and I believe I have fixed these issues.

apt-get update && apt-get dist-upgrade should do the trick.

This is a work-in-progress. Thanks for giving it a try!

marcschh
Posts: 10
Joined: Mon Jul 11, 2011 8:48 pm

Re: zm 1.24.4 ppa for ubuntu natty

Post by marcschh » Mon Jul 11, 2011 8:54 pm

Hi,

will there be a chance for packaging it also for Lucid 10.04 ?

Regards
Marc

who has many trouble with installing from source on lucid (will open an extra thread in near future)

User avatar
iconnor
Posts: 785
Joined: Fri Oct 29, 2010 1:43 am
Location: Toronto
Contact:

Re: zm 1.24.4 ppa for ubuntu natty

Post by iconnor » Mon Jul 11, 2011 9:11 pm

I'm not likely to build it for lucid anytime soon. I just don't have any lucid boxes available.

vraa
Posts: 31
Joined: Mon May 23, 2011 6:28 am

Re: zm 1.24.4 ppa for ubuntu natty

Post by vraa » Mon Jul 11, 2011 9:24 pm

Can you expand in more detail of some of the changes you have made? Do they include x264? libjpeg turbo?

racelife
Posts: 61
Joined: Mon Mar 22, 2010 11:38 pm

Re: zm 1.24.4 ppa for ubuntu natty

Post by racelife » Tue Jul 12, 2011 11:53 pm

I second vraa does it include Turbo and I read somewhere about a system optimization sript to decrease load? I plan on re doing my server from the ground up in the next week or so.

PacoLM
Posts: 967
Joined: Wed Dec 02, 2009 9:55 pm
Location: Spain

Re: zm 1.24.4 ppa for ubuntu natty

Post by PacoLM » Wed Jul 13, 2011 5:45 am

Hi,

I got this error while installing the version 1.24.9:

Code: Select all

Configurando zoneminder (1.24.4-9) ...
Starting ZoneMinder: zmfix: relocation error: /usr/local/lib/libavcore.so.0: symbol av_expr_parse_and_eval, version LIBAVUTIL_50 not defined in file libavutil.so.50 with link time reference
DBI connect('database=zm;host=localhost','zmuser',...) failed: Unknown database 'zm' at /usr/share/perl5/ZoneMinder/Config.pm line 90
Can't call method "prepare_cached" on an undefined value at /usr/share/perl5/ZoneMinder/Config.pm line 92.
BEGIN failed--compilation aborted at /usr/share/perl5/ZoneMinder/Config.pm line 101.
Compilation failed in require at /usr/share/perl5/ZoneMinder.pm line 33.
BEGIN failed--compilation aborted at /usr/share/perl5/ZoneMinder.pm line 33.
Compilation failed in require at /usr/bin/zmpkg.pl line 46.
BEGIN failed--compilation aborted at /usr/bin/zmpkg.pl line 46.
failure
invoke-rc.d: initscript zoneminder, action "start" failed.
I have to say that before installing the package, I have been struggling during days trying to upgrade my 1.24.2 system to 1.24.4 or 1.25 without success, so maybe there's some trash left. Could you tell me which files do I need to clean/delete in order to have a clean installation?

Regards,

PacoLM

mini-ITX system (6 IPCams - Ubuntu14.04 - ZM1.31.1)

User avatar
pete_c
Posts: 88
Joined: Thu Jan 24, 2008 3:21 am
Location: USA

Re: zm 1.24.4 ppa for ubuntu natty

Post by pete_c » Tue Jul 19, 2011 11:15 am

Isaac,

Thank you for your post relating to the ZM Debian install of ZM 1.24.4.

I am testing two step by steps to ZM 1.24.4. First 5 minute install is working but really too slow right now to be of use. Yours appears to be working but missing some configs, libraries and final ZM MySQL setup pieces.

I'm getting a similiar error after a couple of attempts.
~# service zoneminder start
Starting ZoneMinder: DBI connect('database=zm;host=localhost','zmuser',...) failed: Access denied for user 'zmuser'@'localhost' (using password: YES) at /usr/share/perl5/ZoneMinder/Config.pm line 90
Can't call method "prepare_cached" on an undefined value at /usr/share/perl5/ZoneMinder/Config.pm line 92.
BEGIN failed--compilation aborted at /usr/share/perl5/ZoneMinder/Config.pm line 101.
Compilation failed in require at /usr/share/perl5/ZoneMinder.pm line 33.
BEGIN failed--compilation aborted at /usr/share/perl5/ZoneMinder.pm line 33.
Compilation failed in require at /usr/bin/zmpkg.pl line 46.
BEGIN failed--compilation aborted at /usr/bin/zmpkg.pl line 46.
failure
Just to recap steps - Please tell me if this is correct
1 - Install base of Ubuntu 11.04 Server
2 - Options are SSH and LAMP server
3 - Install posted Debian release

First time run appears to be missing some libraries so I :
apt-get -y install libavcodec-extra-52 libavformat-extra-52 libswscale-extra-0 libavfilter-extra-1
I know I'm still missing apache2 configs (unless they are included in the Debian release).

A step by step included precursor files; configurations of ZM before first run would help.

Any suggestions?
Zoneminder User

Box #1 and # 2 - Intel Ubuntu 14.04 64 bit server - Most current beta 1.28 - XX HD IP cams
Box #3 - AMD Ubuntu 14.04 64 bit server - Most current beta 1.28 - XX HD IP cams
Moved rest of analogue cams to Axis Servers and Grandstream cams.

User avatar
iconnor
Posts: 785
Joined: Fri Oct 29, 2010 1:43 am
Location: Toronto
Contact:

Re: zm 1.24.4 ppa for ubuntu natty

Post by iconnor » Tue Jul 19, 2011 3:19 pm

Something to be aware of: the stuff that sets up the database has been removed (it needs to go in it's own package). So you need to create the db yourself wherever it should go.

You might find it easiest to first install zoneminder-1.24.2 from the standard ubuntu, and then add my ppa and upgrade to it.

Isaac

User avatar
pete_c
Posts: 88
Joined: Thu Jan 24, 2008 3:21 am
Location: USA

Re: zm 1.24.4 ppa for ubuntu natty

Post by pete_c » Tue Jul 19, 2011 4:10 pm

Thanks Isaac!
Zoneminder User

Box #1 and # 2 - Intel Ubuntu 14.04 64 bit server - Most current beta 1.28 - XX HD IP cams
Box #3 - AMD Ubuntu 14.04 64 bit server - Most current beta 1.28 - XX HD IP cams
Moved rest of analogue cams to Axis Servers and Grandstream cams.

eufreka
Posts: 15
Joined: Tue Jun 14, 2011 4:07 pm

Re: zm 1.24.4 ppa for ubuntu natty

Post by eufreka » Fri Jul 22, 2011 10:10 pm

iconnor wrote:Something to be aware of: the stuff that sets up the database has been removed (it needs to go in it's own package). So you need to create the db yourself wherever it should go.

You might find it easiest to first install zoneminder-1.24.2 from the standard ubuntu, and then add my ppa and upgrade to it.

Isaac
This approach did not work for me. Zoneminder will no longer start (strict subs error).

awg137
Posts: 3
Joined: Fri Jul 22, 2011 2:28 am

Re: zm 1.24.4 ppa for ubuntu natty

Post by awg137 » Thu Jul 28, 2011 4:06 am

I have installed 1.24.4 from ppa and I see the following message in the syslog:

zmfix[2394]: ERR [Can't run query: Unknown column 'serverhost' in 'where clause']

Where is the serverhost column set and how is it used?

tea4two
Posts: 6
Joined: Fri Jul 29, 2011 6:22 am

Re: zm 1.24.4 ppa for ubuntu natty

Post by tea4two » Mon Aug 01, 2011 6:03 pm

Hi Isaac,
I tried to use your repository in natty with success, but to have ZM working I need to create, after package install, the DB running the zm_create.sql by hand.

I installed the libjpeg-turbo, but it seems that ZM compiled by you not support these.

It's true ?
There is a way to use libjpeg-turbo without compile ZM from SVN ?

Thanks in advance

- Pierluigi

Post Reply

Who is online

Users browsing this forum: No registered users and 2 guests