/dev/video0 is missing

Forum for questions and support relating to the 1.24.x releases only.
Post Reply
resuni
Posts: 15
Joined: Fri Jul 09, 2010 6:11 pm
Location: Colorado Springs, CO, USA
Contact:

/dev/video0 is missing

Post by resuni » Sun Jun 19, 2011 9:29 pm

I got to the "Check that your Camera Works" part of the Documentation where I started running into problems. I tried running xawtv as suggested and got this error:

Code: Select all

brad@bigbrother:~$ xawtv
This is xawtv-3.95.dfsg.1, running on Linux/x86_64 (2.6.32-5-amd64)
v4l2: open /dev/video0: No such file or directory
v4l2: open /dev/video0: No such file or directory
v4l: open /dev/video0: No such file or directory
no video grabber device available
I'm running Zoneminder 1.24.2-8 on Debian Squeeze. I'm using a BlueCherry BC-16480A video capture card (I would post a link but I'm apparently not allowed to :evil: ).

I did try installing a driver I found via git but there's still no video0 in my /dev/ directory. Again, I would post a link to the driver but I'm not allowed to post links. Anyone know what could be the problem?

allangood
Posts: 12
Joined: Mon Jun 06, 2011 3:00 pm

Re: /dev/video0 is missing

Post by allangood » Tue Jul 05, 2011 12:57 am

Hello,

you will have the same problem that I have. ZoneMinder doesn't work with this capture card (with compression)...
You need to compile the solo6x10 driver (I can't post url's too... :x ), but below I post the how to

Look at my post: (no hope to us)
http://www.zoneminder.com/forums/viewto ... bluecherry

How to compile solo6x10 driver:

If you using ubuntu:
sudo add-apt-repository ppa:ben-collins/solo6x10
sudo apt-get update
sudo apt-get install solo6010-dkms
sudo modprobe solo6x10

If not, you must download the source and compile it.

But... will be an waste of time...

I'm trying to change the code of mplayer to pass a single JPEG file to ZoneMinder and put it to work if this card...
This hardware is to expansive to be a paper height!

So, good look to everyone who bought this card (including, me)...

curtishall
Posts: 440
Joined: Sat Sep 25, 2004 12:45 am
Location: Fulton, MO
Contact:

Re: /dev/video0 is missing

Post by curtishall » Mon Aug 22, 2011 7:39 am

For the record you need to use the Github driver, as the PPA hasn't been updated in six months:

https://github.com/bluecherrydvr/solo6x10
--
Curtis Hall
Bluecherry
www.bluecherrydvr.com
store.bluecherry.net

Post Reply

Who is online

Users browsing this forum: No registered users and 14 guests