Ubtuntu 11.04, ZM 1.24.4: zmpkg : relocation error [SOLVED]

Forum for questions and support relating to the 1.24.x releases only.
Post Reply
mmgg
Posts: 25
Joined: Sun Feb 24, 2008 10:35 am

Ubtuntu 11.04, ZM 1.24.4: zmpkg : relocation error [SOLVED]

Post by mmgg » Sat Jun 18, 2011 12:55 pm

Dear,

I built from src the ZM1.2.24 and ffmpeg according to the procedure in the wiki.
When I try to start zm, I got:

zmpkg.pl start
/usr/local/bin/zmfix: relocation error: /usr/local/lib/libavcore.so.0: symbol av_expr_parse_and_eval, version LIBAVUTIL_50 not defined in file libavutil.so.50 with link time reference


It's strange to me, zm doesn't use the same libraries as ffmpeg... (ffmpeg uses libavutil.so.51, while zm uses libavutil.so.50):
ldd `which ffmpeg`
linux-gate.so.1 => (0x0095a000)
libavdevice.so.53 => /usr/local/lib/libavdevice.so.53 (0x00133000)
libavfilter.so.2 => /usr/local/lib/libavfilter.so.2 (0x00719000)
libavformat.so.53 => /usr/local/lib/libavformat.so.53 (0x0013b000)
libavcodec.so.53 => /usr/local/lib/libavcodec.so.53 (0x0095b000)
libpostproc.so.51 => /usr/local/lib/libpostproc.so.51 (0x00110000)
libswscale.so.0 => /usr/local/lib/libswscale.so.0 (0x00462000)
libavutil.so.51 => /usr/local/lib/libavutil.so.51 (0x00240000)
libm.so.6 => /lib/i386-linux-gnu/libm.so.6 (0x00261000)
libpthread.so.0 => /lib/i386-linux-gnu/libpthread.so.0 (0x00287000)
libc.so.6 => /lib/i386-linux-gnu/libc.so.6 (0x002a0000)
libbz2.so.1.0 => /lib/libbz2.so.1.0 (0x0011b000)
libz.so.1 => /lib/i386-linux-gnu/libz.so.1 (0x00920000)
/lib/ld-linux.so.2 (0x00431000)

ls -l libavcore*
-rw-r--r-- 1 root root 70212 2011-06-16 21:30 libavcore.a
lrwxrwxrwx 1 root root 19 2011-06-16 21:30 libavcore.so -> libavcore.so.0.16.1
lrwxrwxrwx 1 root root 19 2011-06-16 21:30 libavcore.so.0 -> libavcore.so.0.16.1
-rwxr-xr-x 1 root root 22964 2011-06-16 21:30 libavcore.so.0.16.1



Any idea on the cause and on how I can fix this?

Thansk for helping

MArc
Last edited by mmgg on Sun Jun 19, 2011 9:14 am, edited 1 time in total.

mmgg
Posts: 25
Joined: Sun Feb 24, 2008 10:35 am

Re: Ubtuntu 11.04, ZM 1.24.4: zmpkg : relocation error

Post by mmgg » Sun Jun 19, 2011 9:14 am

Dear,

Don't try to build your ffmpeg libraries as indicated in the wiki for the Ubuntu 11.04.
Just do an apt-get install ffmpeg... and compile zm... it worked in my case

Rgds

MArc

awg137
Posts: 3
Joined: Fri Jul 22, 2011 2:28 am

Re: Ubtuntu 11.04, ZM 1.24.4: zmpkg : relocation error [SOLV

Post by awg137 » Fri Jul 22, 2011 2:30 am

This fix is not working for me. I'm installing ZM 1.24.4 on Ubuntu 11.04 and I get the following error when I start:

/usr/local/bin/zmfix: relocation error: /usr/local/lib/libavcore.so.0: symbol av_expr_parse_and_eval, version LIBAVUTIL_50 not defined in file libavutil.so.50 with link time reference

Any ideas what this means or how to fix it?

Thanks...

flamebird
Posts: 4
Joined: Tue Sep 13, 2011 12:59 pm

Re: Ubtuntu 11.04, ZM 1.24.4: zmpkg : relocation error [SOLV

Post by flamebird » Wed Sep 14, 2011 2:12 pm

Installing ffmpeg with apt-get didn't resolve this for me either.. Is there any other way to fix this?

Thanks

Post Reply

Who is online

Users browsing this forum: No registered users and 2 guests