1.24.3 SVN with ffmpeg error - SOLVED

Forum for questions and support relating to the 1.24.x releases only.
Post Reply
beire
Posts: 15
Joined: Sun Sep 05, 2010 10:55 pm
Location: België

1.24.3 SVN with ffmpeg error - SOLVED

Post by beire » Sun Jan 16, 2011 4:24 pm

I haven been running 1.24.3 SVN fine for the last few weeks but for zmstreamer i want to recompile with the "--with-ffmpeg=" configure line.

Make and make install run fine, yet upon starting zoneminder i get the following error:

Code: Select all

Starting ZoneMinder: /usr/local/bin/zmfix: relocation error: /usr/local/lib/libavcore.so.0: symbol av_get_random_seed, version LIBAVUTIL_50 not defined in file libavutil.so.50 with link time reference
failure
I have all libraries installed:

Code: Select all

root@ctx:/usr/src/zm# ldd `which ffmpeg`
	linux-gate.so.1 =>  (0xb76e9000)
	libavdevice.so.52 => /usr/local/lib/libavdevice.so.52 (0xb76dd000)
	libavfilter.so.1 => /usr/local/lib/libavfilter.so.1 (0xb76c1000)
	libavformat.so.52 => /usr/local/lib/libavformat.so.52 (0xb75d4000)
	libavcodec.so.52 => /usr/local/lib/libavcodec.so.52 (0xb6afc000)
	libswscale.so.0 => /usr/local/lib/libswscale.so.0 (0xb6ac1000)
	libavcore.so.0 => /usr/local/lib/libavcore.so.0 (0xb6abb000)
	libavutil.so.50 => /usr/local/lib/libavutil.so.50 (0xb6aa1000)
	libm.so.6 => /lib/libm.so.6 (0xb6a74000)
	libpthread.so.0 => /lib/libpthread.so.0 (0xb6a5a000)
	libc.so.6 => /lib/libc.so.6 (0xb68fd000)
	libbz2.so.1.0 => /lib/libbz2.so.1.0 (0xb68eb000)
	libz.so.1 => /lib/libz.so.1 (0xb68d6000)
	libx264.so.112 => /usr/local/lib/libx264.so.112 (0xb67ea000)
	/lib/ld-linux.so.2 (0xb76ea000)
i'm using the following .configure line:

Code: Select all

CXXFLAGS=-D__STDC_CONSTANT_MACROS ZM_SSL_LIB=openssl ./configure --with-webdir=/var/www/zm --with-cgidir=/usr/lib.cgi-bin --with-webuser=www-data --with-webgroup=www-data --enable-mmap=yes ZM_DB_HOST=localhost ZM_DB_NAME=zm ZM_DB_USER=zmuser ZM_DB_PASS=zmpass --with-ffmpeg=/usr/local/bin

Google doesn't help me much this time :(

Any suggestions ?
Last edited by beire on Wed Mar 16, 2011 6:07 am, edited 1 time in total.

dlengen
Posts: 1
Joined: Sat Mar 12, 2011 12:35 pm

Post by dlengen » Sat Mar 12, 2011 12:46 pm

I am having the same problem. Have you found a fix?

mastertheknife
Posts: 678
Joined: Wed Dec 16, 2009 4:32 pm
Location: Israel

Post by mastertheknife » Sat Mar 12, 2011 12:53 pm

Hi, please try this configure line instead. --with--ffmpeg should be a prefix to /usr to /usr/local

Code: Select all

./configure --with-webdir=/var/www/zm --with-cgidir=/usr/lib.cgi-bin --with-webuser=www-data --with-webgroup=www-data --enable-mmap=yes --enable-crashtrace=yes ZM_DB_HOST=localhost ZM_DB_NAME=zm ZM_DB_USER=zmuser ZM_DB_PASS=zmpass --with-ffmpeg=/usr/local
mastertheknife

osoroco
Posts: 13
Joined: Mon Mar 07, 2011 3:49 pm

Re: 1.24.3 SVN with ffmpeg error

Post by osoroco » Mon Mar 14, 2011 4:00 pm

with the latest svn I get this

Code: Select all

g++ -DHAVE_CONFIG_H -I. -I..  -I/usr/include -I/opt/ffmpeg/lib//include -Wall -Wno-sign-compare -fno-inline -I/opt/ffmpeg/lib//include   -g -O2 -MT zm_ffmpeg_camera.o -MD -MP -MF .deps/zm_ffmpeg_camera.Tpo -c -o zm_ffmpeg_camera.o zm_ffmpeg_camera.cpp
zm_ffmpeg_camera.cpp: In member function ‘virtual int FfmpegCamera::Capture(Image&)’:
zm_ffmpeg_camera.cpp:162: error: ‘avcodec_decode_video2’ was not declared in this scope
make[2]: *** [zm_ffmpeg_camera.o] Error 1
make[2]: Leaving directory `/root/zm/svn/src'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/root/zm/svn'
make: *** [all] Error 2
using this configure:

Code: Select all

./configure --with-ffmpeg=/opt/ffmpeg/lib/ --with-webdir=/var/www/zm/ --with-cgidir=/usr/lib/cgi-bin/ --with-webuser=www-data --with-webgroup=www-data --enable-mmap --with-libarch=lib64

User avatar
jdhar
Posts: 125
Joined: Fri Oct 01, 2010 9:15 pm
Location: California
Contact:

Re: 1.24.3 SVN with ffmpeg error

Post by jdhar » Tue Mar 15, 2011 3:50 pm

This usually has to do with the version of ffmpeg installed... do an 'ffmpeg' and paste the output.
eyeZm, Native iPhone App for ZoneMinder: http://www.eyezm.com

Version 1.3 now available on iTunes, introduces Montage view, HTTPS/SSL support and H264 native streaming!

Subscribe to RSS feed for updates: http://www.eyezm.com/rssfeed.xml

beire
Posts: 15
Joined: Sun Sep 05, 2010 10:55 pm
Location: België

Re: 1.24.3 SVN with ffmpeg error

Post by beire » Wed Mar 16, 2011 6:07 am

This problem has been resolved for a while now..
I actually forgot about this thread so never updated it.

The problem was a conflict between ffmpeg svn and ubuntu repo packages.
It was just a matter of removing the right packages (libav*) and recompiling ffmpeg svn.

System has been running great since...

Post Reply

Who is online

Users browsing this forum: No registered users and 4 guests