Disk Usage: -1%

Forum for questions and support relating to the 1.24.x releases only.
Post Reply
stefano_noffke
Posts: 3
Joined: Mon Jan 03, 2011 10:16 am
Location: Torino, Italy
Contact:

Disk Usage: -1%

Post by stefano_noffke » Mon Jan 03, 2011 10:30 am

Greetings,

I am having problems with my fresh installation of Zoneminder.

I installed ZoneMinder on a Ubuntu 10.04 Server using the packages provided with the repositories. Everything worked fine, but when I open the Web interface the Console appears to be "Stopped" and I cannot start it.

The ZoneMinder service is running and it starts at boot.

I cannot find anything on the logs about this issue.

The only thing that is strange is that the system cannot monitor the load and disk usage. On the top-right corner of the Web console it says: "Load: / Disk: -1%"
It seems to me that the Console does not start because it cannot read the disk usage properly, but I could not find a way to make it work.
I tried changing the paths to store the images, events, and sound, but it did not solve the problem.

This is my disk usage:

Code: Select all

root@venus:/var/log/zm# df -h
File system            Dim. Usati Disp. Uso% Montato su
/dev/sda3             143G  1,5G  135G   2% /
none                  2,5G  252K  2,5G   1% /dev
none                  2,5G     0  2,5G   0% /dev/shm
none                  2,5G  1,9M  2,5G   1% /var/run
none                  2,5G     0  2,5G   0% /var/lock
none                  2,5G     0  2,5G   0% /lib/init/rw
/dev/cciss/c0d0p1     230G  5,4G  213G   3% /var
/dev/cciss/c0d0p2     688G   21G  633G   4% /home
/dev/sda2             237M   36M  189M  16% /boot
Here is the zm.conf file:

Code: Select all


root@venus:/etc/zm# cat zm.conf 
# ==========================================================================
#
# ZoneMinder Base Configuration, $Date: 2008-07-25 10:48:16 +0100 (Fri, 25 Jul 2008) $, $Revision: 2612 $
#
# ==========================================================================
#
# This file is generated by 'configure'. Care should be taken if manually
# editing this file as an changes may be overwritten by subsequent configuration
# or installations.
#

# Current version of ZoneMinder
ZM_VERSION=1.24.2

# Path to build directory, used mostly for finding DB upgrade scripts
ZM_PATH_BUILD=/build/buildd/zoneminder-1.24.2

# Build time, used to record when to trigger various checks
ZM_TIME_BUILD=1271082108

# Path to ZoneMinder binaries
ZM_PATH_BIN=/usr/bin

# Path to ZoneMinder libraries (none at present, for future use)
ZM_PATH_LIB=/usr/lib

# Path to ZoneMinder configuration (this file only at present)
ZM_PATH_CONF=/etc/zm

# Path to ZoneMinder web files
ZM_PATH_WEB=/usr/share/zoneminder

# Path to ZoneMinder cgi files
ZM_PATH_CGI=/usr/lib/cgi-bin

# Username and group that web daemon (httpd/apache) runs as
ZM_WEB_USER=www-data
ZM_WEB_GROUP=www-data

# ZoneMinder database hostname or ip address
ZM_DB_HOST=localhost

# ZoneMinder database name
ZM_DB_NAME=zm

# ZoneMinder database user
ZM_DB_USER=**********

# ZoneMinder database password
ZM_DB_PASS=**********

I tried to install ZoneMinder on a PC, and it works perfectly from there...

Do you know what the problem might be?

Thanks in advance.

Stefano Noffke

stefano_noffke
Posts: 3
Joined: Mon Jan 03, 2011 10:16 am
Location: Torino, Italy
Contact:

Post by stefano_noffke » Mon Jan 03, 2011 11:47 am

I found the problem.

Zoneminder needs the php functions "exec" and "shell_exec" to be available. For security reasons those functions were disabled in php.ini.

Enabling those functions again solved the problem.



Thank you.

insippo
Posts: 39
Joined: Mon Dec 27, 2010 11:45 am
Location: estonia

Post by insippo » Tue Jan 04, 2011 11:05 am

i have debian,apache2 and the same problem ,Disk: -1%" Where i find to enable this function?I look /etc/apache2/php.ini and nothing here.
Sry my english.

Thanks

stefano_noffke
Posts: 3
Joined: Mon Jan 03, 2011 10:16 am
Location: Torino, Italy
Contact:

Post by stefano_noffke » Tue Jan 04, 2011 11:34 am

insippo wrote:i have debian,apache2 and the same problem ,Disk: -1%" Where i find to enable this function?I look /etc/apache2/php.ini and nothing here.
Sry my english.

Thanks
Open the php.ini file, and look for the following directive:

"disable_functions = "

You should delete the "exec" and "shell_exec" references there.

PacoLM
Posts: 970
Joined: Wed Dec 02, 2009 9:55 pm
Location: Spain

Post by PacoLM » Tue Jan 04, 2011 11:42 am

Look in /etc/php5/apache2/php.ini

insippo
Posts: 39
Joined: Mon Dec 27, 2010 11:45 am
Location: estonia

Post by insippo » Tue Jan 04, 2011 5:49 pm


Post Reply

Who is online

Users browsing this forum: No registered users and 9 guests