Mootools not found

Forum for questions and support relating to the 1.24.x releases only.
Post Reply
sipi
Posts: 118
Joined: Wed Feb 14, 2007 5:18 pm

Mootools not found

Post by sipi » Sun Nov 28, 2010 5:18 pm

Hi,

please help me. I installed zm from svn and when I open zm console on Mozilla it shows an popup window: Mootools not found! Please download from
http://mootools.net and install in ZoneMinder web root.

Really there is not mootools.js but I find smoe mootools files in tools/mootools directory 1.2.3 and 1.2.3.1 version.

I not found any tip in forum because I not found a correct file on mootools.net. There is only 1.3 version what is not work with svn. I tried other version 1.2, 1.2.1 etc. that they aren't work with svn. I tried softlink and rename but nothing changed.

What is the correct mootools.js and where I find it to download?

sipi
Posts: 118
Joined: Wed Feb 14, 2007 5:18 pm

Post by sipi » Tue Nov 30, 2010 12:21 pm

I found in apache error log:

[Tue Nov 30 13:30:02 2010] [error] [client 192.168.1.1] Symbolic link not allowed or link target not accessible: /srv/www/htdocs/zm/tools/mootools/mootools-core.js, referer: http://192.168.1.253:8086/zm/
[Tue Nov 30 13:30:02 2010] [error] [client 192.168.1.1] Symbolic link not allowed or link target not accessible: /srv/www/htdocs/zm/tools/mootools/mootools-more.js, referer: http://192.168.1.253:8086/zm/


and apache access log:

192.168.1.1 - - [30/Nov/2010:13:30:02 +0100] "GET /zm/ HTTP/1.1" 200 6424 "-" "Mozilla/5.0 (X11; U; Linux x86_64; en-US) AppleWebKit/533.4 (KHTML, like Gecko) Chrome/5.0.375.99 Safari/533.4"
192.168.1.1 - - [30/Nov/2010:13:30:02 +0100] "GET /zm/css/reset.css HTTP/1.1" 304 - "http://192.168.1.253:8086/zm/" "Mozilla/5.0 (X11; U; Linux x86_64; en-US) AppleWebKit/533.4 (KHTML, like Gecko) Chrome/5.0.375.99 Safari/533.4"
192.168.1.1 - - [30/Nov/2010:13:30:02 +0100] "GET /zm/skins/classic/css/skin.css HTTP/1.1" 304 - "http://192.168.1.253:8086/zm/" "Mozilla/5.0 (X11; U; Linux x86_64; en-US) AppleWebKit/533.4 (KHTML, like Gecko) Chrome/5.0.375.99 Safari/533.4"
192.168.1.1 - - [30/Nov/2010:13:30:02 +0100] "GET /zm/skins/classic/views/css/console.css HTTP/1.1" 304 - "http://192.168.1.253:8086/zm/" "Mozilla/5.0 (X11; U; Linux x86_64; en-US) AppleWebKit/533.4 (KHTML, like Gecko) Chrome/5.0.375.99 Safari/533.4"
192.168.1.1 - - [30/Nov/2010:13:30:02 +0100] "GET /zm/js/mootools.ext.js HTTP/1.1" 304 - "http://192.168.1.253:8086/zm/" "Mozilla/5.0 (X11; U; Linux x86_64; en-US) AppleWebKit/533.4 (KHTML, like Gecko) Chrome/5.0.375.99 Safari/533.4"
192.168.1.1 - - [30/Nov/2010:13:30:02 +0100] "GET /zm/skins/classic/views/js/console.js HTTP/1.1" 304 - "http://192.168.1.253:8086/zm/" "Mozilla/5.0 (X11; U; Linux x86_64; en-US) AppleWebKit/533.4 (KHTML, like Gecko) Chrome/5.0.375.99 Safari/533.4"
192.168.1.1 - - [30/Nov/2010:13:30:02 +0100] "GET /zm/tools/mootools/mootools-core.js HTTP/1.1" 403 1036 "http://192.168.1.253:8086/zm/" "Mozilla/5.0 (X11; U; Linux x86_64; en-US) AppleWebKit/533.4 (KHTML, like Gecko) Chrome/5.0.375.99 Safari/533.4"
192.168.1.1 - - [30/Nov/2010:13:30:02 +0100] "GET /zm/tools/mootools/mootools-more.js HTTP/1.1" 403 1036 "http://192.168.1.253:8086/zm/" "Mozilla/5.0 (X11; U; Linux x86_64; en-US) AppleWebKit/533.4 (KHTML, like Gecko) Chrome/5.0.375.99 Safari/533.4"
192.168.1.1 - - [30/Nov/2010:13:30:02 +0100] "GET /zm/skins/classic/js/skin.js HTTP/1.1" 304 - "http://192.168.1.253:8086/zm/" "Mozilla/5.0 (X11; U; Linux x86_64; en-US) AppleWebKit/533.4 (KHTML, like Gecko) Chrome/5.0.375.99 Safari/533.4"


What does it mean?

The file is there user is root, group is root, executing as file. I tried to change user:group to wwwrun:www and to give everybody full right but message is same as.

sipi
Posts: 118
Joined: Wed Feb 14, 2007 5:18 pm

Mootools not found

Post by sipi » Tue Nov 30, 2010 1:20 pm

I will answer if anyone knows the answer. :):)

I found on the net that is an apache zm.conf problem. If zm uses symlinks then need that zm.conf includes an row: FollowSymlinks or need rename mootools-xxx-core-nc.js and mootools-xxx-more-nc.js file to mootools-core.js and mootools-more.js in zm/tools/mootools directory.

This is important because I could not found reference to this issue anywhere.

Post Reply

Who is online

Users browsing this forum: No registered users and 2 guests