Garbled Logitech Orbit MP Video

Forum for questions and support relating to the 1.24.x releases only.
Post Reply
Posts: 12
Joined: Tue Aug 24, 2010 7:53 pm

Garbled Logitech Orbit MP Video

Post by logray » Tue Aug 24, 2010 8:01 pm

Recently built a system with ZM 1.24.2 on ubuntu 10.04.

ZM works great, except my camera shows up as garbled video. :-(

I tried every format, aspect ratio, and palette I could to no avail.

With the settings at PAL/YUYV which is what the camera supports I get garbled video.

I can view the camera just fine in cheese, ffmpeg, etc.




cat /proc/version
Linux version 2.6.32-24-generic (buildd@vernadsky) (gcc version 4.4.3 (Ubuntu 4.4.3-4ubuntu5) ) #41-Ubuntu SMP

modinfo uvcvideo
filename: /lib/modules/2.6.32-24-generic/kernel/drivers/media/video/uvc/uvcvideo.ko
version: v0.1.0
license: GPL
description: USB Video Class driver
author: Laurent Pinchart <laurent>
srcversion: 22968C0170844A6D8A88A20

[ 86.866479] uvcvideo: Found UVC 1.00 device <unnamed> (046d:08c2)
[ 86.906942] input: UVC Camera (046d:08c2) as /devices/pci0000:00/0000:00:1d.7/usb1/1-2/1-2:1.0/input/input5
[ 86.907558] usbcore: registered new interface driver uvcvideo
[ 86.907738] USB Video Class driver (v0.1.0)

lsusb | grep 08c2
Bus 001 Device 003: ID 046d:08c2 Logitech, Inc. QuickCam PTZ

logan@micro:~$ sudo zmu -d /dev/video0 -q -v -V 1
Video Device: /dev/video0
Video Capabilities
Name: UVC Camera (046d:08c2)
Type: 1
Can capture
Video Channels: 1
Audio Channels: 0
Maximum Width: 0
Maximum Height: 0
Minimum Width: 48
Minimum Height: 32
Window Attributes
X Offset: 0
Y Offset: 0
Width: 1024
Height: 576
Picture Attributes
Palette: 8 - YUYV
Colour Depth: 16
Brightness: 12850
Hue: 0
Colour :2570
Contrast: 6425
Whiteness: 65535
Channel 0 Attributes
Name: Camera 1
Channel: 0
Flags: 0
Type: 2 - Camera
Format: 0 - PAL

Posts: 12
Joined: Tue Aug 24, 2010 7:53 pm

Post by logray » Wed Aug 25, 2010 1:18 am

Problem solved.

Set resolution to 1024 x 576.

Posts: 1
Joined: Sun Oct 03, 2010 3:11 am

Post by phoanglong » Sun Oct 03, 2010 3:16 am

could you please tell me how did you get it to work on ubuntu 10.04 LTS

i got a pretty much same version as you.

when i do lsusb | grep 08c2

Bus 002 Device 005: ID 046d:08c2 Logitech, Inc. QuickCam PTZ

it showed up,

but when i do

ls /dev/

there is no videoX created..

could someone please help.

Post Reply

Who is online

Users browsing this forum: No registered users and 18 guests