installation issue using MINT

Forum for questions and support relating to the 1.24.x releases only.
Post Reply
Posts: 2
Joined: Tue Jul 27, 2010 12:44 pm

installation issue using MINT

Post by deckholm » Tue Jul 27, 2010 1:52 pm

I am using Mint which is based on Ubuntu and Installed zoneminder from the synaptic package manager. I am following the Ubuntu installation instructions from installation instructions. I have edited /etc/apache2/sites-enabled/000-default/ so that ZM is the default local host server. When I log into http:///localhost/ the following text appears and nothing else.

It works!

This is the default web page for this server.

The web server software is running but no content has been added, yet.

Where do I go from here?

Thanks for anyones help.

Posts: 195
Joined: Mon Dec 10, 2007 5:53 pm
Location: San Jose, CA

Post by timcraig » Tue Jul 27, 2010 6:28 pm

Try opening a browser to http://localhost/zm

If that doesn't work, look in your apache web folder (it was in /var/www the last time I used a websever on Ubuntu) to see any other folders you have there.

Posts: 2
Joined: Tue Jul 27, 2010 12:44 pm


Post by deckholm » Tue Jul 27, 2010 7:31 pm

http://localhost/zm returns an apache not found error as follows.
"Not Found
The requested URL /zm was not found on this server.
Apache/2.2.14 (ubuntu) Server at localhost Port 80"

In location var/www there is only a file index.html and that contains the text "It works! This is the default web page for this server. The web server is running but no content has been added, yet."

What actually starts zoneminder so that it can be accessed by a webrowser?


Posts: 6
Joined: Fri Jan 21, 2011 6:26 pm

Post by dsbruin » Fri Jan 21, 2011 6:36 pm

I just found this thread as I'm having the same problem. I've got a pristine install of Ubuntu Maverick (10.10) netbook edition running on an Acer Aspire One A0A110 (ZG5). I installed ZM 1.24.2 from the available package in the Ubuntu Software Center GUI (as opposed to installing from source).

Apache2 clearly works, as I get the same welcome message. However, there's no "/zm", etc etc. I took a quick look at the apache confs in

Code: Select all

and I noticed there's nothing from Zoneminder so there's no way the "/zm" alias could exist. I looked around in the zoneminder install directory, didn't find anything useful, then noticed

Code: Select all

. This had two files, one is clearly the zoneminder config file, the other is clearly an Apache2 config file means for the conf.d directory (the file is poorly named "apache.conf", which makes sense if you're thinking from the perspective of Zoneminder, but it is bad since in its intended location of /etc/apache2/conf.d/apache.conf doesn't ring any obvious bells as a Zoneminder specific file, unless you look at its contents).

Here's what's in the file:

Code: Select all

Alias /zm /usr/share/zoneminder

  php_flag register_globals off
  Options Indexes FollowSymLinks
    DirectoryIndex index.php
Simply put that in your conf.d/ subdir for Apache2, issue a restart for apache, then you should be able to hit your zoneminder server's IP address through a browser anywhere on the same network (for example: ) and you'll see the unprotected ZM default UI.

Hope that helps on this outdated thread!

Post Reply

Who is online

Users browsing this forum: No registered users and 12 guests