Howto install ZoneMinder 1.24.2 on Ubuntu 10.04 LTS

Forum for questions and support relating to the 1.24.x releases only.
Post Reply
vpetersson
Posts: 9
Joined: Tue Mar 24, 2009 6:11 am
Contact:

Howto install ZoneMinder 1.24.2 on Ubuntu 10.04 LTS

Post by vpetersson » Sun May 23, 2010 7:24 pm

Hey guys,

Last week I launched an updated version of my ZoneMinder Virtual Appliance. The new version us using Ubuntu 10.04 and ZoneMinder 1.24.2. In order to produce this VA, I obviously had to get ZoneMinder running myself. It's pretty straight forward, but there were a few things that took me some time to get around.

Since I understand that there are people out there that want to run ZoneMinder directly on the hardware, I put together a step-by-step guide on how to get ZoneMinder 1.24.2 running on Ubuntu 10.04.

johnnytolengo
Posts: 184
Joined: Tue Oct 14, 2008 5:59 pm

Post by johnnytolengo » Sun May 23, 2010 10:08 pm

thanks.


jT.

jan
Posts: 17
Joined: Sat May 20, 2006 7:55 am
Location: europe
Contact:

Post by jan » Mon May 24, 2010 1:30 pm

if I install ffmpeg through apt-get I get this during ./configure...

Code: Select all

checking for x264_predict_16x16_init in -lx264... no
checking for av_malloc in -lavutil... no
configure: WARNING: libavutil.a may be required for MPEG streaming
checking for avcodec_init in -lavcodec... no
configure: WARNING: libavcodec.a is required for MPEG streaming
checking for av_new_stream in -lavformat... no
configure: WARNING: libavformat.a is required for MPEG streaming
checking for avdevice_register_all in -lavdevice... no
configure: WARNING: libavdevice.a may be required for MPEG streaming
checking for sws_scale in -lswscale... no
...
checking libavutil/avutil.h usability... no
checking libavutil/avutil.h presence... no
checking for libavutil/avutil.h... no
checking ffmpeg/avutil.h usability... no
checking ffmpeg/avutil.h presence... no
checking for ffmpeg/avutil.h... no
checking libavcodec/avcodec.h usability... no
checking libavcodec/avcodec.h presence... no
checking for libavcodec/avcodec.h... no
checking ffmpeg/avcodec.h usability... no
checking ffmpeg/avcodec.h presence... no
checking for ffmpeg/avcodec.h... no
checking libavformat/avformat.h usability... no
checking libavformat/avformat.h presence... no
checking for libavformat/avformat.h... no
checking ffmpeg/avformat.h usability... no
checking ffmpeg/avformat.h presence... no
checking for ffmpeg/avformat.h... no
checking libswscale/swscale.h usability... no
checking libswscale/swscale.h presence... no
checking for libswscale/swscale.h... no
checking ffmpeg/swscale.h usability... no
checking ffmpeg/swscale.h presence... no
checking for ffmpeg/swscale.h... no
and if I compile ffmpeg from source I get this error:
http://www.zoneminder.com/forums/viewtopic.php?t=15901

vpetersson
Posts: 9
Joined: Tue Mar 24, 2009 6:11 am
Contact:

Post by vpetersson » Sat May 29, 2010 2:02 pm

Jan,

Have you installing ffmpeg-dev? I don't think I needed to install it (as it's not in the installation notes), but perhaps it helps. Also, try 'make clean' before running the './configure' script.

kie1988
Posts: 4
Joined: Tue Aug 14, 2012 6:09 pm

Re:

Post by kie1988 » Tue Aug 14, 2012 9:32 pm

vpetersson wrote:Jan,

Have you installing ffmpeg-dev? I don't think I needed to install it (as it's not in the installation notes), but perhaps it helps. Also, try 'make clean' before running the './configure' script.
Hi. I have the same problem. I am trying to follow the directions given here. Can you please tell me what you mean by "make clean" before running the configure script? Thanks.
Image

Post Reply

Who is online

Users browsing this forum: No registered users and 11 guests