ZM compiling error

Forum for questions and support relating to the 1.24.x releases only.
Post Reply
craver84
Posts: 96
Joined: Sun Aug 31, 2008 7:35 am

ZM compiling error

Post by craver84 » Fri May 21, 2010 9:13 pm

I'm trying to compile ZM for my x64 system:
After installing ffmpeg from SVN:

Code: Select all

cd /usr/src
svn checkout svn://svn.mplayerhq.hu/ffmpeg/trunk ffmpeg
cd ffmpeg
./configure --enable-gpl --enable-shared --enable-pthreads
make
make install
make install-libs
cd /lib
ln -s /usr/local/lib/libswscale.so.0
ln -s /usr/local/lib/libavformat.so.52
ln -s /usr/local/lib/libavcodec.so.52
ln -s /usr/local/lib/libavutil.so.50
ln -s /usr/local/lib/libavdevice.so.52

ln -s /usr/local/lib/swscale.so.0
ln -s /usr/local/lib/avformat.so.52
ln -s /usr/local/lib/avcodec.so.52
ln -s /usr/local/lib/avutil.so.50
ln -s /usr/local/lib/avdevice.so.52



I did:

Code: Select all

cd /usr/src
svn co http://svn.zoneminder.com/svn/zm/trunk zm
cd zm
./configure --with-webdir=/var/www/zm --with-cgidir=/usr/lib/cgi-bin ZM_DB_HOST=localhost ZM_DB_NAME=zm ZM_DB_USER=zmuser ZM_DB_PASS=zmpass --enable-debug=yes --with-webgroup=www-data --with-webuser=www-data --disable-mmap
and this is the result:

Code: Select all

configure: WARNING: libavutil/avutil.h: present but cannot be compiled
configure: WARNING: libavutil/avutil.h:     check for missing prerequisite headers?
configure: WARNING: libavutil/avutil.h: see the Autoconf documentation
configure: WARNING: libavutil/avutil.h:     section "Present But Cannot Be Compiled"
configure: WARNING: libavutil/avutil.h: proceeding with the compiler's result
configure: WARNING:     ## ------------------------------------- ##
configure: WARNING:     ## Report this to support@zoneminder.com ##
configure: WARNING:     ## ------------------------------------- ##
checking for libavutil/avutil.h... no
checking ffmpeg/avutil.h usability... no
checking ffmpeg/avutil.h presence... no
checking for ffmpeg/avutil.h... no
checking libavcodec/avcodec.h usability... no
checking libavcodec/avcodec.h presence... yes
configure: WARNING: libavcodec/avcodec.h: present but cannot be compiled
configure: WARNING: libavcodec/avcodec.h:     check for missing prerequisite headers?
configure: WARNING: libavcodec/avcodec.h: see the Autoconf documentation
configure: WARNING: libavcodec/avcodec.h:     section "Present But Cannot Be Compiled"
configure: WARNING: libavcodec/avcodec.h: proceeding with the compiler's result
configure: WARNING:     ## ------------------------------------- ##
configure: WARNING:     ## Report this to support@zoneminder.com ##
configure: WARNING:     ## ------------------------------------- ##
checking for libavcodec/avcodec.h... no
checking ffmpeg/avcodec.h usability... no
checking ffmpeg/avcodec.h presence... no
checking for ffmpeg/avcodec.h... no
checking libavformat/avformat.h usability... no
checking libavformat/avformat.h presence... yes
configure: WARNING: libavformat/avformat.h: present but cannot be compiled
configure: WARNING: libavformat/avformat.h:     check for missing prerequisite headers?
configure: WARNING: libavformat/avformat.h: see the Autoconf documentation
configure: WARNING: libavformat/avformat.h:     section "Present But Cannot Be Compiled"
configure: WARNING: libavformat/avformat.h: proceeding with the compiler's result
configure: WARNING:     ## ------------------------------------- ##
configure: WARNING:     ## Report this to support@zoneminder.com ##
configure: WARNING:     ## ------------------------------------- ##
checking for libavformat/avformat.h... no
checking ffmpeg/avformat.h usability... no
checking ffmpeg/avformat.h presence... no
checking for ffmpeg/avformat.h... no
checking libswscale/swscale.h usability... no
checking libswscale/swscale.h presence... yes
configure: WARNING: libswscale/swscale.h: present but cannot be compiled
configure: WARNING: libswscale/swscale.h:     check for missing prerequisite headers?
configure: WARNING: libswscale/swscale.h: see the Autoconf documentation
configure: WARNING: libswscale/swscale.h:     section "Present But Cannot Be Compiled"
configure: WARNING: libswscale/swscale.h: proceeding with the compiler's result
configure: WARNING:     ## ------------------------------------- ##
configure: WARNING:     ## Report this to support@zoneminder.com ##
configure: WARNING:     ## -----------------------------------
if i do: make

Code: Select all

make  all-recursive
make[1]: ingresso nella directory «/usr/src/zm»
Making all in src
make[2]: ingresso nella directory «/usr/src/zm/src»
g++ -DHAVE_CONFIG_H -I. -I..  -I/usr/include -I/usr/include -Wall -Wno-sign-compare -fno-inline -I/usr/include  -frepo -g -O2 -MT zmc.o -MD -MP -MF .deps/zmc.Tpo -c -o zmc.o zmc.cpp
In file included from zm_mpeg.h:23,
                 from zm_stream.h:27,
                 from zm_event.h:39,
                 from zm_zone.h:27,
                 from zm_monitor.h:26,
                 from zmc.cpp:28:
zm_ffmpeg.h:33:2: error: #error "No location for avutils.h found"
zm_ffmpeg.h:40:2: error: #error "No location for avcodec.h found"
zm_ffmpeg.h:47:2: error: #error "No location for avformat.h found"
zm_ffmpeg.h:55:2: error: #error "No location for swscale.h found"
In file included from zm_stream.h:27,
                 from zm_event.h:39,
                 from zm_zone.h:27,
                 from zm_monitor.h:26,
                 from zmc.cpp:28:
zm_mpeg.h:43: error: use of enum ‘PixelFormat’ without previous declaration
zm_mpeg.h:44: error: ISO C++ forbids declaration of ‘AVOutputFormat’ with no type
zm_mpeg.h:44: error: expected ‘;’ before ‘*’ token
zm_mpeg.h:45: error: ISO C++ forbids declaration of ‘AVFormatContext’ with no type
zm_mpeg.h:45: error: expected ‘;’ before ‘*’ token
zm_mpeg.h:46: error: ISO C++ forbids declaration of ‘AVStream’ with no type
zm_mpeg.h:46: error: expected ‘;’ before ‘*’ token
zm_mpeg.h:47: error: ISO C++ forbids declaration of ‘AVFrame’ with no type
zm_mpeg.h:47: error: expected ‘;’ before ‘*’ token
zm_mpeg.h:48: error: ISO C++ forbids declaration of ‘AVFrame’ with no type
zm_mpeg.h:48: error: expected ‘;’ before ‘*’ token
zm_mpeg.h:49: error: ISO C++ forbids declaration of ‘uint8_t’ with no type
zm_mpeg.h:49: error: expected ‘;’ before ‘*’ token
zm_mpeg.h:65: error: ‘uint8_t’ has not been declared
make[2]: *** [zmc.o] Errore 1
make[2]: uscita dalla directory «/usr/src/zm/src»
make[1]: *** [all-recursive] Errore 1
make[1]: uscita dalla directory «/usr/src/zm»
make: *** [all] Errore 2
how can i solve it? thanks a lot

jan
Posts: 17
Joined: Sat May 20, 2006 7:55 am
Location: europe
Contact:

Post by jan » Sat May 22, 2010 4:33 pm

I had the same problem with the new ubuntu 10.04...no matter how I tried to compile ffmpeg it just wouldn't go...so I did 'apt-get install ffmpeg' and then installed zoneminder from source (albeit without ffmpeg support) =/

craver84
Posts: 96
Joined: Sun Aug 31, 2008 7:35 am

Post by craver84 » Sat May 22, 2010 5:20 pm

I'm using ubuntu 10.04 too...
Now I try again. Thanks

ericjanssens
Posts: 4
Joined: Wed May 26, 2010 12:48 pm

can't make zoneminder

Post by ericjanssens » Wed May 26, 2010 12:54 pm

because i had also the "can't find message's. so i did the suggested:
'apt-get install ffmpeg' and then installed zoneminder
'

but the problem is still the same.

help....

User avatar
zoneminder
Site Admin
Posts: 5220
Joined: Wed Jul 09, 2003 2:07 pm
Location: Bristol, UK
Contact:

Post by zoneminder » Thu May 27, 2010 12:58 pm

The fix posted at http://www.zoneminder.com/forums/viewtopic.php?t=15921 should also solve this one I think.
Phil

absolutebeginner
Posts: 1
Joined: Sun Mar 22, 2009 8:23 am

ZM make error

Post by absolutebeginner » Thu May 27, 2010 4:45 pm

Thanks Phil

Been beating my head against the proverbial brick wall for days.

Brian

Post Reply

Who is online

Users browsing this forum: No registered users and 7 guests