Export list of events to video doesn't happen

Forum for questions and support relating to the 1.24.x releases only.
Post Reply
lorsungcu
Posts: 23
Joined: Mon Jun 23, 2008 3:56 pm

Export list of events to video doesn't happen

Post by lorsungcu » Wed Feb 03, 2010 4:51 pm

I've got 57 events that I need to export as video so I can join them and back them up as video, but I can't get them to export as video. If I do a single event, it will export properly (through the event viewer), but if I filter the events I need, and ask ZM to create videos for all matches, goto list view and select all/export video, it just sits there going "Exporting..." forever. I tried it with only a couple events, same thing. Never gets past the 'Exporting...' stage. When I click Export in the list view, nothing appears in the log.

What would be ideal would be a command to create video files for all events and concatenate them with ffmpeg...if I can get this to work maybe I'll see about making a script for filtering?

I really, really need this done today - has anyone else had a similar problem/issue? In the mean time I'm going to go through and export individual events one by one, but this would be a really helpful function to have working in the future..

Linsys
Posts: 6
Joined: Tue Jan 26, 2010 10:12 pm

Same issue kinda

Post by Linsys » Thu Feb 04, 2010 5:56 pm

I have almost the same issue...

When I go to each event I can download the video just fine, also when I select "Create video for all matches" in the Event Filter that seems to work because I see ffmpeg working like crazy...

But when I check all the events in the filter I created and try to export the files it quickly returns stating the export was done, I can download the .tar file but there is nothing in it.

I also see this in my error_log

Undefined variable: exportVideo

Linsys
Posts: 6
Joined: Tue Jan 26, 2010 10:12 pm

[SOLVED]

Post by Linsys » Thu Feb 04, 2010 6:59 pm

Ok here is the solution that worked for me:

http://www.zoneminder.com/forums/viewto ... xportvideo

I put in the patches located at the bottom of the page..

Then I started to have the issue the previous poster, posted about where it would just say exporting for ever and never stop.. this was because my memory_limit in my php.ini was only 16M I uped this to 128M

memory_limit = 128M, obviously if you export too many files or the files are too large it will take a while.. You can check the status with ps -ef | grep gzip

Also you can check if the file is being written here:

/var/www/html/zm/temp

Hope that helps.

Post Reply

Who is online

Users browsing this forum: No registered users and 6 guests