Webcam video is green and inverted

Forum for questions and support relating to the 1.24.x releases only.
Post Reply
neosrix
Posts: 5
Joined: Mon Jan 25, 2010 6:17 pm
Location: India
Contact:

Webcam video is green and inverted

Post by neosrix » Mon Jan 25, 2010 6:32 pm

I installed zoneminder by following this wiki http://www.zoneminder.com/wiki/index.ph ... 10_Desktop on Ubuntu 9.10. After installation I am able to see the zoneminder webpage.

I checked my webcam using Cheese before installing zoneminder and it worked fine. However after installing zone minder, the video became green and inverted. same with xawtv as well. I unistalled zoneminder. Even then the webcam video is green and inverted.

following is the lsusb output. Aveo Technology Corp refers to the USB webcam.

output of lsusb
-----------------------------
Bus 001 Device 006: ID 058f:6387 Alcor Micro Corp. Transcend JetFlash Flash Drive
Bus 001 Device 002: ID 1871:01f0 Aveo Technology Corp.
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 005 Device 002: ID 413c:8126 Dell Computer Corp. Wireless 355 Bluetooth
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub


Fromt he following Xorg log , I observe that the camera is detected as keyboard. Am I right. Is that the problem?
Xorg.log
-----------------------------------

config/hal: Adding input device USB2.0 Camera

USB2.0 Camera: always reports core events

USB2.0 Camera: Device: "/dev/input/event7"

USB2.0 Camera: Found keys

USB2.0 Camera: Configuring as keyboard

XINPUT: Adding extended input device "USB2.0 Camera" (type: KEYBOARD)

Option "xkb_rules" "evdev"

Option "xkb_model" "pc105"

Option "xkb_layout" "us"

derekfl
Posts: 2
Joined: Mon Jan 11, 2010 7:54 pm

Post by derekfl » Mon Jan 25, 2010 9:36 pm

I am having the same problem. The video is greenish and green colors look red and red colors look green.

coke
Posts: 518
Joined: Wed Jan 30, 2008 5:53 pm
Location: St. Louis, MO, USA

Post by coke » Mon Jan 25, 2010 10:50 pm

Do you have an nVidia card? I often get this viewing videos on one of my Karmic machines, opening nVidia-settings and closing it immediately fixes the problem. (Though we could be speaking of different things, personally, humans are all converted into smurfs/avatars on mine)

neosrix
Posts: 5
Joined: Mon Jan 25, 2010 6:17 pm
Location: India
Contact:

Post by neosrix » Tue Jan 26, 2010 3:55 am

Thanks for the reply.

I have a ATI Radeon mobility x1300 card. And I donot see any settings application for ATI in ubuntu

neosrix
Posts: 5
Joined: Mon Jan 25, 2010 6:17 pm
Location: India
Contact:

Post by neosrix » Tue Jan 26, 2010 5:42 pm

Any Solutions??

jfkastner
Posts: 74
Joined: Wed Jun 17, 2009 11:52 pm

Post by jfkastner » Tue Jan 26, 2010 7:40 pm

check the faq and the "compatibility list"

usb cams are very difficult since they have so many different chipsets internally, and only a handful models are proven to be good for linux

neosrix
Posts: 5
Joined: Mon Jan 25, 2010 6:17 pm
Location: India
Contact:

Post by neosrix » Wed Jan 27, 2010 5:01 pm

My USB camera used to work well in Ubuntu. However after installing zoneminder the video become green in color. The problem is that now the video is always green in colour, irrespective of which application (cheese, xawtv) I use to access webcam.

I guess zoneminder modified some settings that is making the video appear green.

I have attached the image here

http://picasaweb.google.com/lh/photo/OY ... directlink

orsty3001
Posts: 47
Joined: Tue Jan 26, 2010 5:55 pm

Post by orsty3001 » Thu Jan 28, 2010 2:33 pm

neosrix wrote:My USB camera used to work well in Ubuntu. However after installing zoneminder the video become green in color. The problem is that now the video is always green in colour, irrespective of which application (cheese, xawtv) I use to access webcam.

I guess zoneminder modified some settings that is making the video appear green.

I have attached the image here

http://picasaweb.google.com/lh/photo/OY ... directlink
Change the Capture Palette under the source tab to something else. I had the same problem with a color camera when it was set to yuv422p, I tried a few of them before I found one that worked.

RGB555 seems to work for my camera.

neosrix
Posts: 5
Joined: Mon Jan 25, 2010 6:17 pm
Location: India
Contact:

Post by neosrix » Sun Jan 31, 2010 12:39 pm

OOPS, it looks like not a zone minder problem at all.

How did I found out ? I tried on windows XP and it was the same green image i saw in Ubuntu. I tried on my friends Windows machine as well. Same result.

I bet my cam was working well. I donot see any reason to claim that zoneminder installation has damaged the webcam physically. The only possible thing is that its a bad coincidence that my cam went for a toss on the day (or couple of days) before installation.

But thanks guys for all your support. Time to get a new webcam.

Post Reply

Who is online

Users browsing this forum: No registered users and 2 guests