configure: error: C++ compiler cannot create executables

Forum for questions and support relating to the 1.24.x releases only.
Post Reply
bipolarkm
Posts: 4
Joined: Tue Jul 21, 2009 9:08 am

configure: error: C++ compiler cannot create executables

Post by bipolarkm » Wed Aug 26, 2009 6:50 pm

Hi!
I want to configure zm 1.24.2 on FreeBSD 7.2 amdx64 but have a error :

./configure --with-mysql=/usr/local --with-libarch=lib64 --without-extralibs --with-webdir=/usr/local/www/apache22 --without-ffmpeg --with-cgidir=/usr/local/www/apache22/cgi-bin --with-webuser=apache --with-webgroup=apache --disable-mmap --enable-crashtrace=yes --enable-debug=yes

config.log:

## ----------- ##
## Core tests. ##
## ----------- ##

configure:1408: checking for a BSD-compatible install
configure:1463: result: /usr/bin/install -c
configure:1474: checking whether build environment is sane
configure:1517: result: yes
configure:1582: checking for gawk
configure:1611: result: no
configure:1582: checking for mawk
configure:1611: result: no
configure:1582: checking for nawk
configure:1598: found /usr/bin/nawk
configure:1608: result: nawk
configure:1618: checking whether make sets $(MAKE)
configure:1638: result: yes
configure:2173: checking for g++
configure:2189: found /usr/bin/g++
configure:2199: result: g++
configure:2215: checking for C++ compiler version
configure:2218: g++ --version </dev>&5
g++ (GCC) 4.2.1 20070719 [FreeBSD]
Copyright (C) 2007 Free Software Foundation, Inc.
This is free software; see the source for copying conditions. There is NO
warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.

configure:2221: $? = 0
configure:2223: g++ -v </dev>&5
Using built-in specs.
Target: amd64-undermydesk-freebsd
Configured with: FreeBSD/amd64 system compiler
Thread model: posix
gcc version 4.2.1 20070719 [FreeBSD]
configure:2226: $? = 0
configure:2228: g++ -V </dev>&5
g++: '-V' option must have argument
configure:2231: $? = 1
configure:2254: checking for C++ compiler default output file name
configure:2257: g++ -Ino/include -Lno/lib64 -L/usr/local/lib64/mysql no conftest.cc >&5
g++: no: No such file or directory
configure:2260: $? = 1
configure: failed program was:
| /* confdefs.h. */
|.
| #define PACKAGE_NAME "zm"
| #define PACKAGE_TARNAME "ZoneMinder"
| #define PACKAGE_VERSION "1.24.2"
| #define PACKAGE_STRING "zm 1.24.2"
| #define PACKAGE_BUGREPORT "support@zoneminder.com"
| #define PACKAGE "ZoneMinder"
| #define VERSION "1.24.2"
| #define ZM_MEM_MAPPED 0
| /* end confdefs.h. */
|.
| int
| main ()
| {
|.
| ;
| return 0;
| }
configure:2298: error: C++ compiler cannot create executables
See `config.log' for more details.


Anybody know what it is?
help please

hushpuppy
Posts: 147
Joined: Wed Aug 08, 2007 10:28 am

Post by hushpuppy » Mon Aug 31, 2009 6:18 am

Possible solutions :-
- full disk
- no write permission in the build tree
- issuing more than one configure at the same time in the same build
tree
- buggy configure script and/or shell cause shell hiccups
- buggy shell or compiler (old system ?)
.

User avatar
zoneminder
Site Admin
Posts: 5220
Joined: Wed Jul 09, 2003 2:07 pm
Location: Bristol, UK
Contact:

Post by zoneminder » Mon Aug 31, 2009 8:10 pm

No compiler installed at all usually.
Phil

bipolarkm
Posts: 4
Joined: Tue Jul 21, 2009 9:08 am

Post by bipolarkm » Tue Sep 01, 2009 2:14 pm

Thanks!
but i have gcc in system:

video# gcc -v
Using built-in specs.
Target: amd64-undermydesk-freebsd
Configured with: FreeBSD/amd64 system compiler
Thread model: posix
gcc version 4.2.1 20070719 [FreeBSD]

User avatar
monex
Posts: 169
Joined: Mon Jan 22, 2007 1:10 pm

Post by monex » Tue Sep 01, 2009 7:21 pm

Hi,

make sure that you also have gcc-c++ installed otherwise it won't work.

Hope this helps
Image

bipolarkm
Posts: 4
Joined: Tue Jul 21, 2009 9:08 am

Post by bipolarkm » Tue Sep 01, 2009 8:24 pm

i'm not correctly write a configure parametres --with-extralib="********"
thank you! best regards!

Post Reply

Who is online

Users browsing this forum: No registered users and 2 guests