Upgrade database to 1.24.2

Forum for questions and support relating to the 1.24.x releases only.
Post Reply
User avatar
monex
Posts: 169
Joined: Mon Jan 22, 2007 1:10 pm

Upgrade database to 1.24.2

Post by monex » Mon Jun 29, 2009 7:22 pm

Hi,

when I try to upgrade the database from 1.24.1 to 1.24.2 I get the following error message:

Code: Select all

Upgrading database to version 1.24.2
Loading config from DB
Saving config to DB
Can't find upgrade from version '1.24.1' at /usr/bin/zmupdate.pl line 883, <STDIN> line 2.
Maybe there are no changes but it would be nice if the tool in that case wouldn't exit with an error so that my wrapper script will work with that situation :)

Thank you

Monex
Image

User avatar
rdmelin
Posts: 863
Joined: Wed Oct 29, 2003 2:23 pm
Location: Ellensburg, WA USA

Post by rdmelin » Tue Jun 30, 2009 12:12 am

As a workaround you can edit /usr/bin/zmupdate.pl and add the block that upgrades from 1.24.1. Take a look, you will see that it's easy.

User avatar
zoneminder
Site Admin
Posts: 5220
Joined: Wed Jul 09, 2003 2:07 pm
Location: Bristol, UK
Contact:

Post by zoneminder » Tue Jun 30, 2009 7:52 am

Yikes! Don't know how that got missed out and I have fixed/updated the tarball. Fortunately in this case it's just replacement of local monitor presets so nothing critical. It's easy enough to add manually if you look at db/zm_update-1.24.2.sql
Phil

User avatar
monex
Posts: 169
Joined: Mon Jan 22, 2007 1:10 pm

Post by monex » Tue Jun 30, 2009 6:09 pm

Thanks you for the fix,

Monex
Image

Post Reply

Who is online

Users browsing this forum: No registered users and 9 guests