I've got the libmysqlclient.a blues with Suse 11.1

Forum for questions and support relating to the 1.24.x releases only.
Post Reply
crowning
Posts: 3
Joined: Sat Jun 27, 2009 1:18 pm

I've got the libmysqlclient.a blues with Suse 11.1

Post by crowning » Sat Jun 27, 2009 1:30 pm

Hello,

I've installed Suse 11.1 with the standard mysql+libmysqlclient 5.0.67 packages.
When ZoneMinder complained about the missing libmysqlclient.a library
I've searched this forum to find out that the mysql-devel package is
missing, but this package is unfortunately missing in the current Suse
11.1 distribution (it was there in 10.x distributions, though).

After further searching I de-installed mysql, build mysql from scratch
from the current 5.1.35 source package from mysql.com, copied the
include files to /usr/include (and added a link to /usr/locale/include),
copied the libmysqlclient.a to /usr/lib, run ldconfig...

Issue still not solved.

My question: is there anybody out there who has successfully installed
ZoneMinder on a Suse 11.1 box, preferably with the original mysql 5.0.67?

Thanks in advance for your help.

Cheers,
Tom

User avatar
monex
Posts: 169
Joined: Mon Jan 22, 2007 1:10 pm

Post by monex » Sat Jun 27, 2009 2:25 pm

Hi,

of course I did ;) The mysql-devel package was renamed in openSuSE to libmysqlclient-devel. I'm not sure if it is part of the DVD contents but it is available in the openSuSE standard repository http://download.opensuse.org/repositori ... 1/standard

Can also use the available RPM http://www.zoneminder.com/wiki/index.ph ... s_for_SuSE to install ZoneMinder

Hope this helps

Monex
Image

crowning
Posts: 3
Joined: Sat Jun 27, 2009 1:18 pm

Post by crowning » Sat Jun 27, 2009 4:16 pm

monex wrote:Hi,

of course I did ;) The mysql-devel package was renamed in openSuSE to libmysqlclient-devel. I'm not sure if it is part of the DVD contents but it is available in the openSuSE standard repository http://download.opensuse.org/repositori ... 1/standard

Can also use the available RPM http://www.zoneminder.com/wiki/index.ph ... s_for_SuSE to install ZoneMinder

Hope this helps

Monex
OMG, that was embarrassingly simple. I searched the forum up and down, but it never occurred to me to search the Wiki.

Thanks a lot!

Tom

User avatar
cordel
Posts: 5210
Joined: Fri Mar 05, 2004 4:47 pm
Location: /USA/Washington/Seattle
Contact:

Post by cordel » Tue Jul 07, 2009 7:47 am

Just to note and in case anyone else comes across this thread with a simular issue, Packages across distros ill have varying names. While most of what you find here on the forums started using RedHat common package names (you'll find these allot in early forum posts) they do relate to a degree.

Development packages aka devel, dev, etc do vary in the actual names across distros so searching for a more generic term can help you locate what you need.

Post Reply

Who is online

Users browsing this forum: No registered users and 8 guests