Page 1 of 3

Geovision GV800

Posted: Thu Sep 25, 2008 6:03 am
by Normando
I have read all the posts about Geovision is not compatible with linux because dongle.

But why I can see a distorted video from one of these cards?

The card show me a distortion like when using an NTSC camera set as PAL or vicerversa, and a width line at the botom, but works!

I look that Cordel and Sharp was try without succes to run this card. I want to know what type of test was over this card, and what are the results.

I don't know if you try, but I will try to run under windows and try to capture with btspy oftware from

I will post here any news.

Posted: Thu Sep 25, 2008 4:48 pm
by Normando
Well, I have tested the board in windows xp machine, with the legacy software and run.

I have captured with btspy software some parameters.

Then, I have uninstalled the original drivers and installed the custom driver from my capture file. The result is the same as linux, or a little better.

I have get a gray scale image image (with a few little orange vertical lines). At linux I have get only a gray scale distorted image.

So? Nothing, no linux support.

When running with the propietary software the image quality is bad. The same camera connected to a pico look much better.

For those of you who want to play with geovision driver, run the driver installer as say at

At the bottom I pasted the custom capture.

Another issue. What about this code: ... tv-cards.c

Look into this code and you will see a Geovision GV600 support.
Can anyone confirm this?

That's all

Code: Select all

### BtSpy Report ###

General information:
 Chip: Bt878 , Rev: 0x00
 Subsystem: 0x763c800a
 Vendor: Illegal/unknown Vendor ID
 Values to MUTE audio:
  Mute_GPOE  : 0x0f107f
  Mute_GPDATA: 0x04005e
 Has TV Tuner: No
 Number of Composite Ins: 1
  Composite in #1
   Composite1_Mux   : 2
   Composite1_GPOE  : 0x0f107f
   Composite1_GPDATA: 0x040058
 Has SVideo: No
 Has Radio: No

Add here all the comments you want!
	If your card can decode Stereo TV , and
your card does NOT use one of the following
chips, you will have to "peek" the right
GPDATA and GPOE values to enable Stereo and
SAP audio. The driver already supports the
DPL3518, MSP34xx, PT2254, TDA7432, TDA8425,
TDA9840, TDA9850, TDA9855, TDA9873, TDA9874,
TDA9875, TEA6300 and TEA6420 and does not require
extra information to drive them!

If you are able to get your card working using
this program , please , mail me this file (with
any extra comments you would like to add) to: , so I can add native support
to your card in the next driver release!

Posted: Sat Jul 18, 2009 2:28 pm
by timmans
It appears that the kernel from 2.6.30 will now support GV800, according to this link: ... 3b51590cbb

So if this card is supported in the kernel, does that mean that Zoneminder will automatically support it as well?

Posted: Wed Jul 29, 2009 6:26 pm
by cordel
Very likely it is.

Posted: Fri Aug 07, 2009 2:22 am
by giloosh
i too use a geovision on windows xp, but would like to try it on ubuntu with zoneminder. can anyone confirm that it will work?

It Works!

Posted: Fri Aug 21, 2009 4:20 pm
by terciof
Hi all!

I installed a Ubuntu 9.04 box with kernel 2.6.30 and my GV-800(S) is working!

I have all channels working on Zone Minder OOTB.

I didn't test the audio input, but as the driver creator, it's not working yet.



Posted: Fri Aug 21, 2009 4:48 pm
by terciof
The camera map is:

Camera 1 -> /dev/video0 channel 0
Camera 2 -> /dev/video1 channel 0
Camera 3 -> /dev/video2 channel 0
Camera 4 -> /dev/video3 channel 0

Camera 5 -> /dev/video0 channel 1
Camera 6 -> /dev/video1 channel 1
Camera 7 -> /dev/video2 channel 1
Camera 8 -> /dev/video3 channel 1

Camera 9 -> /dev/video0 channel 2
Camera 10 -> /dev/video1 channel 2
Camera 11 -> /dev/video2 channel 2
Camera 12 -> /dev/video3 channel 2

Camera 13 -> /dev/video0 channel 3
Camera 14 -> /dev/video1 channel 3
Camera 15 -> /dev/video2 channel 3
Camera 16 -> /dev/video3 channel 3

Those devices are only valid if only the GV-800(S) is available.

I tested it in conjunction with a pico2000 and the Pico2000 get /dev/video0 and the GV-800(S) get video1 ~ video4.



Only one /dev/video

Posted: Fri Aug 21, 2009 10:30 pm
by alerios
Hello terciof

I have also tried the driver today, and I get black/withe video from only one of the 2 cameras, and I only have /dev/video0, and not /dev/video1-3

Here is my /etc/modprobe.d/options:

options bttv card=157,157,157,157 tuner=4,4,4,4 gbuffers=32 radio=0,0,0,0 coring=1 full_luma_range=1 chroma_agc=1 combfilter=1 triton1=0 vsfx=0

I also tried:

options bttv card=157,157,157,157,157,157,157,157 tuner=4,4,4,4,4,4,4,4

Only one bt878 video controller listed on lspci

Posted: Fri Aug 21, 2009 11:47 pm
by alerios
After looking at the bttv patch for GV-800, I see that the example has 4 Video and 4 Audio controllers listed on lspci output, but I only have one (and I'm sure to have all channels OK, because I also test the card on windows on the same machine)

Here is lspci output:

00:00.0 Host bridge: Intel Corporation 82865G/PE/P DRAM Controller/Host-Hub Interface (rev 02)
00:02.0 VGA compatible controller: Intel Corporation 82865G Integrated Graphics Controller (rev 02)
00:1e.0 PCI bridge: Intel Corporation 82801 PCI Bridge (rev c2)
00:1f.0 ISA bridge: Intel Corporation 82801EB/ER (ICH5/ICH5R) LPC Interface Bridge (rev 02)
00:1f.1 IDE interface: Intel Corporation 82801EB/ER (ICH5/ICH5R) IDE Controller (rev 02)
00:1f.2 IDE interface: Intel Corporation 82801EB (ICH5) SATA Controller (rev 02)
00:1f.3 SMBus: Intel Corporation 82801EB/ER (ICH5/ICH5R) SMBus Controller (rev 02)
00:1f.5 Multimedia audio controller: Intel Corporation 82801EB/ER (ICH5/ICH5R) AC'97 Audio Controller (rev 02)
01:01.0 Ethernet controller: ADMtek NC100 Network Everywhere Fast Ethernet 10/100 (rev 11)
01:03.0 Multimedia video controller: Brooktree Corporation Bt878 Video Capture (rev 11)
01:03.1 Multimedia controller: Brooktree Corporation Bt878 Audio Capture (rev 11)

My mistake

Posted: Sat Aug 22, 2009 1:11 am
by alerios
Seems that my card is not a GV-800, but a GV-600(S) DB-Type ( ... ge/600.jpg). Anyway, as I said before, I can see one camera image, which is much better that the blue screen.

Here is dmesg output:

[ 15.686780] bttv: driver version 0.9.18 loaded
[ 15.686786] bttv: using 32 buffers with 2080k (520 pages) each for capture
[ 15.686881] bttv: Bt8xx card found (0).
[ 15.686902] bttv 0000:01:03.0: PCI INT A -> GSI 19 (level, low) -> IRQ 19
[ 15.686916] bttv0: Bt878 (rev 17) at 0000:01:03.0, irq: 19, latency: 32, mmio: 0xfc001000
[ 15.687271] bttv0: subsystem: 600a:763d (UNKNOWN)
[ 15.687274] please mail id, board name and the correct card= insmod option to
[ 15.687279] bttv0: using: Geovision GV-800(S) (slave) [card=158,insmod option]
[ 15.687283] IRQ 19/bttv0: IRQF_DISABLED is not guaranteed on shared IRQs
[ 15.687314] bttv0: gpio: en=00000000, out=00000000 in=00ffbaff [init]
[ 15.687403] bttv0: tuner absent
[ 15.687490] bttv0: registered device video0
[ 15.687550] bttv0: registered device vbi0
[ 15.687572] bttv0: PLL: 28636363 => 35468950 .. ok

GeoVision GV 900

Posted: Thu Sep 10, 2009 4:36 pm
by CoYoTe
I'm fighting with a GeoVision GV 900 board.

Using option 77 in bttv drviver, i made it work with 6 channels.
I'm trying to map the inputs.

For example. CAM 2 is VIDEO2 CHANNEL 0, CAM 3 is VIDEO4 CHANNEL 0, but CAM 5 is VIDEO0 CHANNEL 0, so there's no logic in it.

If anyone knows about some kind of scanner to use trying to determine the active inputs, i'll be apreciated.

When I finnaly set all up, (if it works) i'll post the settings


Posted: Tue Sep 22, 2009 3:33 am
by Neppon
Hello and regards from Brazil!

I was tired from random reboot in win xp and try run the gv800 in ubuntu with zoneminder at this moment :c)

I can say that´s its nothing difficult task. read some about (google dig, hehe) and figure out that with kernel 2.6.30 and over will detect the card with no need some code.

Well, first downad and fresh install ubuntu 9.04... make normal distro updates... and see that kernel it´s 2.6.29 (nothing it´s perfect)... will do a binary update, because it´s more fast in a shell like root (or sudo before the command):

#wget ... 0_i386.deb
#dpkg -i linux-headers-2.6.30-020630-generic_2.6.30-020630_i386.deb

#wget ... 30_all.deb
#dpkg -i linux-headers-2.6.30-020630_2.6.30-020630_all.deb

#wget ... 0_i386.deb
#dpkg -i linux-image-2.6.30-020630-generic_2.6.30-020630_i386.deb

Reboot and now have kernel 2.6.30 for default in GRUB :c)
The card it´s listed:
# lspci |grep video
05:00.0 Multimedia video controller: Brooktree Corporation Bt878 Video Capture (rev 11)
05:04.0 Multimedia video controller: Brooktree Corporation Bt878 Video Capture (rev 11)
05:08.0 Multimedia video controller: Brooktree Corporation Bt878 Video Capture (rev 11)
05:0c.0 Multimedia video controller: Brooktree Corporation Bt878 Video Capture (rev 11)

And dev links it´s self created:
# ls -la /dev/video*
crw-rw-rw-+ 1 root video 81, 0 2009-09-21 22:31 /dev/video0
crw-rw-rw-+ 1 root video 81, 2 2009-09-21 22:31 /dev/video1
crw-rw----+ 1 root video 81, 4 2009-09-21 22:14 /dev/video2
crw-rw----+ 1 root video 81, 6 2009-09-21 22:14 /dev/video3

Time to install zone in a shell like root (or sudo before the command):
#apt-get install zoneminder

Now need apache2 configure.. there are two ways: edit documentroot or name a link .. make link it´s more easy and fast in a shell like root (or sudo before the command):
#ln -s /usr/share/zoneminder/ /var/www/zm
You will access the site like http://localhost/zm

The user alerios was asked about card model...
let´s see lspci again (4 video and 4 audio channels detect... this is the last one listed):
# lspci -v
05:0c.1 Multimedia controller: Brooktree Corporation Bt878 Audio Capture (rev 11)
Subsystem: Device 800d:763d
Flags: bus master, medium devsel, latency 32, IRQ 255
Memory at dfef8000 (32-bit, prefetchable)

Humm... let´s see all devices 763d:

# lspci -v |grep 763d
Subsystem: Device 800a:763d
Subsystem: Device 800a:763d
Subsystem: Device 800b:763d
Subsystem: Device 800b:763d
Subsystem: Device 800c:763d
Subsystem: Device 800c:763d
Subsystem: Device 800d:763d
Subsystem: Device 800d:763d

Then I was take a look in the diff (on kernel sources) for kernel above 2.6.30 and figure out that have two card options to be used in modprobe for bttv:

157 -> Geovision GV-800(S) (master)[800a:763d]
158 -> Geovision GV-800(S) (slave) [800b:763d,800c:763d,800d:763d]

And figure out that the first card it´s master (157) and other three are slave (158) card :c)

It´s time to insert the bttv.conf with default values plus the card value above:

#cat /etc/modprobe.d/bttv.conf

# i2c
alias char-major-89 i2c-dev
options i2c-core i2c_debug=1
options i2c-algo-bit bit_test=1

# bttv
alias char-major-81 videodev
alias char-major-81-0 bttv
options bttv card=157,158,158,158 tuner=4,4,4,4 radio=0
options tuner debug=1

Now reboot and cross the fingers!
Login and open firefox at http://localhost/zm and it opens!

Well almost there.. need configure video cams linked to correct cams.. don´t worry, will be easy:

Hit "add new monitor", wil open a new window.. then give a name to you cam (like cam1), let the source to "local", and the function change to "modect" (just for example, you may change it later).. at up hit "source"
and now tha comes the important part: the "device path" need to point to 1 of 4 video controlers... and my case will use "/dev/video0" because my cam it´s on port 1 fom video conectors of card. on "devide channel" need use "0"... set you cam correct "format", my it´s "NTSC", "pallete", my it´s "RGB24", "witdht", my it´s "352" and "height" it´s "288" and just hit save.

My second cam it´s of port 2 from card that will use "/dev/video1" and channel "0"... just follow the table that terciof give to us (thanks!)

Well... the "cam1" it´s listed.. you may hit in "cam1" name to see the image... need hit "F5" to update the image.. but will change to a better option now:

First download and extract the "cambozola" in "/usr/bin"

At main page, hit options, at up hit "images", turn on the "Is the (optional) cambozola java streaming client installed (?)" ... and fill the "Web path to (optional) cambozola java streaming client (?)" with "/usr/bin/cambozola.jar".. now hit "save" and refresh the main page. hit again on "cam1" and will see the image from cam moving (but just in forefox... on internet explorer the image still freezed) :c)

*** I was tried mpeg4 option....change the encoder from ffpmpeg to mpeg_encode... with no result... the "cambozola" saves my day! ***

At this moment I´m trying to up my cam resolution over then 352x288 because I use 640x480 in xp, but in Zm sill without image sucess ... time to more google dig, driver ".c" read and drink more cofee :c)

I hope to help my new friends and exchange knowlenge.
Sorry by my poor language skill´s and wish luck to anyone who try follow my steps, and sorry to make this "big" post.



Posted: Tue Sep 22, 2009 2:59 pm
by CoYoTe
Neppon, great work!

the solution to increase the working resolution is, getting a bigger Sharemem in kernel config

edit your /etc/sysctl.conf

and add at the botton

Code: Select all

kernel.shmall = 167772160
kernel.shmmax = 167772160
With this settings a pico2000 board works with 4 channels in 640x480. Try bigger values if this ones dont work. You must restart the system, this values are valid uppon reboot only.


Posted: Tue Sep 22, 2009 6:07 pm
by Neppon
CoYoTe wrote: the solution to increase the working resolution is, getting a bigger Sharemem in kernel config

Code: Select all

kernel.shmall = 167772160
kernel.shmmax = 167772160
Nice tip, Alejandro!

I was tried the kernel.shmmax with no sucess... the corret it´s use kernel.shmmax and kernel.shmall ... it´s working in 640x480 at 100% now...

Another question: when you look the image moving, you see some lines aberation, like in wrong data rate conversion .. in xp the video are very smooth and clear.. perhaps need use some blob filter with odd lines .. or use another mpeg encoder... or jpg encode setting or quality...
anyone figure out how to do it?


Posted: Mon Oct 05, 2009 4:06 pm
by CoYoTe
working in high resolutions (beyond 352x288 PAL or 320x240 in NTSC) generates this kind of problems. The original windows soft, works in 320x240, if you set it up to work in 640x480 you'll see the same kind of glitchs.

Maybe you can try to process the frames with FFMPEG. You gonna loose some capacities of zoneminder (like modect or scale) but it can improve video quality. And of course you gonna have a delay in vid (i was testing and get about 1 or 2 secs)

A good solution to implement can be make a channel switch resolution when zoomed, but it's not easy to do... maybe in a future release...