Help with "Shared data size conflict in shared_data.."

Post here to ask any questions about hardware suitability, configuration in ZoneMinder, or experiences. If you just want to know if something works with ZoneMinder or not, please check the Hardware Compatibility sections in the forum, and the Wiki first. Also search this topic as well.

Moderator: zoneminder

tl.almora
Posts: 5
Joined: Thu Dec 13, 2012 6:31 am

Help with "Shared data size conflict in shared_data.."

Postby tl.almora » Thu Dec 13, 2012 6:47 am

Hi Everyone
I hope somebody can help me. I'm making a few probes with ZM 1.25.0 and I'm having this message in the System Log:
" Shared data size conflict in shared_data for monitor Monitor-0, expected 328, got 316 "
I'm working with a Laptop Acer Aspire 4425, and there's no problem with the camera view, it's just the legend above.
The camera in working as Local monitor, with NTSC format and YUYV palette.
The system is installed LMDE.
Sorry for the orthography, but my english is on a 50% & I have a few problems to describe some things :oops: .

Thank for the attention.

PacoLM
Posts: 895
Joined: Wed Dec 02, 2009 9:55 pm
Location: Spain

Re: Help with "Shared data size conflict in shared_data.."

Postby PacoLM » Thu Dec 13, 2012 12:37 pm

Look for the error using the search in the forum, this questions has been answered at least 100 times!

mini-ITX system (6 IPCams - Ubuntu14.04 - ZM1.29 - ZMNinja)

tl.almora
Posts: 5
Joined: Thu Dec 13, 2012 6:31 am

Re: Help with "Shared data size conflict in shared_data.."

Postby tl.almora » Sun Dec 16, 2012 2:22 am

Thanks, sorry but I didn't know how to search here :wink:
I've change the /Memory.pm and the alert is gone, but the monitor remaind ORANGE.
Is this normal? I mean, Could there be a failure in the future?

PacoLM
Posts: 895
Joined: Wed Dec 02, 2009 9:55 pm
Location: Spain

Re: Help with "Shared data size conflict in shared_data.."

Postby PacoLM » Sun Dec 16, 2012 3:25 pm

Post your logs, let's see why your monitor is orange.

Restart your system and copy the logs in /var/log/syslog

Regards

mini-ITX system (6 IPCams - Ubuntu14.04 - ZM1.29 - ZMNinja)

tl.almora
Posts: 5
Joined: Thu Dec 13, 2012 6:31 am

Re: Help with "Shared data size conflict in shared_data.."

Postby tl.almora » Mon Dec 17, 2012 11:35 pm

These is the only error displayed in the log:

2012-12-17 15:43:54.960530 zmupdate 2300 ERR Error check failed: '500 Can't connect to www.zoneminder.com:80 (Bad hostname)' zmupdate.pl

And these are the last records in Syslog

Dec 17 17:23:24 lmdezm zmc_dvideo0[2186]: INF [Monitor: 38000 - Capturing at 7.52 fps]
Dec 17 17:23:51 lmdezm zmpkg[28572]: INF [Command: stop]
Dec 17 17:23:52 lmdezm zmdc[2162]: INF ['zmfilter.pl ' stopping at 12/12/17 17:23:52]
Dec 17 17:23:52 lmdezm zmdc[2162]: INF [Can't find child with pid of '2163']
Dec 17 17:23:52 lmdezm zmdc[2162]: INF ['zmfilter.pl ' exited, signal 14]
Dec 17 17:23:52 lmdezm zmdc[2162]: INF ['zmaudit.pl -c' stopping at 12/12/17 17:23:52]
Dec 17 17:23:52 lmdezm zmdc[2162]: INF ['zmaudit.pl -c' exited, signal 14]
Dec 17 17:23:52 lmdezm zmdc[2162]: INF ['zmwatch.pl ' stopping at 12/12/17 17:23:52]
Dec 17 17:23:52 lmdezm zmdc[2162]: INF ['zmwatch.pl ' exited, signal 14]
Dec 17 17:23:52 lmdezm zmdc[2162]: INF ['zmc -d /dev/video0' stopping at 12/12/17 17:23:52]
Dec 17 17:23:52 lmdezm zmc_dvideo0[2186]: INF [Got signal 15 (Terminated), exiting]
Dec 17 17:23:52 lmdezm zmdc[2162]: INF ['zmc -d /dev/video0' exited normally]
Dec 17 17:23:52 lmdezm zmdc[2162]: INF ['zmupdate.pl -c' stopping at 12/12/17 17:23:52]
Dec 17 17:23:52 lmdezm zmdc[2162]: INF ['zmupdate.pl -c' exited, signal 14]
Dec 17 17:23:56 lmdezm dhclient: DHCPREQUEST on wlan0 to 192.168.1.254 port 67
Dec 17 17:23:56 lmdezm dhclient: DHCPACK from 192.168.1.254
Dec 17 17:23:56 lmdezm dhclient: bound to 192.168.1.120 -- renewal in 46 seconds.
Dec 17 17:24:02 lmdezm zmdc[2162]: INF [Server shutdown at 12/12/17 17:24:02]
Dec 17 17:24:14 lmdezm zmpkg[29337]: INF [Command: start]
Dec 17 17:24:17 lmdezm zmdc[29421]: INF [Server starting at 12/12/17 17:24:17]
Dec 17 17:24:20 lmdezm zmdc[29421]: INF ['zmc -d /dev/video0' starting at 12/12/17 17:24:20, pid = 29565]
Dec 17 17:24:20 lmdezm zmdc[29565]: INF ['zmc -d /dev/video0' started at 12/12/17 17:24:20]
Dec 17 17:24:21 lmdezm zmc_dvideo0[29565]: INF [Starting Capture]
Dec 17 17:24:21 lmdezm zmdc[29421]: INF ['zmfilter.pl' starting at 12/12/17 17:24:21, pid = 29578]
Dec 17 17:24:21 lmdezm zmdc[29578]: INF ['zmfilter.pl' started at 12/12/17 17:24:21]
Dec 17 17:24:21 lmdezm zmdc[29421]: INF ['zmaudit.pl -c' starting at 12/12/17 17:24:21, pid = 29591]
Dec 17 17:24:21 lmdezm zmdc[29591]: INF ['zmaudit.pl -c' started at 12/12/17 17:24:21]
Dec 17 17:24:22 lmdezm zmdc[29421]: INF ['zmwatch.pl' starting at 12/12/17 17:24:22, pid = 29604]
Dec 17 17:24:22 lmdezm zmdc[29604]: INF ['zmwatch.pl' started at 12/12/17 17:24:22]
Dec 17 17:24:22 lmdezm zmfilter[29578]: INF [Scanning for events]
Dec 17 17:24:23 lmdezm zmwatch[29604]: INF [Watchdog starting]
Dec 17 17:24:23 lmdezm zmwatch[29604]: INF [Watchdog pausing for 30 seconds]
Dec 17 17:24:23 lmdezm zmdc[29421]: INF ['zmupdate.pl -c' starting at 12/12/17 17:24:23, pid = 29620]
Dec 17 17:24:23 lmdezm zmdc[29620]: INF ['zmupdate.pl -c' started at 12/12/17 17:24:23]

And first of all thanks for the help so far. Is I see and other notification in ZM I'll post it in an other replay. Good day :)

PacoLM
Posts: 895
Joined: Wed Dec 02, 2009 9:55 pm
Location: Spain

Re: Help with "Shared data size conflict in shared_data.."

Postby PacoLM » Tue Dec 18, 2012 5:48 am

Code: Select all

2012-12-17 15:43:54.960530 zmupdate 2300 ERR Error check failed: '500 Can't connect to www.zoneminder.com:80 (Bad hostname)' zmupdate.pl


I think that you have set something wrong somewhere...why is your ZM system trying to connect to zoneminder.com:80??? You should connect to your local address.

PacoLM

mini-ITX system (6 IPCams - Ubuntu14.04 - ZM1.29 - ZMNinja)

tl.almora
Posts: 5
Joined: Thu Dec 13, 2012 6:31 am

Re: Help with "Shared data size conflict in shared_data.."

Postby tl.almora » Wed Dec 19, 2012 12:52 am

curiously the monitor is configurated as Local in /dev/video0, that's why the error is strange for me to :? . Any way, I'll keep watching the operation of the system and comparing with common problems of the forum. thank you very much :D


Return to “Hardware Queries”

Who is online

Users browsing this forum: No registered users and 1 guest