International/German Forum posts

A place for discussion of topics that are not specific to ZoneMinder. This could include Linux, Video4Linux, CCTV cameras or any other topic.
User avatar
monex
Posts: 169
Joined: Mon Jan 22, 2007 1:10 pm

Post by monex » Wed Nov 26, 2008 6:35 pm

Hallo,

die Daten der Kamera müssen exakt mit den Einstellungen übereinstimmen, d.h. man muss dafür sorge tragen, dass die Bilder von der Kamera exakt die eingestellte Auflösung liefern, soweit ich mich erinnere. Also sollte beim cgi Pfad sowas wie image.cgi?resolution=320x240 stehen (die Auflösung wird als Übergabeparameter an das cgi script übergeben), wenn die Eingestellte Auflösung bei ZM 320x240 ist. Wie man das genau bei der Kamera einstellt ist dem Handbuch der Kamera zu entnehmen, da sollte sowas aufgeführt sein, vielleicht passt ja auch eines der mitgelieferten presets für die Kamera :)

Wenn man nicht genau weiß woran es liegt, dass man lein Bild zu sehen bekommt oder man der Meinung ist alles korrekt eingestellt zu haben ist ein Blick in die Logfiles angeraten, am besten mal in /var/log/messages schauen, und wenn die Fehlermeldung unverständlich sein sollte hier am besten posten :)

Hoffe das hilft weiter
Image

OLD_hermann
Posts: 14
Joined: Thu Nov 20, 2008 7:12 pm
Location: Münster NRW Deutschland

Post by OLD_hermann » Thu Nov 27, 2008 9:12 pm

Danke erst mal für die Antwort monex

Habe die Kameras alle auf 320 x 240 stehen daran liegt es anscheinend nicht.
Hier mal die Einträge vom messages ab dem Start von ZM


Nov 27 22:35:41 linux-0ke6 zmdc[3330]: INF [Starting pending process, zmc -m 5]
Nov 27 22:35:41 linux-0ke6 zmdc[3330]: INF ['zmc -m 5' starting at 08/11/27 22:35:41, pid = 8056]
Nov 27 22:35:41 linux-0ke6 zmdc[8056]: INF ['zmc -m 5' started at 08/11/27 22:35:41]
Nov 27 22:35:41 linux-0ke6 zmc_m5[8056]: INF [Debug Level = 0, Debug Log = <none>]
Nov 27 22:35:41 linux-0ke6 zmc_m5[8056]: INF [Starting Capture]
Nov 27 22:35:41 linux-0ke6 zmc_m5[8056]: ERR [Invalid response status 401: Unauthorized]
Nov 27 22:35:41 linux-0ke6 zmc_m5[8056]: ERR [Unable to get response]
Nov 27 22:35:41 linux-0ke6 zmc_m5[8056]: ERR [Failed to post-capture monitor 0]
Nov 27 22:35:41 linux-0ke6 zmdc[3330]: ERR ['zmc -m 5' exited abnormally, exit status 255]
Nov 27 22:35:47 linux-0ke6 zmdc[3330]: INF [Starting pending process, zmc -m 3]
Nov 27 22:35:47 linux-0ke6 zmdc[3330]: INF ['zmc -m 3' starting at 08/11/27 22:35:47, pid = 8137]
Nov 27 22:35:47 linux-0ke6 zmdc[8137]: INF ['zmc -m 3' started at 08/11/27 22:35:47]
Nov 27 22:35:47 linux-0ke6 zmc_m3[8137]: INF [Debug Level = 0, Debug Log = <none>]
Nov 27 22:35:47 linux-0ke6 zmc_m3[8137]: ERR [No monitors found]
Nov 27 22:35:47 linux-0ke6 zmdc[3330]: ERR ['zmc -m 3' exited abnormally, exit status 255]
Nov 27 22:36:39 linux-0ke6 zms[8852]: INF [Debug Level = 0, Debug Log = <none>]
Nov 27 22:36:39 linux-0ke6 zms[8852]: WAR [Shared memory not initialised by capture daemon, some query functions may not be available or produce invalid results]
Nov 27 22:36:39 linux-0ke6 zms[8852]: ERR [Got signal (Floating point exception), crashing]
Nov 27 22:36:39 linux-0ke6 zms[8852]: ERR [Signal address is 66118, no eip ]
Nov 27 22:36:39 linux-0ke6 zms[8852]: ERR [Backtrace: /lib64/libc.so.6 [0x7ffaa1acc660]]
Nov 27 22:36:39 linux-0ke6 zms[8852]: ERR [Backtrace: /srv/www/cgi-bin/nph-zms [0x41e40f]]
Nov 27 22:36:39 linux-0ke6 zms[8852]: ERR [Backtrace: /srv/www/cgi-bin/nph-zms [0x4046e8]]
Nov 27 22:36:39 linux-0ke6 zms[8852]: ERR [Backtrace: /lib64/libc.so.6(__libc_start_main+0xe6) [0x7ffaa1ab8436]]
Nov 27 22:36:39 linux-0ke6 zms[8852]: ERR [Backtrace: /srv/www/cgi-bin/nph-zms(__gxx_personality_v0+0x1a1) [0x403df9]]
Nov 27 22:36:39 linux-0ke6 zms[8852]: INF [Backtrace complete]
Nov 27 22:36:41 linux-0ke6 zmwatch[3576]: INF [Restarting capture daemon for IP-CAM1, shared memory not valid]
Nov 27 22:36:41 linux-0ke6 zmdc[8887]: INF ['zmc -m 5' started at 08/11/27 22:36:41]
Nov 27 22:36:41 linux-0ke6 zmdc[3330]: INF ['zmc -m 5' starting at 08/11/27 22:36:41, pid = 8887]
Nov 27 22:36:41 linux-0ke6 zmwatch[3576]: INF ['zmc -m 5' starting at 08/11/27 22:36:41, pid = 8887]
Nov 27 22:36:41 linux-0ke6 zmc_m5[8887]: INF [Debug Level = 0, Debug Log = <none>]
Nov 27 22:36:41 linux-0ke6 zmc_m5[8887]: INF [Starting Capture]
Nov 27 22:36:41 linux-0ke6 zmc_m5[8887]: ERR [Invalid response status 401: Unauthorized]
Nov 27 22:36:41 linux-0ke6 zmc_m5[8887]: ERR [Unable to get response]
Nov 27 22:36:41 linux-0ke6 zmc_m5[8887]: ERR [Failed to post-capture monitor 0]
Nov 27 22:36:41 linux-0ke6 zmdc[3330]: ERR ['zmc -m 5' exited abnormally, exit status 255]

Beim Fehler code 401 Unauthorized müsste ich eigentlich einen user mit Password eingeben ich weiß aber nicht wo ich dem eintragen muss.

Da weiss ich auch nicht wie das abzustellen ist
Shared memory not initialised by capture daemon, some query functions may not be available or produce invalid results

PS: bei den Kameras handelt es sich um GRANDTEC Wi-Fi

mit freundlichen Grüßen . und vielen Dank
Hermann

User avatar
monex
Posts: 169
Joined: Mon Jan 22, 2007 1:10 pm

Post by monex » Fri Nov 28, 2008 4:15 pm

Hallo,

der Eintrag für Benutzer und Passwort wird ebenfalls über die URL übergeben, z.b.: http://user:password@<ip>/image.cgi?resolution=320x240 Es kann aber auch sein, dass es per Option übergeben wird, dann sollte das ebenfalls in der Dokumentation der Kamera stehen (eventuell kommt dann sowas wie ?user=<user>&password=<password> als Übergabeparameter hinzu).
Image

OLD_hermann
Posts: 14
Joined: Thu Nov 20, 2008 7:12 pm
Location: Münster NRW Deutschland

Post by OLD_hermann » Fri Nov 28, 2008 7:10 pm

Danke monex
Das war der richtige Tipp.
Es reicht wenn man es so eingibt
z.B. root:admin@192.168.1.100

So eine Kleinigkeit und solange danach gesucht.

Nochmals vielen Dank !!!!!
Hermann
:D :D :D :D

User avatar
monex
Posts: 169
Joined: Mon Jan 22, 2007 1:10 pm

Post by monex » Sat Nov 29, 2008 4:02 pm

Keine Ursache :)

Manchmal sind es eben Kleinigkeiten, an denen es hängt.
Image

OLD_hermann
Posts: 14
Joined: Thu Nov 20, 2008 7:12 pm
Location: Münster NRW Deutschland

Hardware ?

Post by OLD_hermann » Mon May 11, 2009 6:18 pm

Hallo Forenmitglieder !
Ich hab da mal eine Frage über die Hardware.

Ich möchte eine Sache installieren mit ca. 8-10 IP-Cameras (Kein Wlan)
Welche Camera aus der Harwareliste sollte ich dafür auswählen.

AXIS, Airlink ,Level One oder welche läuft am besten unter Zoneminder ??

Vielen dank in Voraus
Hermann

User avatar
monex
Posts: 169
Joined: Mon Jan 22, 2007 1:10 pm

Post by monex » Tue May 12, 2009 9:15 am

Hallo,

eigentlich sollten IP-Kameras kein Problem darstellen, so lange sie eine Schnittstelle anbieten, über die man die Bilder herunterladen kann, bzw. einen Video-Stream anbietet.

AXIS haben mir ganz gut gefallen, die anderen aufgelisteten habe ich nicht noch nicht probiert. Mobotix ging auch ganz gut.

Hoffe das hilft erst mal weiter.
Image

OLD_hermann
Posts: 14
Joined: Thu Nov 20, 2008 7:12 pm
Location: Münster NRW Deutschland

HUNDT IP Kamera

Post by OLD_hermann » Fri Jul 03, 2009 4:33 pm

Hallo Forenmitglieder

Ich hab da mal eine Frage zu einer Hundt IP-Kamera

Kennt jemand den genauen Befehl um eine Stream von einer HUNT Netzwerk Kamera zu erhalten ??
wget --user=xxxx --password=xxxx http://192.168.1.200:80/video.???
oder so ???
Hab schon eine anfrage am Hersteller gestellt aber bis dato keine Antwort erhalten.

(http://www.hunt.com.tw)

Dank in vorab
Hermann

OLD_hermann
Posts: 14
Joined: Thu Nov 20, 2008 7:12 pm
Location: Münster NRW Deutschland

Post by OLD_hermann » Sun Jul 26, 2009 5:06 pm

Hallo Leute
Bis jetzt habe ich das raus bekommen
wget --user=admin --password=admin http://192.168.1.200:80/GetStream.cgi?Video=0 -O test2.xxx
Erzeugt eine Datei, nach dem Daten Volumen was sich da pro Sek. ansammelt müsste es ein Video Stream sein.
Ich weiß nur nicht in welchen Containerformat das dann genau vorliegt.

Kommerziellen Videoüberwachungsysteme kenne die Kameras ja eigentlich . z.b. GO1984 usw.
interessant ist das ich nichts bei den Suchmaschinen über den Befehl finden kann.

Bis dahin
Hermann

drew10
Posts: 3
Joined: Mon Jul 27, 2009 6:06 am

Post by drew10 » Mon Jul 27, 2009 6:08 am

ich habe keine karte eingebaut es dann eine usb-cam und eine ip-cam drann laufen.

OLD_hermann
Posts: 14
Joined: Thu Nov 20, 2008 7:12 pm
Location: Münster NRW Deutschland

Post by OLD_hermann » Thu Jul 30, 2009 7:43 pm

Sorry
Die Antwort (Frage) verstehe ich nicht wirklich.

mfg
Hermann

OLD_hermann
Posts: 14
Joined: Thu Nov 20, 2008 7:12 pm
Location: Münster NRW Deutschland

Post by OLD_hermann » Sun Aug 09, 2009 5:12 pm

Problem gelöst Hunt Kamera
So ist es nun bei mir eingestellt und dann geht es.
Bei der Einstellung kommen JPEG bilder

Entfernter Hostname:user:password@192.168.1.200
Entfernter Hostport:80
Entfernter Hostpfad:/GetImage.cgi?CH=0 (oder CH=2 für channel 2)
Remote Host SubPath
Entfernte Bildfarbe 24
Erfasse Breite (Pixel):720
Erfasse Höhe (Pixel): 576

so long
Hermann

bash
Posts: 1
Joined: Thu Aug 20, 2009 6:37 pm

Deutsche Anleitu

Post by bash » Thu Aug 20, 2009 6:42 pm

Hallo,

bin noch ein Anfänger in sachen Linux, würde gern aber zoneminder testen.
Gibt es eine gute deutsche anleitung?

Zwei fragen hätte ich noch..

Reicht es wenn ich Ubuntu installiere, oder brauche eine bestimmte server vision, quasi wie windwos server?

und muss zoneminder direkt in netz installiert weden? d.h muss der pc in gelich netz sein oder kann ich den server auch bei mir zuhause aufstellen?

gruss und danke
bash

User avatar
monex
Posts: 169
Joined: Mon Jan 22, 2007 1:10 pm

Post by monex » Sat Aug 22, 2009 10:17 am

Hallo,

leider gibt es soweit ich weiß keine deutsche Anleitung für die Installation oder den Betrieb von ZoneMinder.

ZoneMinder sollte auf allen gängigen Linux Distributionen laufen, eine spezielle Version ist nicht erforderlich. Wenn man ZoneMinder testen möchte, würde ich die Mandriva Live CD empfehlen. Ansonsten gibt es für viele Distributionen bereits fertige Pakete, die einem die Installation erleichtern.

Viel Erfolg.

Dirk
Image

OLD_hermann
Posts: 14
Joined: Thu Nov 20, 2008 7:12 pm
Location: Münster NRW Deutschland

Post by OLD_hermann » Sat Aug 22, 2009 4:43 pm

Hallo erst mal

Einen kleinen Link der dir helfen könnte.
http://www.linuxforen.de/forums/showthread.php?t=252320

Schau dir den mal an.
er hat mir auch sehr geholfen ZM ans laufen zu bekommen.

Die Anleitung gibt es auch hier im WIKI.

mfg.
Hermann

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest