Page 1 of 3

Reolink RLC-410 Data Streams

Posted: Thu Feb 23, 2017 3:07 am
by pdmedic
So after searching and trial and error I got my RLC-410 camera working with both the high quality and low quality video using low quality as a detector and recording the high quality. Anyway to save others (and myself in the future) from this trial and error here are the settings.

High Quality after you have set it up in the on-line site as clear

Source Ffmpeg
rtsp://user:password@ipaddress:554/h264Preview_01_main
RTP/RTSP
Capture width and pixels as set

Low Quality set up on-line as fluent

Source Ffmpeg
rtsp://user:password@ipaddress:554/h264Preview_01_sub
RTP/RTSP
Capture width and pixels as set

Hope that helps someone it took me way to long to figure out how to get both streams working.

Re: Reolink RLC-410 Data Streams

Posted: Fri Feb 24, 2017 1:00 pm
by vox
Can you post some screenshot please? :) This camera is a copy/alternative of Trendnet TV-IP310PI.
The WEBUI work fine ?

Re: Reolink RLC-410 Data Streams

Posted: Mon Mar 06, 2017 10:46 pm
by pgrunwald
One thing I found playing with this camera is that ONVIF works but the camera has to have both a user name and password set. It would not work with "admin" and a blank password which is default.
rlc-410 probe.png
rlc-410 probe.png (13.63 KiB) Viewed 23428 times
latest firmware


rlc-410 firmware.png
rlc-410 firmware.png (96.99 KiB) Viewed 23428 times

Re: Reolink RLC-410 Data Streams

Posted: Thu Jan 18, 2018 4:14 am
by operat0r
I gave up on ZoneMinder... I could never get the quality anywhere near the live feed. Good idea on using both streams so I guess I could use zoneminder at 640 480 for motion but I have been looking at CNN and crazy YOLOv2 stuff. This example uses GPU so your CPU does not suffer

Code: Select all

# compile from source for extra credit :)
wget https://raw.githubusercontent.com/moeiscool/ffmpegTheEasyWay/master/ffmpeg.sh

# dump using GPU vdpau every hour new file

ffmpeg -c:v h264_vdpau -rtsp_transport tcp -i "rtsp://admin:@25.0.0.238/h264Preview_01_main" -f segment -segment_time 3600 -segment_format mp4  -reset_timestamps 1 -strftime 1 -c copy -map 0 CAM1-%Y%m%d-%H%M%S.mp4



Re: Reolink RLC-410 Data Streams

Posted: Mon Mar 19, 2018 1:38 am
by simonlok
I have a setup with multiple Dahua 1320 and Amcrest units and the ZM works great. However when I load in a RLC-410 with this firmware:

Model RLC-410
Build No. build 17112701
Hardware No. IPC_3816M
Configuration Version v2.0.0.0
Firmware Version v2.0.0.889_17112701
Details IPC_3816M110000000000000
Client Version v1.0.227

They can be connected via FFmpeg or via the Remote - RTP/RTSP options. The Remote RTP/RTSP options are much better.

(general tab) Source Type: Remote
(Source tab rest)
Proto: RTSP
Method: RTP/RTSP
Remote Host: user:pass@ipaddress
Port: 554
Path: /h264Previoew_01_main

Re: Reolink RLC-410 Data Streams

Posted: Sun Sep 02, 2018 11:03 am
by DerGraf
I have a lot of ffmpeg smearing issues with RLC-410-5MP on ZM 1.31.45

Now i want to try "Remote". Unfortunately i got a 404 error (stream not found) and dont know why :evil:
All settings are fine.

Anyone has an idea?

Re: Reolink RLC-410 Data Streams

Posted: Sun Sep 02, 2018 10:20 pm
by iconnor
iconnor is now in possession of two of these cameras, so he (I) should be able to determine the problem and fix it.

One one the picture is perfect, on the other is smears like crazy.

Re: Reolink RLC-410 Data Streams

Posted: Mon Sep 03, 2018 4:20 pm
by DerGraf
iconnor wrote:
Sun Sep 02, 2018 10:20 pm
so he (I) should be able to determine the problem and fix it
Hope you find the problem. I can´t reproduce the issue. Smearing comes up 1-2 times a day for around 2 hours. When it works the camera make very good pictures.

Re: Reolink RLC-410 Data Streams

Posted: Tue Sep 04, 2018 4:32 pm
by DerGraf
Todays smearing starts 8:43am and stops at 10:55am

zmdc logs:

Code: Select all

2018-09-04 10:55:34.065520	zmdc		8866	ERR	'zma -m 2' exited abnormally, exit status 255	zmdc.pl	
2018-09-04 10:55:33.940460	zmdc		8866	ERR	'zma -m 2' exited abnormally, exit status 255	zmdc.pl	
2018-09-04 09:09:02.632770	zmdc		8866	ERR	'zma -m 2' exited abnormally, exit status 255	zmdc.pl	
2018-09-04 08:44:21.808430	zmdc		8866	ERR	'zma -m 2' exited abnormally, exit status 255	zmdc.pl	
2018-09-04 08:44:11.304170	zmdc		8866	ERR	'zma -m 2' exited abnormally, exit status 255	zmdc.pl	
2018-09-04 08:44:11.057800	zmdc		8866	WAR	Can't find process with command of 'zmc -m 2'	zmdc.pl	
2018-09-04 08:44:06.976600	zmdc		8866	ERR	'zma -m 2' exited abnormally, exit status 255	zmdc.pl	
2018-09-04 08:44:01.894290	zmdc		8866	ERR	'zma -m 2' exited abnormally, exit status 255	zmdc.pl	
2018-09-04 08:44:00.817190	zmdc		8866	ERR	'zma -m 2' exited abnormally, exit status 255	zmdc.pl	
2018-09-04 08:43:56.520510	zmdc		8866	ERR	'zma -m 2' exited abnormally, exit status 255	zmdc.pl	
2018-09-04 08:43:51.425090	zmdc		8866	ERR	'zma -m 2' exited abnormally, exit status 255	zmdc.pl	
2018-09-04 08:43:50.335770	zmdc		8866	ERR	'zma -m 2' exited abnormally, exit status 255	zmdc.pl	
2018-09-04 08:43:45.939540	zmdc		8866	ERR	'zma -m 2' exited abnormally, exit status 255	zmdc.pl	
2018-09-04 08:43:40.847780	zmdc		8866	ERR	'zma -m 2' exited abnormally, exit status 255	zmdc.pl	
2018-09-04 08:43:39.755150	zmdc		8866	ERR	'zma -m 2' exited abnormally, exit status 255	zmdc.pl	
2018-09-04 08:43:20.233390	zmdc		8866	ERR	'zma -m 2' exited abnormally, exit status 255	zmdc.pl	
2018-09-04 08:43:19.141360	zmdc		8866	ERR	'zma -m 2' exited abnormally, exit status 255	zmdc.pl	
2018-09-04 08:43:08.638870	zmdc		8866	ERR	'zma -m 2' exited abnormally, exit status 255	zmdc.pl
zma_m2 logs:

Code: Select all

2018-09-04 10:55:34.057402	zma_m2		22448	ERR	Got empty memory map file size 0, is the zmc process for this monitor running?	zm_monitor.cpp	544
2018-09-04 10:55:33.934330	zma_m2		22447	ERR	Shared data not initialised by capture daemon for monitor Eingang	zm_monitor.cpp	483
2018-09-04 09:09:02.621401	zma_m2		17841	ERR	Got empty memory map file size 0, is the zmc process for this monitor running?	zm_monitor.cpp	544
2018-09-04 08:44:21.800698	zma_m2		16776	ERR	Got empty memory map file size 0, is the zmc process for this monitor running?	zm_monitor.cpp	544
2018-09-04 08:44:11.298759	zma_m2		16768	ERR	Shared data not initialised by capture daemon for monitor Eingang	zm_monitor.cpp	483
2018-09-04 08:44:06.969590	zma_m2		16758	ERR	Shared data not initialised by capture daemon for monitor Eingang	zm_monitor.cpp	483
2018-09-04 08:44:01.886278	zma_m2		16749	ERR	Shared data not initialised by capture daemon for monitor Eingang	zm_monitor.cpp	483
2018-09-04 08:44:00.811240	zma_m2		16727	ERR	Shared data not initialised by capture daemon for monitor Eingang	zm_monitor.cpp	483
2018-09-04 08:43:56.515023	zma_m2		16719	ERR	Shared data not initialised by capture daemon for monitor Eingang	zm_monitor.cpp	483
2018-09-04 08:43:51.419346	zma_m2		16718	ERR	Shared data not initialised by capture daemon for monitor Eingang	zm_monitor.cpp	483
2018-09-04 08:43:50.329652	zma_m2		16717	ERR	Shared data not initialised by capture daemon for monitor Eingang	zm_monitor.cpp	483
2018-09-04 08:43:45.932770	zma_m2		16709	ERR	Got empty memory map file size 0, is the zmc process for this monitor running?	zm_monitor.cpp	544
2018-09-04 08:43:40.840178	zma_m2		16708	ERR	Got empty memory map file size 0, is the zmc process for this monitor running?	zm_monitor.cpp	544
2018-09-04 08:43:39.749406	zma_m2		16707	ERR	Got empty memory map file size 0, is the zmc process for this monitor running?	zm_monitor.cpp	544
2018-09-04 08:43:20.226850	zma_m2		16694	ERR	Got empty memory map file size 0, is the zmc process for this monitor running?	zm_monitor.cpp	544
2018-09-04 08:43:19.135962	zma_m2		16693	ERR	Got empty memory map file size 0, is the zmc process for this monitor running?	zm_monitor.cpp	544
2018-09-04 08:43:08.633335	zma_m2		16682	ERR	Got empty memory map file size 0, is the zmc process for this monitor running?	zm_monitor.cpp	544
Help this? I cant nothing to do with this logs. The only thing i see is that the camera starts and starts and after a while starting was success and it run. :?:

Re: Reolink RLC-410 Data Streams

Posted: Sun Sep 30, 2018 9:24 pm
by epruesse
iconnor wrote:
Sun Sep 02, 2018 10:20 pm
iconnor is now in possession of two of these cameras, so he (I) should be able to determine the problem and fix it.

One one the picture is perfect, on the other is smears like crazy.
+=100 :)

I run ZM 1.32.0 from the PPA and my 410WS smears like crazy as well. It's no longer on wifi - bought powerline hoping that'd fix it. Firmware is most recent.

Do settings help? It allows

Profile: main/base/high
Framerate: 2-30
Bitrate: 1-8 mbit
Resolution: 4M (various), 1080, 720
Audio: bool

I'll happily verify patches if you manage to figure out what's going on.

Re: Reolink RLC-410 Data Streams

Posted: Wed Oct 03, 2018 9:06 am
by DerGraf
I´m back on 1.30.4
Since downgrade no smearing anymore.

Re: Reolink RLC-410 Data Streams

Posted: Tue Oct 30, 2018 2:07 pm
by janw
Hi! I'm on v1.32.2. RLC-410 via FFMPEG smears crazy. Cannot get Remote / RTSP to work. Here's the config, can someone validate? Any news on the smearing over ffmpeg?

Thanks!

Image

Re: Reolink RLC-410 Data Streams

Posted: Tue Nov 27, 2018 7:11 pm
by FlippingBinary
I found this forum post because I'm also having this problem. I have two Reolink RLC-420 cameras, but the issue I'm having seems to be the same as what is occurring with the Reolink RLC-410 cameras. The video smears along toward the bottom and the console page shows the fps is much lower than the camera is actually outputting. I turned the camera down to 15 fps but ZoneMinder is reporting around 2 fps. The camera's low bandwidth stream doesn't have as much of an issue and the ZoneMinder console reports just a frame or two below what the camera is set to. I have two other cameras from Great Wall Security which work as expected. I don't restrict any camera's fps in the ZoneMinder settings. The camera is wired to an unmanaged gigabit POE switch which is connected to a Cisco SG300 managed switch in layer 3 mode. The server is connected to that Cisco switch. There should be no latency issues.

If there is anything I can do to help diagnose the source of this problem, please let me know.

Re: Reolink RLC-410 Data Streams

Posted: Thu Nov 29, 2018 6:39 pm
by allanhitch
I've got RLC-410s in 4MP that work like a champ....
I just got a RLC-410 5 MP that I can't do anything with.... I can see it via a web-browser with no problem, but I can't get it to load up consistently in ZoneMinder, and VLC seems to be completely allergic to it....

Same as you guys.... ffmpeg smears like no tomorrow, and RTP/RTSP MIGHT work for a bit, then it goes away and NEVER comes back!

Re: Reolink RLC-410 Data Streams

Posted: Thu Nov 29, 2018 7:36 pm
by iconnor
What's with the height being 1072? Shouldn't it be 1080?