Page 1 of 1

Kodicom 8800 problem

Posted: Wed Oct 14, 2015 12:34 am
by darkpaw
I just reinstalled my system (it was offline for a couple months, waiting on new parts) and decided to go with Ubuntu 14.04 LTS. I'm fairly certain that this was the version I was using previously, though it's possible I'm mistaken. Since it's been a while and I couldn't remember the bttv options, I used what's listed in the ZM Wiki for the Kodicom 8800 options, but I'm getting an error when it loads the driver:

[ 8.258505] bttv: driver version 0.9.19 loaded
[ 8.258509] bttv: using 2 buffers with 2080k (520 pages) each for capture
[ 8.258547] bttv: Bt8xx card found (0)
[ 8.258641] bttv: 0: Bt878 (rev 17) at 0000:06:08.0, irq: 17, latency: 64, mmio: 0xf4ffe000
[ 8.258654] bttv: 0: using: IVC-200 [card=102,insmod option]
[ 8.258776] bttv: 0: tuner absent
[ 8.258779] bttv: 0: the autoload option is obsolete
[ 8.258781] bttv: 0: use option msp3400, tda7432 or tvaudio to override which audio module should be used
[ 8.258815] bttv: probe of 0000:06:08.0 failed with error -34

It does this for all 8 ports. Here is my bttv options in modprobe:

root@zm:/etc/modprobe.d# cat bttv.conf
options i2c-algo-bit bit test=1
options bttv gbuffers=64 card=102,102,102,102,102,102,102,102 radio=0,0,0,0,0,0,0,0 tuner=4,4,4,4,4,4,4,4 chroma_agc=1 combfilter=2 full_luma_range=1 coring=1 autoload=0

It seems odd that it previously was working, but now is not. Is the card dead, or do I have an option not set correctly? I would hate to have to buy a new analog card, as they are rather expensive now.

Re: Kodicom 8800 problem

Posted: Sat Oct 17, 2015 4:28 am
by darkpaw
A follow-up to this. Looks like the card was dead. I swapped it out with a Kodicom 4400R that I was using previously (upgraded to the 8-channel because I had 5 cams that I wanted at full rate, and the 4400 couldn't do it). The 4400R worked flawlessly, so the 8800 must unfortunately be toast.

Most of the "new" PCIe cards don't seem to work with Linux, which makes them a no-go with ZM. Any options for using something "semi-new" (ie: PCIe) with analog input? That works with ZM?

Re: Kodicom 8800 problem

Posted: Fri Feb 15, 2019 10:31 pm
by mastertheknife
A bit late but this also happened to me today, after upgrading my ZM box from CentOS6 to CentOS7.
The exact same error: "bttv: probe of 0000:06:08.0 failed with error -34"
I know for a fact that the card is fine because it has been working fine for years.
After many attempts with the options in bttv.conf, i found that its the combfilter option causing this error. Removing it got the card working!
So don't give up, its not your card, its just a newer kernel\driver.

Here is my /etc/modprobe.d/bttv.conf file that is currently working (after removing combfilter):

Code: Select all

# bttv module options
# For fast loading
options i2c-algo-bit bit_test=1
# The first bttv device is a pico2000 clone, the other 8 are a kodicom 8800 clone.
options bttv gbuffers=16 card=102,102,102,102,102,102,102,102 radio=0,0,0,0,0,0,0,0 tuner=4,4,4,4,4,4,4,4 chroma_agc=1 full_luma_range=1 coring=1

Re: Kodicom 8800 problem

Posted: Thu Oct 17, 2019 1:54 pm
by septry