TRENDnet TV-IP651W

Post here to indicate any hardware you have used and which is known to work with ZoneMinder. Not for questions.
Post Reply
tcalbrecht
Posts: 1
Joined: Fri Apr 18, 2014 8:47 pm

TRENDnet TV-IP651W

Post by tcalbrecht » Tue Nov 25, 2014 2:59 am

I'm trying to configure this IP camera with ZM. Here's the setup:

ZM 1.28.0 running on Ubuntu 14.04.1
I have installed the latest available firmware in the camera.

I configured the camera with the following parameters:

Code: Select all

General:
Name	TRENDnet
Source Type	Remote
Function	Monitor

Source:
Remote Protocol		HTTP
Remote Method	Simple
Remote Host Name	hteeteep://admin:password@192.168.1.111
Remote Host Port		8180
Remote Host Path		/video/mjpg.cgi
Target Colorspace		24 bit
Capture Width (pixels)	640
Capture Height (pixels)	480
Preserve Aspect Ratio	
Orientation	Normal
Deinterlacing	Disabled
I get a solid blue screen in ZM when I try to view the camera.

The video stream is visible in a browser using the above url.

After I activate the camera, I see the following in the ZM log:
2014-11-24 21:48:49.164950 zmc_m4 5394 ERR Invalid response status 401: Authorization Required zm_remote_camera_http.cpp 726
2014-11-24 21:48:49.086635 zmc_m4 5394 ERR Unable to get response zm_remote_camera_http.cpp 1110

Similar messages are in /var/log/syslog.

Any help would be appreciated. Thanks.
Tom

User avatar
kingofkya
Posts: 1111
Joined: Mon Mar 26, 2007 6:07 am
Location: Las Vegas, Nevada

Re: TRENDnet TV-IP651W

Post by kingofkya » Fri Dec 19, 2014 11:01 pm

SO you made the same mistake i did and updated the firmware.:(

ITs newer authentication system that the current releases of zm is not compatible with. IT requires the reciver to reply with a hashed login based on the salt(kinda like and encryption key) it send when it fails.

It prevents people from easely grabbing passwords off the network, because the browser send proof of work aka a md5 hash, rather than the real password, and the hash is different everytime.

Anyways the good newes is there is a patch in the git repo that fixes it, i haven't tried it yet though. https://github.com/ZoneMinder/ZoneMinder/pull/588

Post Reply

Who is online

Users browsing this forum: No registered users and 10 guests