Raspberry Pi Cam module Streaming RTSP h264 video to ZM

Post here to indicate any hardware you have used and which is known to work with ZoneMinder. Not for questions.
jteeuw
Posts: 5
Joined: Mon Jun 02, 2014 7:22 am

Re: Raspberry Pi Cam module Streaming RTSP h264 video to ZM

Post by jteeuw » Mon Jun 02, 2014 12:45 pm

Thanks for the info!

but when i run the code , i get a couple of second the cam on my monitor and the a stops with a error ( see screenshot)
Attachments
error01.jpg
error01.jpg (99.84 KiB) Viewed 3326 times

postfux
Posts: 20
Joined: Thu Mar 03, 2005 11:33 am
Location: Austria

Re: Raspberry Pi Cam module Streaming RTSP h264 video to ZM

Post by postfux » Tue Jun 03, 2014 6:53 am

Hi jteeuw

Sorry now i know what was wrong in my Tutorial. Pleas forget my last post.

Instead of starting:

Code: Select all

ffstream & 
it schould be

Code: Select all

sudo ffserver &
Once ffserver is running you should be able to start

Code: Select all

raspivid -b 5000000 -ex night -mm average -op 150 -t 999999999 -w 640 -h 360 -fps 5 -o - |ffmpeg -v verbose -i - -flags +global_header -vcodec copy -r 5 -an http://0.0.0.0:8554/feed1.ffm
I corrected also the Tutorial at the beginning.

Greetings Markus

jteeuw
Posts: 5
Joined: Mon Jun 02, 2014 7:22 am

Re: Raspberry Pi Cam module Streaming RTSP h264 video to ZM

Post by jteeuw » Tue Jun 03, 2014 7:21 am

hi Markus,

Thanks you for the info , but when i run

Code: Select all

sudo ffserver &
I get the following error :
Attachments
error2.jpg
error2.jpg (64.52 KiB) Viewed 3319 times

jteeuw
Posts: 5
Joined: Mon Jun 02, 2014 7:22 am

Re: Raspberry Pi Cam module Streaming RTSP h264 video to ZM

Post by jteeuw » Tue Jun 03, 2014 7:23 am

jteeuw wrote:hi Markus,

Thanks you for the info , but when i run

Code: Select all

sudo ffserver &
I get the following error :

Found it , i run the following code to correct it :

Code: Select all

sudo mkdir tmp2

postfux
Posts: 20
Joined: Thu Mar 03, 2005 11:33 am
Location: Austria

Re: Raspberry Pi Cam module Streaming RTSP h264 video to ZM

Post by postfux » Tue Jun 03, 2014 8:11 am

Hi jteeuw

Glad to hear that i could help you and that you got it running!

Greetings Markus

jteeuw
Posts: 5
Joined: Mon Jun 02, 2014 7:22 am

Re: Raspberry Pi Cam module Streaming RTSP h264 video to ZM

Post by jteeuw » Tue Jun 03, 2014 1:39 pm

Hi Markus,

The stream is visible in VLC but in zoneminder i get the following errors:
Attachments
error4.gif
error4.gif (132.09 KiB) Viewed 3310 times
error3.jpg
error3.jpg (253.73 KiB) Viewed 3310 times

postfux
Posts: 20
Joined: Thu Mar 03, 2005 11:33 am
Location: Austria

Re: Raspberry Pi Cam module Streaming RTSP h264 video to ZM

Post by postfux » Tue Jun 03, 2014 7:32 pm

Hi jteeuw

Sorry i don't have so deep knowledge about zoneminder.

Have you compiled ZM by yourself ore used a prebuild version?
Do you use a 64bit Linux version? I have not used it for ZM,
so maybe when compiling you need different settings.

Greetings Markus

Post Reply

Who is online

Users browsing this forum: No registered users and 3 guests