Axis M3114 works

Post here to indicate any hardware you have used and which is known to work with ZoneMinder. Not for questions.

Moderator: zoneminder

Posts: 9
Joined: Mon Apr 23, 2012 5:15 pm

Axis M3114 works

Postby cambot » Sat Apr 28, 2012 5:19 pm

I have 3 Axis M3114 cameras and I have them all working with h264 streaming with no errors!

My setup:

ubuntu server 12.04 LTS 32-bit

You *must* use Original ffmpeg. The libav ffmpeg that ubuntu supplies if you do apt-get install zoneminder will NOT work. It will appear to work for about 10-30 seconds, but then you'll get garbled data from the cameras into zoneminder. This took me forever to find!

The steps to get it installed:

1. Install the ubuntu-server from a CD. When it's time to pick what features you want, ONLY choose OpenSSH server. Do not install anything else.

2. Once the server is up and you can login, make sure you use the Jon Severinsson PPA to get the Original ffmpeg, before you do anything else. This way when you install zoneminder, it will use this and not attempt to grab the libav version of the packages. If you already installed libav, you will need to uninstall ALL of it in order for this to work. I had a hard time doing this, so I just wiped my server over and re-installed.

Here's what you type to get the Original ffmpeg installed:

Code: Select all

sudo apt-get install python-software-properties
sudo add-apt-repository ppa:jon-severinsson/ffmpeg
sudo apt-get update
sudo apt-get install -V ffmpeg

3. Now you can install zoneminder from packages. ubuntu-server 12.04 installs 1.25.0 currently.

Code: Select all

sudo apt-get install zoneminder

4. I setup a video streaming profile for each camera so I could reduce the image size to 800x600. But you can choose any size you want if you have disk space and cpu to handle it. The settings I chose are: h264, GOV Length 20, Variable Bit rate. In my example the stream profile is named "zmprofile".

5. Configure Zoneminder options. On the Images tab, set the following:

Code: Select all

FFMPEG_INPUT_OPTIONS: "-rtsp_flags filter_src -an"

4. Configure Zoneminder as usual. When it comes time to configure the cameras, choose the Axis h264 ffmpeg preset.

In the Source Path field, is where you put the URL that ffmpeg uses. Here's what I use:

Code: Select all


In this case, replace user with your camera's username, password with the password, camera.mynet with the IP address or hostname of your camera.

5. You will likely need to stop and then stop Zoneminder for all of the settings to take, not just "restart".

Posts: 342
Joined: Thu Jul 06, 2006 2:27 pm

Re: Axis M3114 works

Postby Flasheart » Sun Apr 29, 2012 6:25 am

Thanks for the update Cambot - hopefully it'll be useful to other ubuntu users. Surprised about the ffmpeg bit though, not heard of that before.

Return to “Hardware Compatibility List”

Who is online

Users browsing this forum: No registered users and 1 guest