ACTi Got MJPEG stream working

Post here to indicate any hardware you have used and which is known to work with ZoneMinder. Not for questions.
Post Reply
User avatar
kp4djt
Posts: 212
Joined: Mon Jun 18, 2007 1:53 am
Location: Tampa, FL
Contact:

ACTi Got MJPEG stream working

Post by kp4djt » Sun Sep 19, 2010 11:25 pm

Folks,
ACTi has a mjpeg stream using the following format:
http://login:pwd@address:port/cgi-bin/cmd/encoder?GET_STREAM
I have it on a ACM-5611. You need to update the firmware to the latest:
Firmware Version = A1D-220-V3.12.13-AC

Here is my setup under the source tab:

Code: Select all

Source>General
Name	                          Monitor-10
Source Type	                   Remote
Function	                     Monitor
Enabled	                       [/]
Linked Monitors 	
Maximum FPS	                   5
Alarm Maximum FPS	           10
Reference Image Blend %ge	   7
Triggers	                  None available

Source>source
Remote Protocol	                  HTTP
Remote Method	                  Simple
Remote Host Name	          admin:123456@192.168.7.200
Remote Host Port	                  80
Remote Host Path	                  cgi-bin/cmd/encoder?GET_STREAM
Remote Image Colors	          24 bit color
Capture Width (pixels)	          1280
Capture Height (pixels)	            720
Preserve Aspect Ratio	
Orientation                             Normal

Here is the settings that count in the camera
Video Settings:
Camera Name 	        ACTi-1
Streaming Method 	TCP only
B2 Frame Enable 	        [ ]
Audio In 	                disabled
Resolution 	                1280x720
Frame Rate Mode 	        Constant
Frame Rate 	                10
Encoder Type 	        MJPEG
Video Quality  	        [50]     (1 ~ 100) 	
Video Control Port 	[6001    ]
Video Streaming Port 	[6002    ]
Now if I can just figure out why this camera causes high load rates when
I use MPEG4, see my post in the hardware questions about this.
Chuck Hast -- KP4DJT --
Web site www.wchast.com
ZM demo www.wchast.com/zm

mrd
Posts: 255
Joined: Wed Apr 26, 2006 12:39 am
Location: Boston USA

Post by mrd » Fri Jan 14, 2011 1:36 am

I can' seem to get this to work? I've verified the same settings, but my monitor just keeps showing a blank image. I can see the stream in my browser fine. I'm wondering if I need to change any of the ZM "options" to support this, but I have another IP camera setup that is stream mjpeg fine.
MRD

User avatar
kp4djt
Posts: 212
Joined: Mon Jun 18, 2007 1:53 am
Location: Tampa, FL
Contact:

Post by kp4djt » Fri Jan 14, 2011 3:26 am

What camera are you using, and what is the firm ware rev. When I purchased the ACM-5611N, I had to update the firmware in order to get the mjpeg stream.
Chuck Hast -- KP4DJT --
Web site www.wchast.com
ZM demo www.wchast.com/zm

mrd
Posts: 255
Joined: Wed Apr 26, 2006 12:39 am
Location: Boston USA

Post by mrd » Fri Jan 14, 2011 4:05 pm

I'm using a ACM-4001 and it has the latest firmware on it. I am able to view the mjpeg stream from my browser just fine, but could not get it to work in ZM. I was finally able to get the RTSP streaming to work and it seems fine, but I would like to go back to mjpeg if it works.
MRD

User avatar
kp4djt
Posts: 212
Joined: Mon Jun 18, 2007 1:53 am
Location: Tampa, FL
Contact:

Post by kp4djt » Sat Jan 15, 2011 1:40 am

If your software is up to date you should be able to do the following, changing the login/password data to that in your camera along with the address of course:
admin:123456@192.168.7.200/cgi-bin/cmd/encoder?GET_STREAM

If you have changed the port then you need to make sure that is in there, here is a example:

admin:123456@192.168.7.200:8080/cgi-bin/cmd/encoder?GET_STREAM

I am using port 80 which of course is the standard port. If I access my camera from the browser using this method I will see the mjpeg stream just fine. You do need to make sure it is turned on in the camera, I am having my repaired (the day/night shutter was not working correctly). so I can not get you a snapshot of the setup screen. But there is info on the web site about pulling such a stream.
Chuck Hast -- KP4DJT --
Web site www.wchast.com
ZM demo www.wchast.com/zm

Post Reply

Who is online

Users browsing this forum: No registered users and 4 guests