Search found 1340 matches

by asker
Tue Sep 22, 2015 6:53 pm
Forum: ZoneMinder 1.28.x
Topic: Set function from API does not work
Replies: 50
Views: 14967

Re: Set function from API does not work

marcolino7 wrote:Hi Asker,
I tried to create a cron job executed every 5 minutes, but cookies.txt was not created.
Do you have any suggestion?

Regards
Make sure you specify a path for cookies.txt so you know where it is being created and its writable
by asker
Tue Sep 22, 2015 1:08 pm
Forum: ZoneMinder 1.28.x
Topic: Set function from API does not work
Replies: 50
Views: 14967

Re: Set function from API does not work

You use curl for the APIs exactly like you did above Step 1) You need to authenticate with ZM curl -c cookies.txt -d "username=xxxx&password=yyyy&action=login&view=console" http://yourZMIP/zm/index.php Step 2) Use the authentication information along with your desired API. Example curl -b cookies.tx...
by asker
Tue Sep 22, 2015 11:34 am
Forum: ZoneMinder 1.28.x
Topic: Set function from API does not work
Replies: 50
Views: 14967

Re: Set function from API does not work

Okay great. This is with OPT_AUTH enabled correct?
If so, your API security is working fine
marcolino7 wrote:Hi Asker,
1st of your command created coockies.txt and second command produced this output:

Code: Select all

{
    "version": "1.28.102",
    "apiversion": "1.28.102.1"
}
by asker
Tue Sep 22, 2015 10:43 am
Forum: ZoneMinder 1.28.x
Topic: Set function from API does not work
Replies: 50
Views: 14967

Re: Set function from API does not work

There is a problem here. Your security for APIs are not working (both bbunge and marco) Can you please do this. Please follow each step and please confirm that you have performed all the steps below in your response. 1. Enable OPT_AUTH in ZM, log out of ZM 2. Launch a terminal 3. Change directory to...
by asker
Mon Sep 21, 2015 6:13 pm
Forum: ZoneMinder 1.28.x
Topic: Set function from API does not work
Replies: 50
Views: 14967

Re: Set function from API does not work

Marco, please do the following: 1. Please restart your ubuntu server 2. Open up a browser, log into ZM. Open up a new tab in the same browser and please paste the response you get for http://server/zm/api/host/getVersion.json (replace server) - I'd like to see the exact message 3. Open up ZM, disabl...
by asker
Mon Sep 21, 2015 2:21 pm
Forum: ZoneMinder 1.28.x
Topic: Set function from API does not work
Replies: 50
Views: 14967

Re: Set function from API does not work

Did you follow this part of the guide at https://github.com/pliablepixels/zmNinja/wiki/Configuring-ZoneMinder-with-API Edit /usr/share/zoneminder/www/api/app/Config/core.php Around line 218 you will see this: Configure::write('Session', array( 'defaults' => 'php' )); change it to Configure::write('S...
by asker
Fri Sep 18, 2015 8:32 pm
Forum: ZoneMinder 1.28.x
Topic: web authentication persistence
Replies: 2
Views: 907

Re: web authentication persistence

Hello, not absolutely sure what you are after is the answer I am about to give, but is your problem that you want to keep your 'Montage View' on without having to manually re-authenticate? There are two options: 1) You add a &user=xxx&pass=yyyy to the http url for streaming. For example, if you ever...
by asker
Thu Sep 17, 2015 4:42 pm
Forum: ZoneMinder 1.28.x
Topic: Set function from API does not work
Replies: 50
Views: 14967

Re: Set function from API does not work

Hi,
bbunge posted instructions on how to install zoneminder-master for ubuntu for both 14.x and 15.x
Please see here
http://www.zoneminder.com/forums/viewto ... 32&t=23375
by asker
Wed Sep 16, 2015 4:34 pm
Forum: ZoneMinder 1.28.x
Topic: Set function from API does not work
Replies: 50
Views: 14967

Re: Set function from API does not work

Hi Marco, I don't believe Debian has a distribution that automatically installs the API correctly. You can compile from source, but I won't be able to guide you since I don't use Debian Hope 1) works for you. Hi asker, i tried to install a new server with latest version of the ZM and API using instr...
by asker
Wed Sep 16, 2015 2:52 pm
Forum: ZoneMinder 1.28.x
Topic: Set function from API does not work
Replies: 50
Views: 14967

Re: Set function from API does not work

Looks like you are running an old version of the APIs. There are two ways to handle this: 1) Stick with the current version you have and restart ZM after you change monitor mode from your side. I think the API for that is http://zoneminder/zm/api/states/change/restart.json Try it from command line f...
by asker
Wed Sep 16, 2015 1:56 pm
Forum: ZoneMinder 1.28.x
Topic: Set function from API does not work
Replies: 50
Views: 14967

Re: Set function from API does not work

The Controller for this is MonitorsController.php inside the API directory. If I recall correctly, the monitor is not restarted when you edit the mode. Take a look at daemonControl inside that file - you will probably need to restart that monitor. Once you test and have it working, consider doing a ...
by asker
Tue Sep 15, 2015 7:54 pm
Forum: ZoneMinder 1.28.x
Topic: Cannot create JPEGs with v1.28.1/Ubuntu 14.04/FI8918W
Replies: 13
Views: 2428

Re: Cannot create JPEGs with v1.28.1/Ubuntu 14.04/FI8918W

Okay, I have the same camera. So let's see if I can help. Questions (not all of them may be directly relevant to your problem) 1. Launch a terminal and let me know the output of df -h 2. Please post a screenshot of how you have configured the camera in ZM - please post an image of the General/Source...
by asker
Mon Sep 14, 2015 6:40 pm
Forum: ZoneMinder 1.28.x
Topic: Cannot create JPEGs with v1.28.1/Ubuntu 14.04/FI8918W
Replies: 13
Views: 2428

Re: Cannot create JPEGs with v1.28.1/Ubuntu 14.04/FI8918W

Before we debug other aspects, can you try the following instead of snapshot.cgi


General Tab:
Source Type: FFMpeg

Source Tab:
Source Path:
http://camip/videostream.cgi?user=xxx&pwd=yyy (replace xxx/yyy/camip)

Remote Method:
RTP/RTP/HTTP

colorspace: 24bit

Width/Height:640x480
by asker
Wed Sep 02, 2015 6:13 pm
Forum: ZoneMinder 1.28.x
Topic: XML
Replies: 2
Views: 725

Re: XML

The (currently) 2nd post when you search for "force classic" in this forum might help Hi all, I recently installed Zoneminder 1.28.1 (on LinuxMint 17.2 Rafaela 64bit) and successfully got it up and running. I was rather foolishly tweaking the settings and in the "General" settings went to change the...