Search found 62 matches

by raydude
Mon Nov 13, 2017 4:53 pm
Forum: ZoneMinder 1.30.x
Topic: Upgrade from 0.28 to 0.30 failed.
Replies: 2
Views: 734

Re: Upgrade from 0.28 to 0.30 failed.

Just realized the problem. zmupdate.pl is updating to 0.28.1, not 0.30.2...

zmupdate.pl

Database already at version 1.28.1, update aborted.

Don't know why though...
by raydude
Mon Nov 13, 2017 4:50 pm
Forum: ZoneMinder 1.30.x
Topic: Upgrade from 0.28 to 0.30 failed.
Replies: 2
Views: 734

Upgrade from 0.28 to 0.30 failed.

I hope someone can help. I'm lost and my cameras aren't running: Nov 13 08:49:21 server zmdc[16690]: ERR ['zma -m 1' exited abnormally, exit status 255] Nov 13 08:49:21 server undef[16911]: ERR [Config mismatch, expected 218 items, read 216. Try running 'zmupdate.pl -f' to reload config.] Nov 13 08:...
by raydude
Thu Jun 29, 2017 7:38 am
Forum: ZoneMinder 1.30.x
Topic: ZM is filling /dev/shm
Replies: 3
Views: 1435

Re: ZM is filling /dev/shm

I should mention the big camera is also 1080P...
by raydude
Thu Jun 29, 2017 7:38 am
Forum: ZoneMinder 1.30.x
Topic: ZM is filling /dev/shm
Replies: 3
Views: 1435

Re: ZM is filling /dev/shm

For those who find themselves in this situation. I have two 1080P cameras setup with ffmpeg, they are the 475M listings in /dev/shm. The 211M is a 720P camera with ffmpeg. The 3.9G camera is setup as "remote" rtsp and apparently requires a huge amount of shared memory. I'll try to configure it as ff...
by raydude
Thu Jun 29, 2017 1:16 am
Forum: ZoneMinder 1.30.x
Topic: ZM is filling /dev/shm
Replies: 3
Views: 1435

ZM is filling /dev/shm

Why does it do this? How can I stop it? server ~ # df -h /dev/shm Filesystem Size Used Avail Use% Mounted on shm 7.6G 7.6G 0 100% /dev/shm server ~ # ls /dev/shm squid-cf__metadata.shm squid-cf__readers.shm zm.mmap.2 zm.mmap.4 squid-cf__queues.shm zm.mmap.1 zm.mmap.3 server ~ # ls /dev/shm squid-cf_...
by raydude
Sat Dec 17, 2016 9:22 am
Forum: ZoneMinder 1.29.x
Topic: php errors on webui (gentoo) zoneminder 1.9.1
Replies: 7
Views: 3401

Re: php errors on webui (gentoo) zoneminder 1.9.1

I fixed this by changing the routine to this: function getDiskPercent() { $total = disk_total_space(ZM_PATH_WEB.'/'.ZM_DIR_EVENTS); if ( ! $total ) { Error("disk_total_space returned false for " . ZM_PATH_WEB.'/'.ZM_DIR_EVENTS ); return 0; } $free = disk_free_space(ZM_PATH_WEB.'/'.ZM_DIR_EVENTS); if...
by raydude
Thu Feb 18, 2016 7:11 pm
Forum: ZoneMinder 1.28.x
Topic: Problems with event directory
Replies: 6
Views: 2552

Re: Problems with event directory

Thanks for trying. I know about ownership needing to be apache:apache. It's not the upgrade that kills the videos. The videos do not get written when there is a symlink or I use the mounted folders. They simply do not write. There is no error message, just messages about the files disappearing and t...
by raydude
Tue Feb 16, 2016 4:38 pm
Forum: ZoneMinder 1.28.x
Topic: Problems with event directory
Replies: 6
Views: 2552

Re: Problems with event directory

Here's the lines in the fstab that I used. /mnt/raid6/zoneminder/events /usr/share/zoneminder/www/events none defaults,bind 0 2 /mnt/raid6/zoneminder/images /usr/share/zoneminder/www/images none defaults,bind 0 2 Please note: when gentoo installs zoneminder it puts symlinks from /usr/share/zoneminde...
by raydude
Tue Feb 16, 2016 4:35 pm
Forum: ZoneMinder 1.28.x
Topic: Problems with event directory
Replies: 6
Views: 2552

Re: Problems with event directory

You are talking about this: https://wiki.zoneminder.com/Using_a_ded ... Hard_Drive

I followed that, it does not work. Once I implement that, all existing recordings go away and new ones won't happen.

I think there's something else going on.
by raydude
Mon Feb 15, 2016 6:36 pm
Forum: ZoneMinder 1.28.x
Topic: Problems with event directory
Replies: 6
Views: 2552

Problems with event directory

I've been suffering with a problem for quite some time and I've isolated it down to one issue, but I don't understand the cause. I'm running Gentoo, ZM 1.28.1 and its working great on an mpeg4 1080P camera, as long as I allow the events to be stored on my ssd in the same folder as the zoneminder www...
by raydude
Sun Oct 18, 2015 12:59 am
Forum: ZoneMinder 1.28.x
Topic: modect stopped working
Replies: 8
Views: 1456

Re: modect stopped working

Whelp. I completely blew it away, including /usr/share/zoneminder, the database, /var/lib/zoneminder, etc. gentoo puts symlinks for events and images in the usr/share/zoneminder/www folder that links to /var/lib/zoneminder/events and /var/lib/zoneminder/images. Those files were not automatically cre...
by raydude
Sun Sep 27, 2015 11:04 pm
Forum: ZoneMinder 1.28.x
Topic: modect stopped working
Replies: 8
Views: 1456

Re: modect stopped working

Thanks for the help. My answers: 1) 1.28.1. Originally I installed from source on my gentoo linux server, but since it stopped working (similar symptoms) I removed the database and installed from ebuild since 1.28.1 is now in portage. 2) emerge zoneminder From the web console: "ZoneMinder Console - ...
by raydude
Sat Sep 26, 2015 9:19 pm
Forum: ZoneMinder 1.28.x
Topic: modect stopped working
Replies: 8
Views: 1456

Re: modect stopped working

I'm really stuck. Permissions seem okay. I think the real problem is zms is crashing, I don't even know what the process is called, but there is no zms running as can be seen here: ps -ef | grep zm apache 20064 1 0 Sep25 ? 00:00:22 /usr/bin/perl -wT /usr/bin/zmdc.pl startup apache 20108 20064 2 Sep2...
by raydude
Sat Sep 26, 2015 2:40 am
Forum: ZoneMinder 1.28.x
Topic: modect stopped working
Replies: 8
Views: 1456

Re: modect stopped working

Here's zmfilter.log which shows it deleting the events. 09/25/2015 19:26:39.967747 zmfilter[16015].INF [Deleting event 162] 09/25/2015 19:26:39.968593 zmfilter[16015].INF [Deleting event 163] 09/25/2015 19:26:39.969448 zmfilter[16015].INF [Deleting event 164] It's had 164 events but none of them wer...
by raydude
Sat Sep 26, 2015 2:37 am
Forum: ZoneMinder 1.28.x
Topic: modect stopped working
Replies: 8
Views: 1456

Re: modect stopped working

More information: zmc_m1 and zmc_m2 are running fine. It is alarming, as evidence in zma_m1.log, but later, the pictures aren't found and the alarm is deleted. It looks like it can't write the files out to the drive. I'll keep hunting. Here's a snip of one of the zma logs: 09/25/15 19:26:24.260909 z...